Package Details: android-x86-64-libiconv 1.16-2

Git Clone URL: https://aur.archlinux.org/android-x86-64-libiconv.git (read-only, click to copy)
Package Base: android-x86-64-libiconv
Description: Provides libiconv.so and libcharset.so (Android x86-64)
Upstream URL: http://www.gnu.org/software/libiconv/
Licenses: LGPL
Conflicts: android-libiconv-x86_64
Replaces: android-libiconv-x86_64
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 0
Popularity: 0.000000
First Submitted: 2019-09-18 16:09
Last Updated: 2020-03-05 17:59

Latest Comments

Martchus commented on 2020-03-02 16:29

I need to port this package to use the android-environment (which wasn't available at the time I've created that package). In the mean time you can simply fix the _android_toolchain variable at the top of the PKGBUILD.

CapSel commented on 2020-03-01 02:25

from config.log:

clang: error: unknown target triple 'x86-64-linux-android', please use -triple or -arch

CapSel commented on 2020-03-01 02:23

Fails to compile:

==> Making package: android-x86-64-libiconv 1.16-1 (nie, 1 mar 2020, 03:17:55)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading libiconv-1.16.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 5045k  100 5045k    0     0  1417k      0  0:00:03  0:00:03 --:--:-- 1417k
==> Validating source files with sha256sums...
    libiconv-1.16.tar.gz ... Passed
==> Extracting sources...
  -> Extracting libiconv-1.16.tar.gz with bsdtar
==> Starting build()...
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for x86-64-linux-android-strip... /opt/android-ndk/toolchains/x86-64-linux-android-4.9/prebuilt/linux-x86_64/bin/x86-64-linux-android-strip
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make sets $(MAKE)... (cached) yes
checking for x86-64-linux-android-gcc... /opt/android-ndk/toolchains/llvm/prebuilt/linux-x86_64/bin/clang
checking whether the C compiler works... no
configure: error: in `/tmp/android-x86-64-libiconv-13653191386321348014/android-x86-64-libiconv/src/libiconv-1.16':
configure: error: C compiler cannot create executables
See `config.log' for more details
==> ERROR: A failure occurred in build().
    Aborting...
aura >>= There was a makepkg failure.