Package Details: andyetitmoves 1.2.2-3

Git Clone URL: https://aur.archlinux.org/andyetitmoves.git (read-only)
Package Base: andyetitmoves
Description: physics-based platform game (full version)
Upstream URL: http://www.andyetitmoves.net/
Licenses: custom:shareware
Submitter: jose1711
Maintainer: jose1711
Last Packager: jose1711
Votes: 25
Popularity: 0.000080
First Submitted: 2010-09-04 20:15
Last Updated: 2015-07-28 10:50

Required by (0)

Sources (1)

  • andyetitmoves.desktop

Latest Comments

C5OK5Y commented on 2013-06-28 10:44

Thanks.

jose1711 commented on 2013-06-28 10:43

thank you, disowned

C5OK5Y commented on 2013-06-28 08:11

Sure!

jose1711 commented on 2013-06-28 07:51

@C5OK5Y: i appreciate your comments however i currently do not have time to fix the pkgbuild. wanna adopt?

C5OK5Y commented on 2013-06-28 07:33

After more reading about the FSH, putting the (static) game data in /usr/share seems to be better than /opt (but /usr/share/games is even better).

C5OK5Y commented on 2013-06-27 20:40

The PKGBUILD has several issues:
1) (this one prevents successful building) Line 62:
/bin/tar cf - * | ( cd ../../pkg/usr/share/AndYetItMoves/; tar xfp - ) should be
/bin/tar cf - * | ( cd "${pkgdir}/usr/share/AndYetItMoves/"; tar xfp - )
2) There are multiple occurrences of unquoted variables, which may contain file paths with spaces - if someone tries to build the package from a directory path which contains spaces, the whole thing will blow up.
3) There is no need for the lib32-* packages on x86_64.
4) Line 59 is unnecessary.
--
5) I *think* that the game files should be in /opt/AndYetItMoves/ instead of /usr/share/AndYetItMoves/. The FSH says that /usr/share is for "Architecture-independent (shared) data." but /opt is for "Optional application software packages.".

caemir commented on 2013-05-17 14:51

...././PKGBUILD: ligne 62 : cd: ../../pkg/usr/share/AndYetItMoves/: Aucun fichier ou dossier de ce type

Marvn commented on 2012-02-03 16:27

the lib32-* libs are indeed not longer needed for x86_64 users

Marvn commented on 2012-02-03 16:25

the lib32-* libs are indeed not longer needed for x86_64 users...

Kwpolska commented on 2011-12-20 17:01

The files (at least for the HIB) are now andyetitmoves-1.2.2-1_arch.tar.gz.
gadget3000's problem no longer occurs. Changed parts:       ^^

Kwpolska commented on 2011-12-20 16:57

The files (at least for the HIB) are now andyetitmoves-1.2.2-1_arch.tar.gz.
Please fix it. Changed parts: ^^

jose1711 commented on 2011-12-19 19:46

is your arch 64bit? cause i have not really tested it.. :-/

gadget3000 commented on 2011-12-19 17:23

I keep getting this error when building:
tar: Skipping to next header
tar: A lone zero block at 144251
tar: Exiting with failure status due to previous errors

If I then force it to ignore this with '|| return 0', then I get the error:
install: cannot stat `icons/48x48.png': No such file or directory
Because the icons folder no longer exists.

SataMaxx commented on 2011-10-05 18:23

You should add these dependancies for x86_64 : lib32-libpng12, lib32-libvorbis, lib32-sdl_image

mrozanc commented on 2011-08-19 21:42

sdl should be added as a dependency.

mrozanc commented on 2011-08-14 10:49

@jose1711: yes, the problem is that I had to recompile lib32-openal with abs. I don't know why.

jose1711 commented on 2011-08-13 19:47

please see related topic at http://andyetitmoves.net/forum/index.php?topic=2155

jose1711 commented on 2011-08-13 18:25

@Skunnyk: right. the filesize is slightly different, but the contents is the same. technically, it seems there is no 64bit version at all :-/

Skunnyk commented on 2011-08-13 16:39

For 64bits, you should add lib32-mesa, lib32-sdl, lib32-sdl_image, lib32-libpng12 (from aur)
Note: There is a 64bits version on the humblebundle.com download page, but it's the same files as in 32bits tarball…

jose1711 commented on 2011-08-13 14:59

@Chinoisfurax: i should add lib32-libpng12 to deps for 64bit arch then, correct?

mrozanc commented on 2011-08-13 12:58

I had to compile again lib32-libpng12 and lib32-openal (via abs) to play with the sound.

I had:
$ AndYetItMoves
./lib/AndYetItMoves: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

then

$ AndYetItMoves
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
AL lib: alsa.c:512: Could not open playback device 'default': No such device or address
AL lib: oss.c:169: Could not open /dev/dsp: No such file or directory

but the links already existed.

jose1711 commented on 2011-08-12 20:18

thank you - missing x86_64 dependencies added. pkgbuild now also accepts HIB key for those who purchased it during HIB #3. please test and report any encountered problems.

Anonymous comment on 2011-08-12 18:04

And lib32-openal for the sound

Anonymous comment on 2011-08-12 18:02

For x86_64, it depends on lib32-libtheora

jose1711 commented on 2011-08-12 12:23

@Enverex: i'll take a closer look during this weekend. thanks for suggesting it

Enverex commented on 2011-08-12 10:54

Any chance of an update to the PKGBUILD that lets the user specify the package location if it's not in the source folder? See (http://aur.archlinux.org/packages/cortexcommand/PKGBUILD) for an example.

jose1711 commented on 2011-08-06 19:24

@freethebee: thank you for letting me know that. updated.

Anonymous comment on 2011-08-06 16:53

Hi, perhaps openal should be added as a dependency. I had some problems getting any sound, but openal fixed it.

gadget3000 commented on 2011-07-27 07:38

Here is a PKGBUILD for 1.2.0: http://underrun.org/~gadget/PKGBUILDandyetitmoves

gadget3000 commented on 2011-07-27 07:16

This already exists as 'ayim' http://aur.archlinux.org/packages.php?ID=39485

jose1711 commented on 2011-07-26 21:17

@intgr: new HIB??! awesome. let me first buy it so i can test it on my own. thanks for letting me know that. jose

intgr commented on 2011-07-26 20:04

Please update it to 1.2.0, the version included in Humble Indie Bundle #3: http://www.humblebundle.com/

I changed these lines and it worked for me:

pkgver=1.2.0
[ "$CARCH" = "x86_64" ] && source=(${source[@]} "AndYetItMoves-${pkgver}_x86_64.tar.gz")
[ "$CARCH" = "x86_64" ] && md5sums=(${md5sums[@]} '2a6f12fe44f79481fa19ad15dc4309a6')