Package Details: angrydd 1.0.1-6

Git Clone URL: https://aur.archlinux.org/angrydd.git (read-only)
Package Base: angrydd
Description: "Angry, Drunken Dwarves" is a classic "falling blocks" puzzle game
Upstream URL: http://www.sacredchao.net/~piman/angrydd/
Licenses: GPL, custom
Submitter: None
Maintainer: mikesd
Last Packager: mikesd
Votes: 4
Popularity: 0.000000
First Submitted: 2006-03-15 04:25
Last Updated: 2015-06-21 10:10

Latest Comments

mikesd commented on 2010-12-26 07:15

Fixed. Not giving the same error it was last time I tried to update it to python2.

dzaragoza commented on 2010-12-24 03:07

Please make the following change:

Given the change of the python 2.x interpreter to python2, it is necessary to change the first line of the python program at /usr/bin/angrydd from:

#!/usr/bin/env python

to

#!/usr/bin/env python2

Otherwise the game won't start, giving this error:

File "/usr/bin/angrydd", line 37
""" %(
^
SyntaxError: invalid syntax

Regards

dzaragoza commented on 2010-12-24 03:06

Please make the following change:

Given the change of the python 2.x interpreter to python2, it is necessary to change the first line of the python program at /usr/bin/angrydd from:

#!/usr/bin/env python

to

#!/usr/bin/env python

Otherwise the game won't start, giving this error:

File "/usr/bin/angrydd", line 37
""" %(
^
SyntaxError: invalid syntax

Regards

mikesd commented on 2010-11-29 10:05

Hmmmm, currently this is giving an error when run even when adjusted to use python2:

$ pkg/usr/bin/angrydd
Traceback (most recent call last):
File "pkg/usr/bin/angrydd", line 62, in <module>
from constants import *
ImportError: No module named constants

Not sure if this is a Python 2.7 issue or something to do with pygame. Looking into it.

mikesd commented on 2010-11-29 09:20

Hmmmm, currently this is giving an error when run even when adjusted to use python2:

$ pkg/usr/bin/angrydd
Traceback (most recent call last):
File "pkg/usr/bin/angrydd", line 62, in <module>
from constants import *
ImportError: No module named constants

Not sure if this is a Python 2.7 issue or something to do with pygame. Looking into it.

miffe commented on 2010-11-27 16:45

==> ERROR: Invalid syntax for optdepend : 'psyco (improved loading times)'