Package Details: animdl-git r366.fd3277f-1

Git Clone URL: https://aur.archlinux.org/animdl-git.git (read-only, click to copy)
Package Base: animdl-git
Description: highly efficient anime downloader and streamer
Upstream URL: https://github.com/justfoolingaround/animdl
Licenses: GPL3
Conflicts: animdl
Provides: animdl
Submitter: mnabid
Maintainer: None
Last Packager: TrialnError
Votes: 3
Popularity: 0.000012
First Submitted: 2021-08-12 05:17 (UTC)
Last Updated: 2023-06-28 19:48 (UTC)

Latest Comments

TrialnError commented on 2023-06-28 19:49 (UTC)

Feel free to adopt the package Porous3247.
I took your changes and applied them. At least most of them. Your custom pkgver wouldn't produce any output.

Porous3247 commented on 2023-05-12 23:18 (UTC) (edited on 2023-05-12 23:20 (UTC) by Porous3247)

Updated PKGBUILD:

# Maintainer: Nafis <mnabid.25@outlook.com>
# Contributor: Porous3247 <pqtb3v7t at jasonyip1 dot anonaddy dot me>

_pkgname=animdl
pkgname="${_pkgname}-git"
pkgver=1.7.12
pkgrel=1
pkgdesc="A highly efficient anime downloader and streamer"
arch=('any')
url="https://github.com/justfoolingaround/animdl"
license=('GPL3')
depends=('anitopy'
         'python'
         'python-anchor-kr'
         'python-click'
         'python-cssselect'
         'python-httpx'
         'python-lxml'
         'python-packaging'
         'python-pkginfo'
         'python-pycryptodomex'
         'python-regex'
         'python-requests'
         'python-rich'
         'python-tqdm'
         'python-yaml'
         'python-yarl')
makedepends=('git'
             'python-poetry-core'
             'python-build'
             'python-installer'
             'python-wheel')
optdepends=(
    'mpv: streaming support'
    'vlc: streaming support'
    'fzf: fuzzy finder support'
    'python-pypresence: Discord RPC'
)
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("git+${url}.git")
md5sums=('SKIP')

pkgver() {
    cd "${srcdir}/${_pkgname}/${_pkgname}/core"
    printf "%s.r%s.%s" \
        "$(grep -o '[0-9.]\+' __version__.py)" \
        "$(git log --oneline HEAD ^$(git rev-list -1 HEAD __version__.py) | wc -l)" \
        "$(git rev-parse --short HEAD)" \
        | sed "s/\.r0\..\+//"
}

prepare () {
    git -C "${srcdir}/${_pkgname}" clean -dfx
}

build () {
    cd "${srcdir}/${_pkgname}"
    python -m build --wheel --no-isolation
}

package() {
    cd "${srcdir}/${_pkgname}"
    python -m installer --destdir="${pkgdir}" dist/*.whl
}

TroubleClef commented on 2023-01-03 21:46 (UTC)

The project doesn't supply the setup.py file anymore, and the installation command needs to be changed to pip install. Thank you for the package!

talleyhoe commented on 2022-12-06 00:32 (UTC) (edited on 2022-12-06 00:32 (UTC) by talleyhoe)

Hey -- Could you add python-pip as a dependency? It's a dependency for animdl update. Great package btw

mnabid commented on 2022-07-02 08:59 (UTC)

@Farzat Thanks for the package. I added it to the dependency list.

Farzat commented on 2022-06-26 10:29 (UTC)

This project now requires python-anchor-kr as a dependency. I created an AUR package python-anchor-kr-git which provides that.