Package Details: anki-git r1940.9396d74-1

Git Clone URL: https://aur.archlinux.org/anki-git.git (read-only, click to copy)
Package Base: anki-git
Description: Helps you remember facts (like words/phrases in a foreign language) efficiently
Upstream URL: http://ankisrs.net/
Keywords: anki memorise memory study
Licenses: AGPL3
Conflicts: anki, anki20
Provides: anki
Submitter: degeberg
Maintainer: None
Last Packager: zandimna
Votes: 19
Popularity: 0.034416
First Submitted: 2017-02-12 11:51
Last Updated: 2019-06-05 21:46

Pinned Comments

zandimna commented on 2019-02-13 12:19

@misc Apparently this is reporting an error due to a module change for a workaround, add " from PyQt5.QtWebEngineWidgets import * " to the file /usr/share/anki/aqt/webview.py

Please leave a comment for any further errors

Latest Comments

1 2 Next › Last »

MartinX3 commented on 2020-09-24 16:57

Seems like the developers of anki doesn't provide a way to generate their provided binary bundle. It's only possible to run anki directly from code, which makes it impossible (?) to write an installation routine.

MartinX3 commented on 2020-08-23 10:56

Broken

==> Beginne pkgver()... ==> Aktualisierte Version: anki-git r5005.13476503-1 ==> Beginne build()... -> Building UI /var/tmp/pamac-build-martin/anki-git/PKGBUILD: Zeile 34: ./tools/build_ui.sh: Datei oder Verzeichnis nicht gefunden ==> FEHLER: Ein Fehler geschah in build(). Breche ab...

nikos commented on 2019-10-07 14:48

When I try to start Anki, I unfortunately get the following error: python3: relocation error: /usr/lib/python3.7/site-packages/PyQt5/Qt/plugins/platforms/../../lib/libQt5XcbQpa.so.5: symbol _ZN20QPlatformIntegration11screenAddedEP15QPlatformScreenb version Qt_5_PRIVATE_API not defined in file libQt5Gui.so.5 with link time reference Do you maybe have an idea how to fix it? Thank you very much!

EDIT: I fixed the problem. Removing the folder usr/lib/python3.7/site-packages/PyQt5/Qt solved it.

zandimna commented on 2019-02-13 12:19

@misc Apparently this is reporting an error due to a module change for a workaround, add " from PyQt5.QtWebEngineWidgets import * " to the file /usr/share/anki/aqt/webview.py

Please leave a comment for any further errors

misc commented on 2019-02-10 19:31

Unfortunately, pyqt5 kills support for the required QtWebEngine with today's 5.12.

e: Ah, it's "just" separated out into the new python-pyqtwebengine package. Inverted commas since it's still crashing with "'QWebEngineView' is not defined" for me.

zandimna commented on 2018-11-13 10:06

Updated it according to current Makefile. It should build now.

linkmauve commented on 2018-07-27 12:29

Hi, please pull this repository: https://git.linkmauve.fr/linkmauve/anki-git

I fixed all issues happening when installing Anki; it still doesn’t run though, because it requires Qt 5.9 and ArchLinux provides 5.11.

DarkShadow44 commented on 2018-05-26 13:09

Still doesn't build.

DarkShadow44 commented on 2018-04-12 21:21

Doesn't build anymore. mv: cannot stat 'tools/runanki.system': No such file or directory

prometheus commented on 2018-02-19 21:52

Gives following error when started:

Traceback (most recent call last):

  File "/usr/bin/anki", line 6, in <module>

    import aqt

  File "/usr/share/anki/aqt/__init__.py", line 14, in <module>

    from aqt.qt import *

  File "/usr/share/anki/aqt/qt.py", line 44, in <module>

    raise Exception("Qt 5.10 is known to be buggy.")

Exception: Qt 5.10 is known to be buggy.