Package Details: any-dl 0.22.0-1

Git Clone URL: https://aur.archlinux.org/any-dl.git (read-only)
Package Base: any-dl
Description: Generic video downloader for principially any site.
Upstream URL: http://www.first.in-berlin.de/software/tools/any-dl/
Licenses: GPL3
Submitter: oriba
Maintainer: oriba
Last Packager: oriba
Votes: 5
Popularity: 0.008960
First Submitted: 2013-02-11 00:51
Last Updated: 2017-05-21 23:04

Latest Comments

oriba commented on 2017-05-21 23:03

Thanks for reporting this, klore.
I just created a new release and a new package for it.
Will be available soon.

klore commented on 2017-05-21 17:11

hello,
I cant compile :(

File "tools.ml", line 1:
Error: The implementation tools.ml does not match the interface tools.cmi:
...
In module Array2:
Values do not match:
val make_float : int -> float array
is not included in
external make_float : int -> float array = "caml_make_float_vect"
make[1]: *** [OCamlMakefile:1076: tools.cmx] Error 2
make[1]: Leaving directory '/tmp/pamac-build-user/any-dl/src/any-dl-0.20.0'
make: *** [OCamlMakefile:777: native-code] Error 2

oriba commented on 2016-03-23 00:04

Updated the package, so that the used source-package for the PKGBUILD contains the same files as the github-archive.
The md5sum may differ because of different file-names.

Later versions of the package may use the github-sources directly.
Thats possibly less error prone and more clear.

oriba commented on 2016-03-22 23:46

Thanks for pointing me to this.

I created the tgz-file on my computer, from where I push the sources to github. I could have used the github-zip/-tgz, and thought about using them yesterday, but decided not to use them.

Now I see, that in the created tgz-file (created at my computer), some files are missing: some *.mli and testparsers.adl.
You can check this, by comparing the uncompressed directories with "diff -r".

The package can be built, but is different in the just mentioned way.
I should either change my tgz, or use the tgz from github.
So, I will create a new package-version for this.

But the package would compile in any case.

alex.theoto commented on 2016-03-22 20:53

I cannot find the current version at the site.
At github there is source code, with md5sum is: c526c7a44fa742b0cfd0afca72119096

oriba commented on 2015-09-07 09:15

Thanks for pointing me to this.
I added that package to AUR.

rEnr3n commented on 2015-09-07 08:10

ocaml-csv is not in repo

oriba commented on 2015-02-26 14:17

I recommend to install the new version of ocamlnet: 4.0.2, and then recompile / repackage / reinstall any-dl.
With the old ocamlnet-library version, a stack-overlow occured when downloading certain video-streams.
That bug has been fixed now, and to avoid that potential trouble with any-dl, ocamlnet 4.0.2 should be used.
So, build ocamlnet anew, and build any-dl anew too, to be sure it works fine.

oriba commented on 2014-09-08 11:31

OK, changed category.

willemw commented on 2014-09-08 06:52

If the program is only a downloader and not also a multimedia player then the category should be "network".

All comments