Package Details: ape 2.0.55-1

Git Clone URL: https://aur.archlinux.org/ape.git (read-only)
Package Base: ape
Description: A plasmid editor
Upstream URL: http://biologylabs.utah.edu/jorgensen/wayned/ape/
Licenses: proprietary
Submitter: psilva
Maintainer: psilva
Last Packager: psilva
Votes: 2
Popularity: 0.000001
First Submitted: 2016-10-23 11:56
Last Updated: 2018-08-16 17:38

Latest Comments

mthead commented on 2018-10-23 11:04

ape is working again with a fully up-to-date system. Required rebuilding tclkit-8.6.4-9. For me ape doesn't exit cleanly in i3 but works okay in cinnamon.

psilva commented on 2018-08-25 12:30

Oh, nevermind, now I do get the segfault. Investigating...

psilva commented on 2018-08-25 12:30

Yes, it launches without segfaults. I even upgraded tclkit and sdx, on the off chance you were running some newer version than I am. Do you have old versions of those packages by any chance?

mthead commented on 2018-08-25 11:39

I am getting: % ape [1] 6480 segmentation fault (core dumped) tclkit-dyn /opt/ApE/main.tcl Is ape launching okay for you?

mthead commented on 2018-08-20 12:20

Thank you very much. You didn't have to do that on your trip!

psilva commented on 2018-08-16 17:41

Alright, the internal directory naming convention with 2.0.55 had changed, and that broke the build. Should be working now, though not with 2.0.54 (I assume, untested), as the build() function now unpacks and uses a differently named root directory.

psilva commented on 2018-08-14 10:53

Hey, currently out of town with little access to a computer or Internet. I'll be back on the 24th, and will take a look then.

mthead commented on 2018-08-11 15:52

stiefel40k has updated the PKGBUILD for tclkit and it builds now. However still having the same problem with ape. Although different errors now when trying to build. I have tried it with an ApE_win_current.zip that is not actually the newest but 2.0.54 (which I prefer). With that one, I can build and install ape, but it gives the same core dump message when trying to launch it. With the current ApE_win_current.zip, I couldn't even build it.

mthead commented on 2018-08-11 10:40

ApE fails to start now with: % ape
[1] 13859 segmentation fault (core dumped) tclkit-dyn /opt/ApE/main.tcl

Trying to rebuild it from the aur gives: /home/matt/ape/PKGBUILD: line 15: 2428 Segmentation fault (core dumped) sdx.kit unwrap ApE.exe

Tried rebuilding tclkit to see if that might need recompiled against some new library but that can't be built either.

mthead commented on 2017-06-28 11:29

Thank you for this. ape 2.0.52 is out now. Only the pkgver and pkgrel need to be changed.