Package Details: apitrace-git 3242.fe91ec3-1

Git Clone URL: https://aur.archlinux.org/apitrace-git.git (read-only, click to copy)
Package Base: apitrace-git
Description: Graphics API Tracing
Upstream URL: https://github.com/apitrace/apitrace
Licenses: BSD
Conflicts: apitrace
Provides: apitrace
Submitter: Glaucous
Maintainer: lordheavy
Last Packager: lordheavy
Votes: 10
Popularity: 0.000000
First Submitted: 2011-04-27 21:23 (UTC)
Last Updated: 2015-07-19 23:03 (UTC)

Latest Comments

mirh commented on 2020-05-27 21:02 (UTC)

Could you update this and lib32? Python2 is no longer needed since some months.

lordheavy commented on 2015-01-23 10:14 (UTC)

@Glaucous Thanks! Adopted and updated

Glaucous commented on 2015-01-22 17:31 (UTC)

I'm not using this software anymore, I'd appreciate it if you'd adopt it.

lordheavy commented on 2015-01-22 17:25 (UTC)

Do you plan to update it ? or i will have to orphan and adopt it.

mosra commented on 2015-01-17 13:12 (UTC)

Can you please update the PKGBUILD to the new Git workflow? Thanks!

Glaucous commented on 2013-03-21 22:25 (UTC)

Thanks, sorry for the delay.

lordheavy commented on 2013-03-20 20:03 (UTC)

Patch is merged upstream, you can remove mosra's one

Glaucous commented on 2013-03-12 20:43 (UTC)

Patch added, thanks.

mosra commented on 2013-03-12 20:24 (UTC)

I fixed it in retrace/CMakeLists.txt by changing `proc` to `procps`, here's the patch: https://gist.github.com/mosra/5146653 . I will report it upstream when I get some time.

ahuillet commented on 2013-03-12 20:07 (UTC)

Apitrace no longer builds on Archlinux : Linking CXX executable ../eglretrace cd /home/arthur/src/apitrace/build/retrace && /usr/bin/cmake -E cmake_link_script CMakeFiles/eglretrace.dir/link.txt --verbose=1 /usr/bin/c++ CMakeFiles/eglretrace.dir/glws_egl_xlib.cpp.o -o ../eglretrace -rdynamic libretrace_common.a libglretrace_common.a ../dispatch/libglproc_egl.a -lX11 -lpthread -ldl -lrt -lproc libretrace_common.a ../image/libimage.a ../thirdparty/libpng/libpng_bundled.a ../libcommon.a ../thirdparty/zlib/libz_bundled.a ../thirdparty/snappy/libsnappy_bundled.a /usr/bin/ld: cannot find -lproc collect2: error: ld returned 1 exit status

Glaucous commented on 2013-02-03 18:22 (UTC)

Fixed, thanks.

canurabus commented on 2013-02-03 02:19 (UTC)

Hey, I get the following error when trying to install this: ==> Moving LICENSE to /usr/share/licenses mv: cannot stat ‘/tmp/packerbuild-1000/apitrace-git/apitrace-git/pkg/usr/share/doc/apitrace/LICENSE’: No such file or directory ==> ERROR: A failure occurred in package(). Aborting... The build failed.

Glaucous commented on 2012-02-08 11:39 (UTC)

Fixed deps.

Glaucous commented on 2011-11-06 17:08 (UTC)

Fixed, thanks.

lucak3 commented on 2011-11-03 07:00 (UTC)

------------------------------- msg "Moving docs to /usr/share/doc" mv "${pkgdir}"/usr/{doc,share/doc/apitrace} ------------------------------- seems not to be needed anymore. Hence you should also modify mkdir -p "${pkgdir}"/usr/share/{doc,licenses/apitrace} to mkdir -p "${pkgdir}"/usr/share/licenses/apitrace

Glaucous commented on 2011-10-17 18:43 (UTC)

Indeed, good catch. Updated.

lucak3 commented on 2011-10-09 10:51 (UTC)

I cannot believe it worked till now, i did not specify cmake to use python2.7. You need to change these lines: ------------------------------------------------------------- cmake -H"${_gitname}" -Bbuild -DCMAKE_INSTALL_PREFIX=/usr ------------------------------------------------------------- to ------------------------------------------------------------- cmake -H"${_gitname}" -Bbuild -DCMAKE_INSTALL_PREFIX=/usr \ -DPYTHON_EXECUTABLE='/usr/bin/python2.7' -------------------------------------------------------------

Glaucous commented on 2011-09-08 19:30 (UTC)

Thank you! Updated.

lucak3 commented on 2011-09-08 19:07 (UTC)

PKGBUILD refreshed: http://ompldr.org/vYTljbQ/apitrace-git-20110907-1.src.tar.gz

Glaucous commented on 2011-04-28 14:07 (UTC)

Added libgl as dependency.