Package Details: aporia-git 0.4.1.40-1

Git Clone URL: https://aur.archlinux.org/aporia-git.git (read-only)
Package Base: aporia-git
Description: Aporia is an IDE for the Nim programming language
Upstream URL: https://github.com/nim-lang/Aporia
Licenses: GPL2
Conflicts: aporia
Provides: aporia
Submitter: Schala
Maintainer: jonathon
Last Packager: jonathon
Votes: 15
Popularity: 0.013097
First Submitted: 2013-03-11 21:37
Last Updated: 2017-03-13 20:39

Pinned Comments

jonathon commented on 2017-09-02 22:41

Having issues building? Try moving $HOME/.nimble out of the way (or use a clean chroot).

Latest Comments

jonathon commented on 2017-09-02 22:41

Having issues building? Try moving $HOME/.nimble out of the way (or use a clean chroot).

jonathon commented on 2017-03-13 20:24

Adopted and updated now 'nim' has been updated to 0.16 in Community.

tesfabpel commented on 2016-05-27 21:26

Hi,
please add the "nim" package to the dependencies.
:)

Thanks

Afwas commented on 2015-12-13 02:10

@Krux02: Please use `nimble install nimsuggest`. I tried to package nimsuggest but that doesn't seem to be a good idea.
Next week I will write a post_install for Aporia to do just that.

Krux02 commented on 2015-12-12 17:00

when I do autocomplete it tells me `Could not find NimSuggest in PATH`. So my suggestion is, to add NimSuggest to the dependencies, too.

MissingNo commented on 2015-06-04 15:58

It doesn't build with the following error:

==> Starting build()...
Looking for gtk2 (#head)...
None found, installing...
Error: unhandled exception: /home/gerrit/.nimble/packages.json(1, 0) Error: { expected [JsonParsingError]
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build aporia-git.

Afwas commented on 2015-05-23 15:51

@guzzard: Should be fixed now.
I also fixed the function to determine the version.

guzzard commented on 2015-05-23 15:35

Had an issue installing..

install -m644 "share/gtksourceview-2.0/language-specs/nimrod.lang" "$pkgdir/usr/share/gtksourceview-2.0/language-specs/"

needed to change "nimrod.lang" to "nim.lang", then it worked fine.

despairblue commented on 2015-01-16 12:25

change `gtksourceview-2` depends to `gtksourceview2`

pintergreg commented on 2014-10-31 10:21

I installed nimble-git from AUR and nimble install babel and gtk2, then Aporia compiled, but I didn't compiled it through AUR.

All comments