Package Details: appgate-sdp 6.0.3-1

Git Clone URL: https://aur.archlinux.org/appgate-sdp.git (read-only, click to copy)
Package Base: appgate-sdp
Description: Appgate SDP (Software Defined Perimeter) desktop client
Upstream URL: https://www.appgate.com/support/software-defined-perimeter-support
Licenses: custom, custom:commercial
Provides: appgate-sdp
Submitter: masterdisaster
Maintainer: frealgagu
Last Packager: frealgagu
Votes: 5
Popularity: 0.045401
First Submitted: 2018-07-19 12:05 (UTC)
Last Updated: 2022-11-27 04:21 (UTC)

Pinned Comments

frealgagu commented on 2020-12-18 07:36 (UTC)

I maintain the latest built package at:

https://github.com/frealgagu/archlinux.appgate-sdp/releases/

Latest Comments

1 2 3 Next › Last »

gladykov commented on 2022-11-28 11:40 (UTC)

@ZetaRevan You need to make sure you have installed gnome-keyring or kwallet, and also "Launch GNOME services on startup" selected (in case of gnome keyring)

ZetaRevan commented on 2022-11-09 14:31 (UTC)

Okay, I'm having an issue with this., maybe someone can help. I can get the app to work & connect, but I can't get it to store/remember my profile link. I have to enter it every time I start it up.

noons commented on 2021-01-18 15:36 (UTC)

@frealgagu

python-distro should be added as a dependency. I've been ripping my hair out trying to figure out why DNS resolver wasn't starting correctly on one computer, but fine on another. Tracked it to

“module 'platform' has no attribute 'linux_distribution'” error in set_dns.

Turns out the one that was working had pip installed which installs python-distro as a dependency.

frealgagu commented on 2020-12-18 07:36 (UTC)

I maintain the latest built package at:

https://github.com/frealgagu/archlinux.appgate-sdp/releases/

masterdisaster commented on 2020-03-17 14:41 (UTC)

Hi @trygveaa and @dgallant, thank you both for the information you have provided. I have updated the current package to 4.3.2 and have created a new package for Appgate 5 (appgate-sdp-5). Both include a patch which disables the test in nm.py as described in Dave's blog post.

Regarding the certificate error: I am getting a message that the endpoint certificate is not valid on Appgate 5.0, but I can work around it by editing the profile and re-approving it. I will later try if this is also the case in 5.1 for me.

Please let me know if you encounter any issues.

davegallant commented on 2020-03-17 04:15 (UTC)

@trygveaa Thanks. This allows the GUI to run on 4.3.2. I ran into some DNS issues, which were resolved by modifying a single line in /opt/appgate/linux/nm.py. I am using python3.8 system python and this file does not run with it.

I wrote a post here with more details: https://davegallant.github.io/blog/2020/03/16/appgate-sdp-on-arch-linux/

trygveaa commented on 2020-03-14 12:09 (UTC) (edited on 2020-03-14 12:11 (UTC) by trygveaa)

The reason 4.3 and newer is not working for you is that makepkg removes static libraries by default, and the newer versions require them. Adding options=(staticlibs) to the PKGBUILD makes it work.

Here is a PKGBUILD which works for 5.0. I have just changed the version number, updated the md5sum and added that options line.

# Maintainer: Pawel Mosakowski <pawel at mosakowski dot net>
pkgname=appgate-sdp
conflicts=('appgate-sdp-headless')
pkgver=5.0.3
_download_pkgver=5.0
pkgrel=1
epoch=
pkgdesc="Software Defined Perimeter - GUI client"
arch=('x86_64')
url="https://www.cyxtera.com/essential-defense/appgate-sdp/support"
license=('custom')

# dependecies calculated by namcap
depends=('gconf' 'libsecret' 'gtk3' 'python' 'nss' 'libxss' 'nodejs' 'dnsmasq')
source=("https://sdpdownloads.cyxtera.com/AppGate-SDP-${_download_pkgver}/clients/${pkgname}_${pkgver}_amd64.deb"
        "appgatedriver.service")

options=(staticlibs)

prepare() {
    tar -xf data.tar.xz
}

package() {
    cp -dpr "${srcdir}"/{etc,lib,opt,usr} "${pkgdir}"
    mv -v "$pkgdir/lib/systemd/system" "$pkgdir/usr/lib/systemd/"
    rm -vrf "$pkgdir/lib"

    cp -v "$srcdir/appgatedriver.service" "$pkgdir/usr/lib/systemd/system/appgatedriver.service"

    mkdir -vp "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/copyright" "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/LICENSE.github" "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/LICENSES.chromium.html.bz2" "$pkgdir/usr/share/licenses/appgate-sdp"
}
md5sums=('1ffc310a4aea80fb8574f7d3eaa611ec'
         '002644116e20b2d79fdb36b7677ab4cf')

I tried 5.1 too, but got a certificate error in the client when trying to authenticate. Though, I'm not sure if that's an issue with my installation, or the server, as my employer recommends using 4.3 and says they consider 5.x to be unsupported (but 5.0 worked better than 4.3 for me). Note that 5.1 requires updating appgatedriver.service as well, as the service binary has been renamed to /opt/appgate/appgate-driver.

masterdisaster commented on 2019-08-27 14:32 (UTC)

@dgallant

Hi, I am also looking into it, for reference this is the full error I get:

error: 140 Quitting. (node:4443) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): Error: Cannot find module '../screen' (node:4443) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

It appears that the issue is with node and a module called 'screen' - not my strongest suit but will continue investigating.