Package Details: appgate-sdp-5 5.1.2-2

Git Clone URL: https://aur.archlinux.org/appgate-sdp-5.git (read-only, click to copy)
Package Base: appgate-sdp-5
Description: Software Defined Perimeter v5 - GUI client
Upstream URL: https://www.cyxtera.com/essential-defense/appgate-sdp/support
Licenses: custom
Conflicts: appgate-sdp, appgate-sdp-headless
Submitter: masterdisaster
Maintainer: masterdisaster
Last Packager: masterdisaster
Votes: 1
Popularity: 0.54
First Submitted: 2020-03-17 14:34
Last Updated: 2020-06-04 17:08

Latest Comments

1 2 Next › Last »

stalet commented on 2020-06-16 12:30

I got it working by starting the service, thanks.

masterdisaster commented on 2020-06-15 15:26

Hi stalet,

What is the mode of /var/run/.appgate.driver.socket on your system?

I get:

ls -la /var/run/.appgate.driver.socket

srwxrwxrwx 1 root root 0 Jun 15 07:19 /var/run/.appgate.driver.socket

I believe that the socket is created by the appgatedriver.service, is that service running on your system?

stalet commented on 2020-06-15 14:24

I keep getting this error in my journal: Error : Connection to VPN driver has failed. Reason: Connection refused /var/run/.appgate.driver.socket

Am I missing something ?

masterdisaster commented on 2020-06-05 12:51

Hi james, thanks for letting me know about this issue. So far I can see that on my system 'chrome-sandbox' does not have the SUID bit set yet the 'appgate' executable starts and runs. I will look into it later today or tomorrow.

james commented on 2020-06-05 11:32

The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /opt/appgate/chrome-sandbox is owned by root and has mode 4755.

/opt/appgate/chrome-sandbox needs to have a chmod 4755 applied to it or else it won't start the gui application

masterdisaster commented on 2020-06-04 17:11

Thanks MonkeeSage I have removed the bundled unit file, but still had to add a single line patch since the upstream syntax of InaccessiblePaths was preventing the appgatedriver from starting.

MonkeeSage commented on 2020-06-04 04:39

ExecStart in appgatedriver.service changed from /opt/appgate/tun-service to /opt/appgate/appgate-driver in this version and needs to be updated here. The file /opt/appgate/tun-service no longer exists.

masterdisaster commented on 2020-06-03 18:02

Version bumped to 5.1.3

Before upgrading from v5.0 you need to know that now you need to receive a profile which you paste into Appgate, the old method of providing the endpoint and accepting a certificate then logging in with username and password is not present in v5.1.

Added patch /opt/appgate/linux/set_dns (thanks megapoliss) Added python-dbus as a dependency (thanks wreck) Added gnome-keyring as an optional dependency (thanks wreck) Updated the nm.py.patch Updated the download link

james commented on 2020-06-03 11:32

appgate 5.1 is out will this be updated?

wreck commented on 2020-04-26 23:27

thank you @megapoliss, that patch resolves the issue of appgate-resolver not shutting down properly after quitting/disconnecting.

in order for set_dns to run in the first place, however, i needed to install python-dbus, which should be added as a dependency i believe.

one more question for the peanut gallery: the application complains unless i open my profile for editing and validate the certificate in use every time, it doesn't seem to be saving that validation state anywhere. i don't remember running into this on another system i was using this with, anyone know what might be happening here or how to resolve? EDIT: solved, another dependency is a keyring (i installed gnome-keyring and it solved the problem, the certificate is being saved there).