Package Details: appgate-sdp 5.4.3-1

Git Clone URL: (read-only, click to copy)
Package Base: appgate-sdp
Description: Appgate SDP (Software Defined Perimeter) desktop client
Upstream URL:
Licenses: custom, custom:commercial
Provides: appgate-sdp
Submitter: masterdisaster
Maintainer: masterdisaster (frealgagu)
Last Packager: frealgagu
Votes: 4
Popularity: 0.090242
First Submitted: 2018-07-19 12:05
Last Updated: 2021-09-02 14:55

Pinned Comments

frealgagu commented on 2020-12-18 07:36

I maintain the latest built package at:

Latest Comments

1 2 Next › Last »

noons commented on 2021-01-18 15:36


python-distro should be added as a dependency. I've been ripping my hair out trying to figure out why DNS resolver wasn't starting correctly on one computer, but fine on another. Tracked it to

“module 'platform' has no attribute 'linux_distribution'” error in set_dns.

Turns out the one that was working had pip installed which installs python-distro as a dependency.

frealgagu commented on 2020-12-18 07:36

I maintain the latest built package at:

masterdisaster commented on 2020-03-17 14:41

Hi @trygveaa and @dgallant, thank you both for the information you have provided. I have updated the current package to 4.3.2 and have created a new package for Appgate 5 (appgate-sdp-5). Both include a patch which disables the test in as described in Dave's blog post.

Regarding the certificate error: I am getting a message that the endpoint certificate is not valid on Appgate 5.0, but I can work around it by editing the profile and re-approving it. I will later try if this is also the case in 5.1 for me.

Please let me know if you encounter any issues.

davegallant commented on 2020-03-17 04:15

@trygveaa Thanks. This allows the GUI to run on 4.3.2. I ran into some DNS issues, which were resolved by modifying a single line in /opt/appgate/linux/ I am using python3.8 system python and this file does not run with it.

I wrote a post here with more details:

trygveaa commented on 2020-03-14 12:09

The reason 4.3 and newer is not working for you is that makepkg removes static libraries by default, and the newer versions require them. Adding options=(staticlibs) to the PKGBUILD makes it work.

Here is a PKGBUILD which works for 5.0. I have just changed the version number, updated the md5sum and added that options line.

# Maintainer: Pawel Mosakowski <pawel at mosakowski dot net>
pkgdesc="Software Defined Perimeter - GUI client"

# dependecies calculated by namcap
depends=('gconf' 'libsecret' 'gtk3' 'python' 'nss' 'libxss' 'nodejs' 'dnsmasq')


prepare() {
    tar -xf data.tar.xz

package() {
    cp -dpr "${srcdir}"/{etc,lib,opt,usr} "${pkgdir}"
    mv -v "$pkgdir/lib/systemd/system" "$pkgdir/usr/lib/systemd/"
    rm -vrf "$pkgdir/lib"

    cp -v "$srcdir/appgatedriver.service" "$pkgdir/usr/lib/systemd/system/appgatedriver.service"

    mkdir -vp "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/copyright" "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/LICENSE.github" "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/LICENSES.chromium.html.bz2" "$pkgdir/usr/share/licenses/appgate-sdp"

I tried 5.1 too, but got a certificate error in the client when trying to authenticate. Though, I'm not sure if that's an issue with my installation, or the server, as my employer recommends using 4.3 and says they consider 5.x to be unsupported (but 5.0 worked better than 4.3 for me). Note that 5.1 requires updating appgatedriver.service as well, as the service binary has been renamed to /opt/appgate/appgate-driver.

masterdisaster commented on 2019-08-27 14:32


Hi, I am also looking into it, for reference this is the full error I get:

error: 140 Quitting. (node:4443) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): Error: Cannot find module '../screen' (node:4443) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

It appears that the issue is with node and a module called 'screen' - not my strongest suit but will continue investigating.

davegallant commented on 2019-08-11 04:28

My employer requires >= 4.3 to be installed. When pulling that .DEB, I'm getting error: 140 when loading the GUI and the application exits.

masterdisaster commented on 2019-02-10 11:10

@frealgagu Hi, I was trying to add the .asc file however looks like Cyxtera has shuffled the download links around. Example: current .deb can be downloaded from I have tried to download and but no luck.

frealgagu commented on 2018-12-03 20:05

@masterdisaster, could you add the .asc to sources please?


frealgagu commented on 2018-11-28 20:23

Confirming that package is working as expected. Starting appgatedriver.service is necessary to stablish the connections.