Package Details: applet-window-buttons-git 0.11.1-3

Git Clone URL: https://aur.archlinux.org/applet-window-buttons-git.git (read-only, click to copy)
Package Base: applet-window-buttons-git
Description: This is a Plasma 5 applet that shows window buttons in your panels
Upstream URL: https://github.com/psifidotos/applet-window-buttons
Licenses: GPL
Conflicts: applet-window-buttons
Provides: applet-window-buttons
Submitter: subutux
Maintainer: artfox3
Last Packager: artfox3
Votes: 4
Popularity: 0.001620
First Submitted: 2021-06-09 19:04 (UTC)
Last Updated: 2023-10-21 17:41 (UTC)

Required by (0)

Sources (1)

Latest Comments

artfox3 commented on 2023-10-21 17:52 (UTC)

Updated dependency 'plasma-framework' to 'plasma-framework5'

Thanks @alexdelorenzo and @Aftershock9009

alexdelorenzo commented on 2023-10-20 22:23 (UTC)

Dependencies got renamed:

:: installing plasma-framework5 (5.111.0-1) breaks dependency 'plasma-framework' required by applet-window-buttons-git

Aftershock9009 commented on 2023-10-20 13:52 (UTC) (edited on 2023-10-20 13:53 (UTC) by Aftershock9009)

@artfox3 plasma-framework has been renamed to plasma-framework5. Modifying the PKGBUILD is needed but enough for a build.

artfox3 commented on 2023-02-26 21:34 (UTC)

@Profiluefter i did update the package so it could build on 5.27, it is a fix from a commit in the package github, tho the commit is yet to be merged and so the package in github is still on the version 0.11.1, that's why i didn't change the main version, but i did change the rel version to 2, from 0.11.1-1 to 0.11.1-2 which should make the package update automatically when updating your system.

Profiluefter commented on 2023-02-26 09:07 (UTC)

Was broken for me for plasma-desktop 5.27. A rebuild/reinstall helped. Might be a good idea to increment the package version so this happens automatically?

archisman commented on 2022-06-16 03:15 (UTC)

@Max77 the solution is to add extra-cmake-modules to makedepends.

@subutux Please add this to the PKGBUILD.

Max77 commented on 2022-05-05 10:36 (UTC)

Error

CMake Error at CMakeLists.txt:15 (find_package):
  Could not find a package configuration file provided by "ECM" with any of
  the following names:

    ECMConfig.cmake
    ecm-config.cmake

  Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
  to a directory containing one of the above files.  If "ECM" provides a
  separate development package or SDK, be sure it has been installed.

artfox3 commented on 2022-02-12 13:39 (UTC)

Update the make dependency pls and also the version to the latest one

artfox3 commented on 2022-01-30 07:43 (UTC)

I guess it needs "extra-cmake-modules" as a make dependency also