Package Details: arch-audit 0.1.8-1

Git Clone URL: https://aur.archlinux.org/arch-audit.git (read-only)
Package Base: arch-audit
Description: An utility like pkg-audit based on Arch CVE Monitoring Team data
Upstream URL: https://github.com/ilpianista/arch-audit
Keywords: rust security
Licenses: MIT
Submitter: ilpianista
Maintainer: ilpianista
Last Packager: ilpianista
Votes: 52
Popularity: 9.335584
First Submitted: 2016-09-22 21:44
Last Updated: 2017-02-16 18:12

Required by (5)

Sources (1)

Latest Comments

oxe commented on 2017-03-05 17:33

3-5-17 While yaourt -S

Compiling kernel32-sys v0.2.2
Build failed, waiting for other jobs to finish...
error: failed to run custom build command for `kernel32-sys v0.2.2`
could not execute process `/tmp/yaourt-tmp-xxx/aur-arch-audit/src/arch-audit-0.1.8/target/release/build/kernel32-sys-xxx/build-script-build` (never executed)

ran several times w/ same error...

dvzrv commented on 2017-02-26 23:46

@ilpianista: My bad. That was a wrong assumption then!

In any case: It successfully builds on armv6h and armv7h. If you like to add those architectures, that would be more than welcomed!
Once this moves to community, Arch Linux ARM will pick it up anyways.
Would just be awesome to be able to build this very useful tool without makepkg -A! Thx!

ilpianista commented on 2017-02-25 15:20

@dvzrv you should read https://wiki.archlinux.org/index.php/PKGBUILD#arch

dvzrv commented on 2017-02-24 13:42

@ilpianista: You can safely set arch=('any'). That way it'll be easier buildable on ARM as well.

ilpianista commented on 2016-12-05 21:36

@hsa it was not because to build from AUR, you should install the whole base-devel group. However, I just added it.

https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

hsa commented on 2016-12-05 21:33

Hello,

@georgezaf : I have the same error when the package pkg-config is not installed
@ilpianista : why pkg-config isn't a dependency ?

Thanks

dracorp commented on 2016-11-25 08:54

@ilpianista
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 852, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'python-ptrace==0.9' distribution was not found and is required by maybe

ilpianista commented on 2016-11-23 16:31

@georgezaf I just tried in a clean environment and it built successfully.

georgezaf commented on 2016-11-22 21:25

dont work

Compiling openssl-sys v0.9.1
Compiling yaml-rust v0.3.4
Build failed, waiting for other jobs to finish...
error: failed to run custom build command for `openssl-sys v0.9.1`
process didn't exit successfully: `/home/tuxuser/.cache/pacaur/arch-audit/src/arch-audit-0.1.5/target/release/build/openssl-sys-76c1fa79ef1208aa/build-script-build` (exit code: 101)
--- stderr
thread 'main' panicked at '

Could not find directory of OpenSSL installation, and this `-sys` crate cannot
proceed without this knowledge. If OpenSSL is installed and this crate had
trouble finding it, you can set the `OPENSSL_DIR` environment variable for the
compilation process.

If you're in a situation where you think the directory *should* be found
automatically, please open a bug at https://github.com/sfackler/rust-openssl
and include information about your system as well as this message.

$HOST = x86_64-unknown-linux-gnu
$TARGET = x86_64-unknown-linux-gnu
openssl-sys = 0.9.1


It looks like you're compiling on Linux and also targeting Linux. Currently this
requires the `pkg-config` utility to find OpenSSL but unfortunately `pkg-config`
could not be found. If you have OpenSSL installed you can likely fix this by
installing `pkg-config`.

', /home/tuxuser/.cargo/registry/src/github.com-1ecc6299db9ec823/openssl-sys-0.9.1/build.rs:142
note: Run with `RUST_BACKTRACE=1` for a backtrace.

==> ERROR: A failure occurred in build().
Aborting...
:: failed to build arch-audit package(s)
[tuxuser@tuxuser Desktop]$ error: failed to run custom build command for `openssl-sys v0.9.1` archlinux
bash: openssl-sys: command not found
bash: error:: command not found

sachilles commented on 2016-09-30 12:50

Hi,

I guess this package is really nice. Is there a chance to get this package working on Arm architectures (for Raspberry Pi or other SOCs)? Unfortunately, the dependency `cargo` can't be satisfied since this package does not exist for archlinuxArm (just check [1]).

Thanks in advance.

[1] https://archlinuxarm.org/packages

All comments