Package Details: arcus 2.4.0-1

Git Clone URL: https://aur.archlinux.org/arcus.git (read-only)
Package Base: arcus
Description: Communication library between internal components for Ultimaker software
Upstream URL: https://github.com/Ultimaker/libArcus
Licenses: GPLv3
Submitter: greyltc
Maintainer: greyltc
Last Packager: greyltc
Votes: 16
Popularity: 0.805206
First Submitted: 2015-08-02 21:43
Last Updated: 2017-02-23 14:08

Latest Comments

yanganto commented on 2017-03-08 03:39

@greyltc
Thank for you help
I force cmake to use python 3.6 by putting the following lines under the cmake command in build():
-DPYTHON_EXECUTABLE="/usr/bin/python3.6"
-DPYTHON_LIBRARY="/usr/lib/libpython3.6m.so"
-DPYTHON_INCLUDE_DIR="/usr/include/python3.6"

greyltc commented on 2017-03-01 10:12

@Commod0re
Python 3.4 would work just fine if you had sip installed properly for it. This looks like an issue with your sip install. However you installed python 3.4, try to install python-sip for it in the same way.

It's a mystery to me how cmake picks the stuff it uses. Let's assume your python-sip is properly setup for python 3.6, then could try to force cmake to use your python 3.6 by putting the following lines under the cmake command in build():
-DPYTHON_EXECUTABLE="/usr/bin/python3.6"
-DPYTHON_LIBRARY="/usr/lib/libpython3.6.so"
-DPYTHON_INCLUDE_DIR="/usr/include/python3.6"

Commod0re commented on 2017-03-01 00:14

CMake Error at cmake/FindSIP.cmake:64 (MESSAGE):
Could not find SIP

I have several versions of Python installed. cmake is detecting/using Python 3.4 instead of 3.6 for some reason

swm commented on 2017-02-19 16:34

Checking the md5sum of 2.3.1.tar.gz failed while building (using yaourt). Downloading the source URL via firefox leads to a changed file name "libArcus-2.3.1.tar.gz".

Changing the PKGBUILD fixes this:
source=("libArcus.tar.gz::https://github.com/Ultimaker/libArcus/archive/${pkgver}.tar.gz")

yanganto commented on 2017-02-02 02:30

Hi, greyltc, I found more detail about this issue.
I have python 3.4.5 (which do not have SIP package) and 3.6.0 (with SIP).
I do don know why python3.4 is used to build.
May you give me hand to deal with it?
Thank you.

====

-- Found Protobuf: /usr/lib64/libprotobuf.so;-lpthread (found suitable version "3.0.0", minimum required is "3.0.0")
-- Found PythonInterp: /usr/bin/python3.4 (found suitable version "3.4.5", minimum required is "3.4.0")
-- Found PythonLibs: /usr/lib64/libpython3.4m.so (found suitable version "3.4.5", minimum required is "3.4.0")
-- Found SIP version: Unable to import sipconfig and determine your sip configuration.

-- Configuring done
-- Generating done
-- Build files have been written to: /tmp/packerbuild-1000/arcus/arcus/src/libArcus-2.3.1/build
Scanning dependencies of target Arcus
[ 5%] Building CXX object CMakeFiles/Arcus.dir/src/Socket.cpp.o
[ 11%] Building CXX object CMakeFiles/Arcus.dir/src/SocketListener.cpp.o
[ 17%] Building CXX object CMakeFiles/Arcus.dir/src/MessageTypeStore.cpp.o
[ 23%] Building CXX object CMakeFiles/Arcus.dir/src/PlatformSocket.cpp.o
[ 29%] Building CXX object CMakeFiles/Arcus.dir/src/Error.cpp.o
[ 35%] Linking CXX shared library libArcus.so
[ 35%] Built target Arcus
CMakeFiles/python_module_Arcus.dir/build.make:69: *** missing separator. Stop.
make[1]: *** [CMakeFiles/Makefile2:104: CMakeFiles/python_module_Arcus.dir/all] Error 2
make: *** [Makefile:150: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
The build failed.

greyltc commented on 2017-01-30 10:58

yanganto, I can't recreate this...

yanganto commented on 2017-01-30 02:04

Hello there, I got this issue.

[ 35%] Built target Arcus
CMakeFiles/python_module_Arcus.dir/build.make:69: *** missing separator. Stop.
make[1]: *** [CMakeFiles/Makefile2:104: CMakeFiles/python_module_Arcus.dir/all] Error 2
make: *** [Makefile:150: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

However, this issue is not the same as https://github.com/Ultimaker/libArcus/issues/41.

Could anyone give me a hand?

ccavanaugh commented on 2016-11-21 09:48

protobuf has been updated to 3.0.2 in the Extra repo.

Please update dependencies to use protobuf instead of protobuf3 in AUR.

faultylee commented on 2016-10-16 12:11

I'm getting the same issue from before
ImportError: No module named 'sipconfig'
Thought the actual issue is that python is already on 3.5, but cmake is still looking for 3.4. I did have python34 install, but somehow pip can't install sip, hence I get the above error. If I remove python34, I'll get

CMake Error at /usr/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find PythonInterp: Found unsuitable version "1.4", but required
is at least "3.4.0" (found /usr/bin/python3.4)

If I patch src/libArcus-2.1.3/cmake/FindSIP.cmake to look for 3.5.0 instead, I get

CMake Error at /usr/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find PythonInterp: Found unsuitable version "1.4", but required
is at least "3.5.0" (found /usr/bin/python3.4)

but there's no /usr/bin/python3.4, not sure what went wrong, Any idea?

greyltc commented on 2016-08-14 18:29

@larsch
Okay, I've fixed the package but I can't push it to the AUR at the moment because the AUR's git authentication is broken.

Everything seems to be fine now and I can't reproduce your cura segfault.

It might be worth a try for you to remove the whole cura software chain and rebuild & reinstall:

pacman -R cura curaengine uranium arcus
pacaur(/yaourt/whatever) -S cura

All comments