Package Details: arduide-git 0.r340.8beb733-1

Git Clone URL: https://aur.archlinux.org/arduide-git.git (read-only)
Package Base: arduide-git
Description: ArduIDE is a Qt-based IDE for the open-source Arduino electronics prototyping platform.
Upstream URL: http://mupuf.org/project/arduide.html
Licenses: GPL
Submitter: MuPuF
Maintainer: MuPuF
Last Packager: MuPuF
Votes: 74
Popularity: 2.558669
First Submitted: 2010-08-16 00:45
Last Updated: 2016-03-16 23:53

Latest Comments

MuPuF commented on 2016-06-17 07:21

@tsester: Sorry, I guess arduide does not support the latest version of arduino. I have received patches in this direction but I am not using arduide anymore :s I merely maintain the project (AKA, look at and merge patches when I get some).

I have been unable to find a new maintainer yet...

tsester commented on 2016-06-17 06:03

can i use arduino[AUR] for the existing installation path? if so, what is the path? tried /usr, /usr/bin, /usr/share/arduino .. :(

MuPuF commented on 2015-11-15 11:25

Thanks albfan, I pushed your patch to the arduide project.

albfan commented on 2015-11-15 11:13

the problem is arduino sdk 1.06 is not avaliable on archived googlecode project.

Just compile from HEAD^ and everything works fine.

For easily testing change

https://github.com/mupuf/arduide.git

to

https://github.com/albfan/arduide.git

on PKGBUILD and you're done

MuPuF commented on 2015-11-08 22:21

Sorry jooch, this version of the SDK is not supported. I have not worked on this project for a long time since I do not use arduinos anymore :s If anyone is up for coding support for the new arduino SDK, I am willing to review it and merge when it is in a good-enough shape!

jooch commented on 2015-11-07 11:34

Installed it and entered the path to the SDK (/usr/share/arduino) but keeps telling me the SDK is not valid. I have "arduino 1:1.6.5.r5-2" installed.

Viper_Scull commented on 2014-12-21 12:34

No problem mate. Good luck on your PhD defense. I'll have mine in a few months.
What's your dissertation about?

MuPuF commented on 2014-12-15 23:18

@Viper_Scull: It won't work until I update the code to support the SDK 1.0.6. I won't be able to do it in the coming week (I have my PhD defense), but I will after christmas! I'll set an alarm. Thanks for warning me!

Viper_Scull commented on 2014-12-15 12:23

arduino is now at 1.0.6 version.
Frist time I run arduide it asks for SDK (up to 1.0.5 ) path. Does it work with SDK 1.0.6?

MuPuF commented on 2014-09-21 06:52

@DanielH: Thank you, I updated the package :)

All comments