Package Details: ariamaestosa 1.4.12-1

Git Clone URL: https://aur.archlinux.org/ariamaestosa.git (read-only)
Package Base: ariamaestosa
Description: MIDI editor, player, tracker and composer
Upstream URL: http://ariamaestosa.sourceforge.net/
Licenses: GPL2
Submitter: hilton
Maintainer: ids1024
Last Packager: ids1024
Votes: 20
Popularity: 1.662308
First Submitted: 2010-02-17 02:40
Last Updated: 2016-04-30 00:27

Latest Comments

xyproto commented on 2014-08-04 10:51

I'll look at the issue, svictor. Thanks.

svictor commented on 2014-08-03 17:16

Just built Aria for the first time. It fails to launch with message "Error: can't open file '/usr/share/ariamaestosa/score/keyG.png' (error 2: No such file or directory)"

"pacman -Ql ariamaestosa | grep keyG" returns nothing, confirming that the file is not in the package.

Joermungand commented on 2014-03-11 16:22

Version 1.4.9 has been released. Builds just fine on x86-64.

xyproto commented on 2013-08-09 11:45

Thank you spider-mario! Updated the package.

spider-mario commented on 2013-08-08 21:34

Missing dependency on webkitgtk2.

xyproto commented on 2013-08-08 20:55

This package fails to build. (even with wxgtk2.9 and wx-config-2.9)

The error is:

Src/Editors/ControllerEditor.cpp:906:33: error: 'class AriaMaestosa::MainFrame' has no member named 'Bind'
getMainFrame()->Bind(wxEVT_COMMAND_MENU_SELECTED, &ControllerEditor::onDeleteInstrumentEvent, this, id);

I'll report this upstream to the ariamaestosa developers, if not one of you will beat me to it (which would be great, btw). :)

jryan commented on 2013-08-07 17:53

Also had an issue compiling after I fixed that. It looks like the wxgtk2.9 is wrong (http://ariamaestosa.sourceforge.net/building.html: "I am currently using 2.8.x on Linux/Windows...") Switching the wxgtk2.9 to wxgtk fixed the PKGBUILD.

jryan commented on 2013-08-07 17:43

Had a problem with the wx-config failing during the build process:

scons: Reading SConscript files ...
>> Operating system : linux
>> Build type : release
>> Renderer : wxwidgets
>> Architecture : 64bit
>> wx-config : wx-config
OSError: [Errno 2] No such file or directory:
File "/home/jryan/system/aur/ariamaestosa/ariamaestosa/src/AriaSrc-1.4.7/SConstruct", line 511:
main_Aria_func()
File "/home/jryan/system/aur/ariamaestosa/ariamaestosa/src/AriaSrc-1.4.7/SConstruct", line 137:
compile_Aria(which_os)
File "/home/jryan/system/aur/ariamaestosa/ariamaestosa/src/AriaSrc-1.4.7/SConstruct", line 275:
wxversion = subprocess.check_output([WXCONFIG,"--version"]).strip()
File "/usr/lib/python2.7/subprocess.py", line 568:
process = Popen(stdout=PIPE, *popenargs, **kwargs)
File "/usr/lib/python2.7/subprocess.py", line 711:
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1308:
raise child_exception
==> ERROR: A failure occurred in build().
Aborting...

The wxgtk package creates a wx-config2.9 but not a wx-config which scons was looking for? I added a link called wx-config to my path and that fixed the issue, wonder if there is a way to fix it though?

xyproto commented on 2013-04-03 23:35

Thanks paum and Greizgh, updated the package.

paum commented on 2013-04-03 19:23

setconf should be in dependencies

Anonymous comment on 2013-04-03 10:57

Thanks for the update. 1.4.7 is out, although not starred as last release.
Sha256sum: 84f9abcf9e1715b08e518230b29ac4b97aa71265405c388603ae713ae2afcfa6

Build perfectly with your pkgbuild.

xyproto commented on 2013-03-27 13:31

The way this package is built has changed, so it'll take a bit longer than usual to update this package.

xyproto commented on 2012-08-19 23:50

Updated to 1.4.3

xyproto commented on 2012-08-14 21:07

The latest version doesn't compile. Bug has been reported directly to upstream. Here's the non-working PKGBUILD: http://ix.io/2Lw

xyproto commented on 2012-07-11 14:59

Updated to 1.4.2.

xyproto commented on 2011-10-08 13:32

Adopted. Upgraded to 1.3b2.

hilton commented on 2011-10-02 21:21

Disowning.

hilton commented on 2011-07-10 17:36

Latest version doesn't compile:

In file included from Src/IO/IOUtils.cpp:20:0:
Src/Midi/Sequence.h: In member function 'int AriaMaestosa::Sequence::getXScrollInPixels() const':
Src/Midi/Sequence.h:309:77: error: 'round' was not declared in this scope
scons: *** [Src/IO/IOUtils.o] Error 1
scons: building terminated because of errors.

hilton commented on 2010-09-13 13:06

Updated to 1.2.3!
Please note that after installing it may show Warnings while updating the
desktop shortcuts database, but it is unrelated to this package.
[I forgot to set the 'quiet' option, will do that next release]

hilton commented on 2010-05-01 17:20

Updated to 1.2.1

hilton commented on 2010-05-01 14:39

Updated to 1.2!