Package Details: arm-frc-linux-gnueabi-binutils 2.30-1

Git Clone URL: https://aur.archlinux.org/arm-frc-linux-gnueabi-binutils.git (read-only)
Package Base: arm-frc-linux-gnueabi-binutils
Description: A set of programs to assemble and manipulate binary and object files (arm-frc-linux-gnueabi)
Upstream URL: http://sources.redhat.com/binutils
Licenses: GPL
Groups: frc-toolchain
Submitter: calcmogul
Maintainer: None
Last Packager: calcmogul
Votes: 3
Popularity: 0.000001
First Submitted: 2014-12-14 13:39
Last Updated: 2018-01-29 18:10

Latest Comments

calcmogul commented on 2019-01-08 18:12

This package is no longer needed. The toolchain is now built upstream by wpilib and the wpilib deps are provided via GradleRIO. Only the frc-toolchain package is needed.

zerofrost commented on 2017-10-11 06:11

==> Making package: arm-frc-linux-gnueabi-binutils 2.29-2 (Tue Oct 10 23:04:51 PDT 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
make: *** No rule to make target 'configure-host'. Stop.
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build arm-frc-linux-gnueabi-binutils package(s)

Using pacaur to download and build package. The error appears to be an unknown build target, configure-host. In all other instances of seeing this be built, I have seen make configure be used. See OSDev page on building cross compilers http://wiki.osdev.org/GCC_Cross-Compiler

calcmogul commented on 2017-10-09 04:57

I just reran the build locally with the toolchain already installed as well as with arm-frc-linux-gnueabi-binutils and arm-frc-linux-gnueabi-gcc uninstalled. I didn't see any failures. Could you provide a paste of your compilation errors?

zerofrost commented on 2017-10-09 04:29

Installation is broken. Please change make configure-host to make configure.

calcmogul commented on 2016-08-07 02:36

Could you be more specific about the errors produced?

LightQuantum commented on 2016-08-07 02:32

This new version of binutils seems to be not compatible with Wpilib. CLion threw out errors. I have to downgrade to 2.26-1 to fix the build problems.