Package Details: armory-git v0.96.5.r0.g1d02a664-1

Git Clone URL: https://aur.archlinux.org/armory-git.git (read-only)
Package Base: armory-git
Description: Full-featured Bitcoin wallet management application
Upstream URL: https://github.com/goatpig/BitcoinArmory
Licenses: MIT, AGPL3
Conflicts: armory, armory-bin, armory-goatpig-git
Provides: armory
Submitter: jgottula
Maintainer: jon
Last Packager: jon
Votes: 13
Popularity: 0.000000
First Submitted: 2012-01-10 07:04
Last Updated: 2019-02-19 18:36

Latest Comments

« First ‹ Previous 1 2 3 4

gangelop commented on 2013-03-01 16:29

You should change the dependency to from qt to qt4. For anyone that's having problems, in your PKGBUILD file just change "qt" to "qt4" in "depends" and make the package again.

Anonymous comment on 2012-11-15 16:44

fsk141: your PKGBUILD works, thanks.

jgottula: can you update this package please, or disown it?

fsk141 commented on 2012-10-28 20:38

Here's a fixed PKGBUILD, enjoy!

http://pastie.org/5129026

Anonymous comment on 2012-08-26 10:57

Won't compile here:

-------------------------------------------------
g++ -I"/usr/include/python`python -c 'import sys; print str(sys.version_info[0]) + "." + str(sys.version_info[1])'`" -c -O2 -pipe -fPIC -Icryptopp -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -lpthread CppBlockUtils_wrap.cxx
File "<string>", line 1
import sys; print str(sys.version_info[0]) + "." + str(sys.version_info[1])
^
SyntaxError: invalid syntax
CppBlockUtils_wrap.cxx:150:20: fatal error: Python.h: No such file or directory
compilation terminated.
make: *** [CppBlockUtils_wrap.o] Error 1
make: *** Waiting for unfinished jobs....
-------------------------------------------------

The following command from the makefile seems not to run with Python 3.x:
import sys; print str(sys.version_info[0]) + "." + str(sys.version_info[1])

Putting the whole build into a virtualenv with Python2.7 fixes this.

However it still breaks later because the static python libs are not available:

g++ -shared -lpthread UniversalTimer.o BinaryData.o FileDataPtr.o BtcUtils.o BlockObj.o BlockUtils.o EncryptionUtils.o libcryptopp.a "/usr/lib/libpython`python -c 'import sys; print str(sys.version_info[0]) + "." + str(sys.version_info[1])'`.a" CppBlockUtils_wrap.o -o ../_CppBlockUtils.so
g++: error: /usr/lib/libpython2.7.a: No such file or directory
make: *** [swig] Error 1

Any ideas?

jgottula commented on 2012-07-07 03:42

I added psychoweb's sed line to the PKGBUILD. Looks like the python2 package has had some directory changes recently.

oneeyed commented on 2012-07-03 12:19

The fix from psychoweb works just fine.

Anonymous comment on 2012-07-01 09:26

It failed to build in my machine. Adding the following sed before the make in the build() function solved the problem:

cd cppForSwig
sed -ir 's#".*/lib/libpython2.7.a"#"/usr/lib/python2.7/config/libpython2.7.a"#' Makefile
make swig

jgottula commented on 2012-06-01 17:44

Package update today adds python2-bsddb as a dependency.

jgottula commented on 2012-05-21 23:41

A couple of months back, the qtdev branch was the one being actively developed. Unfortunately I haven't kept up.

I've changed the PKGBUILD to build from the master branch; let me know if there are any further issues.

Anonymous comment on 2012-05-12 20:50

Why using "qtdev" branch? There are no updates for months, while current version is 0.76 (yours is 0.5)