Package Details: arnold 2009.05.31-5

Git Clone URL: https://aur.archlinux.org/arnold.git (read-only)
Package Base: arnold
Description: An Amstrad CPC emulator using SDL with a GTK+ interface
Upstream URL: http://www.yasara.org/cpc/
Keywords: cpc emulator sdl
Licenses: GPL
Submitter: lordheavy
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 16
Popularity: 0.100169
First Submitted: 2009-06-16 21:54
Last Updated: 2015-12-06 14:19

Latest Comments

Raimar commented on 2015-12-06 21:06

@FredBezies You are welcome.

FredBezies commented on 2015-12-06 14:20

@raimar : package updated. Thanks a lot for your comments on it.

Raimar commented on 2015-12-06 13:56

depends=('sdl' 'gtk2' 'libpulse') should be enough, to avoid warnings with namcap. In addition the desktop link for arnold should be located in games instead of system tools.

megadriver commented on 2015-08-30 13:50

I've recently moved to Gentoo full-time, so I'm disowning all my packages. Farewell!

megadriver commented on 2015-02-16 19:24

Updated. Thanks!

megadriver commented on 2015-02-16 19:23

Updated, thanks!

milko commented on 2015-02-15 12:16

I managed to install the package by removing the DLAGENTS directive.
I got several of these:

Resolving [...] failed: Name or service not known.

curl is used by default, if you also do so.

So, this can also be removed:
makedepends=('wget')

jwm-art commented on 2014-02-23 16:57

Really nasty constant buzzy hi-freq sound. Changing audio drivers only changes the characteristic of it. Any ideas?

megadriver commented on 2013-08-31 18:29

Very true. Fixed, thanks!

russo79 commented on 2013-08-31 17:33

Hi

You should all wget to your makedepends array, since it's not always installed on the computer and you force its usage as a download agent.

Regards

megadriver commented on 2013-08-31 08:10

Updated to arnold-tng (may 31, 2009), as it seems to be the latest version, and it supports OpenGL fullscreen mode.

megadriver commented on 2013-08-31 08:06

Updated to the version from may 31, 2009 (arnold-tng), as it seems to be the latest version, and it supports OpenGL.

megadriver commented on 2013-06-08 09:07

That's OK with me.

Somehow it got into my head that alsa-lib was a dependency of pulseaudio. Fixed, thanks!

russo79 commented on 2013-06-08 07:44

Good to hear that.

Just one small thing.
I think you are missing the 'alsa-lib' dependency, since arnold can also work with alsa-lib.

You can take a look at my PKGBUILD at https://aur.archlinux.org/packages/arnold/

After fixing this, I can request a merge of my package into yours on the AUR mailing list so that we don't have a duplicate package.

I that OK for you?

megadriver commented on 2013-06-08 06:05

I gave Pulseaudio 4.0 a chance, and it looks like all the problems I had in the past are gone. I'm a "convert" now, so I reenabled Pulseaudio support.

megadriver commented on 2013-03-21 08:29

I don't use it. Plain old ALSA is good enough for me.

For Pulseaudio support, just add 'pulseaudio' to the "depends" array and remove the "./configure --without-pulse" line.

russo79 commented on 2013-03-21 00:07

Hi
Is there a particular reason for disabling pulseaudio support?

megadriver commented on 2013-03-20 21:02

Adopted!
Removed the dependency on Pulseaudio.

megadriver commented on 2013-03-20 21:01

Adopted!

Removed the dependency on Pulseaudio.

mikhaddo commented on 2013-01-14 07:13

I just can't play with azerty keyboard, something like "a" goind up and "n" going left !

CyrIng commented on 2012-09-13 19:09

Using yaourt,
installing arnold [##################################] 100%
No issue

Glinx commented on 2011-03-23 21:42

PKGBUILD not working - "arnold.desktop not found"
Works by running local just using ./configure and make though. Thank you.