Package Details: arpage 0.3.3-9

Git Clone URL: https://aur.archlinux.org/arpage.git (read-only)
Package Base: arpage
Description: JACK MIDI arpeggiator with transport and tempo sync
Upstream URL: http://sourceforge.net/projects/arpage/
Licenses: GPL
Submitter: lee
Maintainer: lee
Last Packager: lee
Votes: 12
Popularity: 0.000000
First Submitted: 2009-12-13 04:55
Last Updated: 2017-04-10 19:48

Latest Comments

lee commented on 2017-04-10 19:56

@rvega Can't reproduce (but found something else to fix). Do you have an idea what might have introduced the strange characters in the pastebin? Perhaps that could give us a hint, unless it's just some pastbin misbehaviour.

rvega commented on 2017-03-16 20:14

Can't compile arpage 0.3.3 See errors: http://pastebin.com/9uK6Gj1K

lee commented on 2016-01-31 09:11

Thanks, @milkmiruku, updated.

milkmiruku commented on 2016-01-29 15:14

i had to add CPPFLAGS="-std=gnu++11" to the PKGBUILD to get arpage to compile.

the error (then followed by many many parse and expected errors before failing) was:

In file included from /usr/include/c++/5.3.0/type_traits:35:0,
from /usr/include/sigc++-2.0/sigc++/visit_each.h:22,
from /usr/include/sigc++-2.0/sigc++/functors/slot.h:6,
from /usr/include/sigc++-2.0/sigc++/signal_base.h:27,
from /usr/include/sigc++-2.0/sigc++/signal.h:8,
from /usr/include/sigc++-2.0/sigc++/sigc++.h:86,
from /usr/include/glibmm-2.4/glibmm/thread.h:51,
from /usr/include/glibmm-2.4/glibmm.h:87,
from main.cc:20:
/usr/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.

lee commented on 2013-11-08 16:07

I had removed it because namcap reported it as already satisfied (via jack -> libffado).
However, only for jack2 libffado is mandatory, for jack1 it is optional. So I put libxml++ back in again.

@greygjhart Please don't flag out-of-date unless packages are out of date (version-wise).

greygjhart commented on 2013-11-08 08:33

Kind of strange that libxml++ is not listed among the dependencies for this package given the fact that it *does* need it to compile, it is mentioned in the -svn version of this PKGBUILD, and finally the problem has already been mentioned earlier in theses very comments (and apparently fixed at this time)… So whoever removed it : put it back, this is not funny : )

lee commented on 2012-01-28 08:36

updated to 0.3.3-4, now fixed to compile with gcc >= 4.6
thanks @DrCherry for reporting

Anonymous comment on 2012-01-28 06:51

Can't get this package to complie. During the make I get the following:

http://pastebin.com/6aAZPLwJ

I have libxml++ and running in 64-bit Arch. pacman is up to date.

lee commented on 2011-02-28 21:03

updated to 0.3.3-3
includes the xml syntax fix.
thanks speps and sorry for the delay, I somehow seem to have missed your comment.

lee commented on 2011-01-09 23:07

Here it works. I just checked, whenever it recieves midi, it either plays notes
through (jack transport stopped) or the arp rules are applied and it sends
notes accordingly (jack transport running).

What means "no success" checking with gmidimonitor? i.e. what output did you
connect it's input to and what happend?

As far as I see arpage has no command line options, so no luck with -v, --verbose.

All comments