Package Details: artha 1.0.3-6

Git Clone URL: https://aur.archlinux.org/artha.git (read-only)
Package Base: artha
Description: A free cross-platform English thesaurus based on WordNet
Upstream URL: http://artha.sourceforge.net/wiki/index.php/Home
Licenses: GPL
Submitter: ShadowKyogre
Maintainer: donpicoro
Last Packager: donpicoro
Votes: 68
Popularity: 0.229867
First Submitted: 2009-09-17 03:35
Last Updated: 2017-11-30 08:22

Dependencies (6)

Required by (0)

Sources (1)

Pinned Comments

donpicoro commented on 2017-10-04 13:32

OK, got it to work. In principle there is nothing wrong with artha itself but now the compilation of WordNet requires to be done using

./configure --prefix=/usr --mandir=/usr/share/man CFLAGS=-fPIC CXXFLAGS=-fPIC

instead of just

./configure --prefix=/usr --mandir=/usr/share/man

Cheers.

Latest Comments

donpicoro commented on 2017-12-01 15:10

@a36233 Did you check that in principle there is nothing wrong with artha itself but now the compilation of WordNet requires to be done using

./configure --prefix=/usr --mandir=/usr/share/man CFLAGS=-fPIC CXXFLAGS=-fPIC

instead of just

./configure --prefix=/usr --mandir=/usr/share/man

Let me know whether this solves the issue.

a36233 commented on 2017-11-30 14:14

checking for wninit in -lwordnet... no
checking for wninit in -lWN... no
checking for wninit in -lwn... no
checking for wninit in -lWordNet... no
checking for wninit in -lWORDNET... no
You must have WordNet library installed to build.
(http://wordnet.princeton.edu/download)
==> ERROR: A failure occurred in build().
Aborting...

donpicoro commented on 2017-11-30 08:22

Done, thanks for noticing @simonp.

simonp commented on 2017-11-30 08:08

Please use https to download the sources:
https://downloads.sourceforge.net/sourceforge/artha/artha-1.0.3.tar.bz2

donpicoro commented on 2017-10-04 13:32

OK, got it to work. In principle there is nothing wrong with artha itself but now the compilation of WordNet requires to be done using

./configure --prefix=/usr --mandir=/usr/share/man CFLAGS=-fPIC CXXFLAGS=-fPIC

instead of just

./configure --prefix=/usr --mandir=/usr/share/man

Cheers.

donpicoro commented on 2017-09-17 20:25

If you look at the dependencies, you'll that wordnet is included. It has been included since looooooong time ago.

I cannot get it to compile either which is very strange. But this package has worked since long time ago.

I'm on a trip at the moment and I cannot promise I will look into this issue for about two weeks. If you could help with anything it would be great.

Cheers,

shivshankar commented on 2017-09-17 15:37

error while build
You must have WordNet library installed to build.
(http://wordnet.princeton.edu/download)
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build artha.

while before build
==> artha dependencies:
- wordnet (already installed)
- gtk2 (already installed)
- dbus-glib (already installed)

please update with latest depenancies

donpicoro commented on 2015-04-30 07:52

I took over the maintenance long time ago and I do not recall doing any active choice about it... but come to think of it you are right to question whether it should go under such category.

How about "office" category?

awim commented on 2015-04-27 16:11

why is the category 'editors'?

donpicoro commented on 2012-11-25 17:08

Updated.

mrbit commented on 2012-11-25 14:09

please update 1.0.3 thanks

mrbit commented on 2012-11-25 14:09

please updaet 1.0.3 thanks

donpicoro commented on 2012-10-28 19:23

I filled a bug report upstream a few days ago and it hasn't been addressed yet. As soon as I figure it out I will post the updated package. Sorry but this is not on my hands right now.

https://bugs.launchpad.net/artha/+bug/1068868

donpicoro commented on 2012-10-28 19:23

I filled a bug report upstream a few days ago and it hasn't been addressed yet. As soon as I figure it out I will post the updated package. Sorry but this is not on my hands right now.

donpicoro commented on 2012-10-19 05:30

Hej,
sorry for the delay. I just moved out from my country so I didn't have the time to complete the task yet. I did a quick test whether it was just a matter of version change but it turns out it does not compile out of box.

I will fix as soon as possible, please be patient.

Thanks for using the package, I am glad you find it useful.

headkase commented on 2012-10-17 10:51

Artha 1.0.3 is now out: http://artha.sourceforge.net/wiki/index.php/Home

Flagged! Thank you for maintaining this package!

schivmeister commented on 2011-12-24 15:45

Can anyone get notifications to work? I see no option for it at all, though both requirements are met.

Anonymous comment on 2010-10-18 04:51

Thanks for the tip schivmeister, pkgrel-bumped.

gnome-utils provides a dictionary, goldendict etc. But i have yet to find a dictionary/thesaurus as elegant as artha.

schivmeister commented on 2010-10-17 17:48

Use options=(!emptydirs) instead.

Btw is there any other alternative offline dictionary? If not, I hope to bring this into [community] (provided wordnet does not forbid redistribution).

Anonymous comment on 2010-07-16 21:00

np deej, i really like it too :)

Anonymous comment on 2010-07-16 08:05

A truly indispensable little gem of a programme. Outstanding.
Thank you regis !

Toolan

Anonymous comment on 2010-07-11 03:53

Bumped to rel-2: added optional dependencies, and empty directory fix (thanks to larryhaja)

larryhaja commented on 2010-07-10 00:29

Hi, thanks for updating the PKGBUILD. I noticed that there are 2 empty directories in the package. I'm not sure why. The directories are /usr/lib and /usr/include. I added the following line at the end of the PKGBUILD to delete any empty directories.

find $pkgdir -depth -type d -empty -exec rm -rf {} \;

Anonymous comment on 2010-07-09 22:44

Adopted. Bumped to 1.0.2