Package Details: asciidoctor-pdf 1.6.2-1

Git Clone URL: https://aur.archlinux.org/asciidoctor-pdf.git (read-only, click to copy)
Package Base: asciidoctor-pdf
Description: translate asciidoctor directly to pdf
Upstream URL: https://asciidoctor.org/
Licenses: MIT
Submitter: gaelic
Maintainer: gaelic (tba)
Last Packager: tba
Votes: 8
Popularity: 0.015958
First Submitted: 2019-02-19 13:13 (UTC)
Last Updated: 2021-12-31 17:27 (UTC)

Latest Comments

ThinkPad commented on 2022-04-19 20:41 (UTC) (edited on 2022-04-19 20:42 (UTC) by ThinkPad)

Uninstalled asciidoctor-pdf, uninstalled ruby, deleted ~/.local/share/gem, re-installed asciidoctor-pdf clean-building all. Now it works.

ThinkPad commented on 2022-04-13 22:54 (UTC) (edited on 2022-04-13 23:17 (UTC) by ThinkPad)

I had rbenv installed and was using shims as a workaround to prawn not yet supporting Ruby 3. I have now removed everything related and re-installed asciidoctor-pdf.

This is the current state:

$ irb
----
<internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require': cannot load such file -- rdoc (LoadError)
    from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
    from /usr/lib/ruby/gems/3.0.0/gems/irb-1.4.1/lib/irb/input-method.rb:17:in `<top (required)>'
    from /usr/lib/ruby/gems/3.0.0/gems/irb-1.4.1/lib/irb/context.rb:14:in `require_relative'
    from /usr/lib/ruby/gems/3.0.0/gems/irb-1.4.1/lib/irb/context.rb:14:in `<top (required)>'
    from /usr/lib/ruby/gems/3.0.0/gems/irb-1.4.1/lib/irb.rb:16:in `require_relative'
    from /usr/lib/ruby/gems/3.0.0/gems/irb-1.4.1/lib/irb.rb:16:in `<top (required)>'
    from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
    from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
    from /usr/lib/ruby/gems/3.0.0/gems/irb-1.4.1/exe/irb:9:in `<top (required)>'
    from /usr/bin/irb:25:in `load'
    from /usr/bin/irb:25:in `<main>'

Error thrown during use:

/usr/lib/ruby/3.0.0/rubygems/specification.rb:1401:in `rescue in block in activate_dependencies': Could not find 'prawn-table' (~> 0.2.0) among 95 total gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/home/mcp/.local/share/gem/ruby/3.0.0:/usr/lib/ruby/gems/3.0.0' at: /usr/lib/ruby/gems/3.0.0/specifications/asciidoctor-pdf-1.6.2.gemspec, execute `gem env` for more information
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1398:in `block in activate_dependencies'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1387:in `each'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1387:in `activate_dependencies'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1369:in `activate'
    from /usr/lib/ruby/3.0.0/rubygems.rb:286:in `block in activate_bin_path'
    from /usr/lib/ruby/3.0.0/rubygems.rb:285:in `synchronize'
    from /usr/lib/ruby/3.0.0/rubygems.rb:285:in `activate_bin_path'
    from /usr/bin/asciidoctor-pdf:25:in `<main>'
/usr/lib/ruby/3.0.0/rubygems/dependency.rb:311:in `to_specs': Could not find 'prawn-table' (~> 0.2.0) among 95 total gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/home/mcp/.local/share/gem/ruby/3.0.0:/usr/lib/ruby/gems/3.0.0' , execute `gem env` for more information
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1399:in `block in activate_dependencies'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1387:in `each'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1387:in `activate_dependencies'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1369:in `activate'
    from /usr/lib/ruby/3.0.0/rubygems.rb:286:in `block in activate_bin_path'
    from /usr/lib/ruby/3.0.0/rubygems.rb:285:in `synchronize'
    from /usr/lib/ruby/3.0.0/rubygems.rb:285:in `activate_bin_path'
    from /usr/bin/asciidoctor-pdf:25:in `<main>'

ThinkPad commented on 2022-04-13 22:31 (UTC)

$ which ruby
----
/usr/bin/ruby

$ which irb
----
/usr/bin/irb
$ irb
irb(main):001:0> require prawn
(irb):1:in `<main>': undefined local variable or method `prawn' for main:Object (NameError)
Did you mean?  spawn
    from /usr/lib/ruby/gems/3.0.0/gems/irb-1.4.1/exe/irb:11:in `<top (required)>'
    from /usr/bin/irb:25:in `load'
    from /usr/bin/irb:25:in `<main>'
irb(main):002:0> require asciidoctor-pdf
(irb):2:in `<main>': undefined local variable or method `asciidoctor' for main:Object (NameError)
    from /usr/lib/ruby/gems/3.0.0/gems/irb-1.4.1/exe/irb:11:in `<top (required)>'
    from /usr/bin/irb:25:in `load'
    from /usr/bin/irb:25:in `<main>'

tba commented on 2022-02-17 11:21 (UTC)

Can you please show

which ruby

which irb

Then launch irb and show require "prawn", require "asciidoctor-pdf". Like this

$ irb
irb(main):001:0> require 'prawn'
=> true
irb(main):002:0> require 'asciidoctor-pdf'
=> true

ThinkPad commented on 2022-02-16 17:48 (UTC) (edited on 2022-02-16 17:48 (UTC) by ThinkPad)

ruby-prawn 2.4.0-1

tba commented on 2022-02-16 11:28 (UTC)

Cannot reproduce. What version of ruby-prawn do you have installed?

pacman -Q ruby-prawn

ThinkPad commented on 2022-02-15 23:26 (UTC)

I'm getting this error when trying to use the package:

/usr/lib/ruby/3.0.0/rubygems/specification.rb:1401:in `rescue in block in activate_dependencies': Could not find 'prawn' (~> 2.4.0) among 104 total gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/home/mcp/.gem/ruby/3.0.0:/usr/lib/ruby/gems/3.0.0' at: /usr/lib/ruby/gems/3.0.0/specifications/asciidoctor-pdf-1.6.2.gemspec, execute `gem env` for more information
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1398:in `block in activate_dependencies'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1387:in `each'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1387:in `activate_dependencies'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1369:in `activate'
    from /usr/lib/ruby/3.0.0/rubygems.rb:286:in `block in activate_bin_path'
    from /usr/lib/ruby/3.0.0/rubygems.rb:285:in `synchronize'
    from /usr/lib/ruby/3.0.0/rubygems.rb:285:in `activate_bin_path'
    from /usr/bin/asciidoctor-pdf:25:in `<main>'
/usr/lib/ruby/3.0.0/rubygems/dependency.rb:311:in `to_specs': Could not find 'prawn' (~> 2.4.0) among 104 total
gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/home/mcp/.gem/ruby/3.0.0:/usr/lib/ruby/gems/3.0.0' , execute `gem env` for more information
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1399:in `block in activate_dependencies'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1387:in `each'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1387:in `activate_dependencies'
    from /usr/lib/ruby/3.0.0/rubygems/specification.rb:1369:in `activate'
    from /usr/lib/ruby/3.0.0/rubygems.rb:286:in `block in activate_bin_path'
    from /usr/lib/ruby/3.0.0/rubygems.rb:285:in `synchronize'
    from /usr/lib/ruby/3.0.0/rubygems.rb:285:in `activate_bin_path'
    from /usr/bin/asciidoctor-pdf:25:in `<main>'

I can confirm ruby-prawn is installed as a dependency of asciidoctor-pdf. I also tried re-installing ruby-prawn with --asdeps. Not sure how to proceed.

tba commented on 2021-04-20 09:25 (UTC)

It's because of ruby was upgraded to 3. Please try again. I've bumped pkgrels of my packages but you'll probably need to clean build a bunch of other dependencies.

ThinkPad commented on 2021-04-19 18:03 (UTC) (edited on 2021-04-19 18:11 (UTC) by ThinkPad)

I am getting this error when installing via yay

error: failed to commit transaction (conflicting files)
ruby-pdf-core-0.7: /usr/bin/ruby_executable_hooks exists in filesystem (owned by ruby-ttfunk-1.5)
Errors occurred, no packages were upgraded.

Running

sudo rm /usr/bin/ruby_executable_hooks
sudo yay -S ruby-pdf-core-0.7 --asdeps
sudo yay -S asciidoctor-pdf

solved it. But now I get a new issue

ERROR:  Error installing prawn-2.2.2.gem:
    prawn-2.2.2 requires Ruby version ~> 2.1. The current ruby version is 3.0.1.64.
==> ERROR: A failure occurred in package().
    Aborting...
error making: ruby-prawn

tba commented on 2021-03-23 16:20 (UTC)

@lrm, it's not needed. ruby-css_parser is the replacement as the ruby-prawn-svg dependency. What package requires ruby-css_parser-1.6?

lrm commented on 2021-03-23 15:54 (UTC)

ruby-css_parser-1.6 doesn't exist in AUR anymore.

tba commented on 2021-01-18 08:43 (UTC)

Hello.

What do you mean by outdated binaries? All dependencies exist and installable

$ yay -Q --provides 'ruby-ttfunk<1.6'
ruby-ttfunk-1.5 1.5.1-3
$ yay -Q --provides 'ruby-css_parser<1.7'
ruby-css_parser-1.6 1.6.0-2

xmrdo commented on 2021-01-17 16:38 (UTC)

Depends on outdated binaries. Can't be installed

: no results found for ruby-ttfunk<1.6 (dependency tree: asciidoctor-pdf ruby-prawn-icon ruby-prawn ruby-ttfunk) :: no results found for ruby-css_parser<1.7 (dependency tree: asciidoctor-pdf ruby-prawn-svg ruby-css_parser) :: no results found for ruby-pdf-core<0.8 (dependency tree: asciidoctor-pdf ruby-prawn-icon ruby-prawn ruby-pdf-core)

tba commented on 2020-11-26 07:44 (UTC)

Hi,

Thanks for reporting.

The problem is that one of dependencies is broken (specifically ruby-pdf-reader: it is hardly dependent on ruby-ascii85 version 1.0.x, and ruby-ascii85 is now 1.1.0). I've built package ruby-ascii85-1.0 to satisfy the dependency.

What you can do is one of those:

  • Report to ruby-pdf-reader maintainer for him to fix dependencies (change ruby-ascii85 to ruby-ascii85<1.1).
  • Just install ruby-ascii85-1.0 explicitly.
  • (The ugliest) Fix dependency manually in /usr/lib/ruby/gems/2.7.0/specifications/pdf-reader-2.4.1.gemspec. Find line with Ascii85 and change version ~ 1.0.0 to ~ 1.0.

satcom886 commented on 2020-11-26 00:35 (UTC)

I just installed this and this happens when I start asciidoctor-pdf:

Traceback (most recent call last):
        16: from /usr/bin/asciidoctor-pdf:23:in `<main>'
        15: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `activate_bin_path'
        14: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `synchronize'
        13: from /usr/lib/ruby/2.7.0/rubygems.rb:298:in `block in activate_bin_path'
        12: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
        11: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
        10: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         9: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1403:in `block in activate_dependencies'
         8: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
         7: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
         6: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         5: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1403:in `block in activate_dependencies'
         4: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
         3: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
         2: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         1: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1400:in `block in activate_dependencies'
/usr/lib/ruby/2.7.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'Ascii85' (~> 1.0.0) - did find: [Ascii85-1.1.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/satcom886/.gem/ruby/2.7.0:/usr/lib/ruby/gems/2.7.0', execute `gem env` for more information

tba commented on 2020-06-04 17:51 (UTC) (edited on 2020-06-04 18:33 (UTC) by tba)

ruby-ttfunk<1.6 is provided by ruby-ttfunk-1.5 package. You can see it in the "Dependencies" section above: ruby-ttfunk<1.6 (ruby-ttfunk-1.5) with a link. I use yay as aur helper and it can resolve dependencies fine. Don't know about other aur helpers. FWIW, the same situation is with ruby-prawn (depends on ruby-pdf-core-0.7). Unfortunately, this versions are locked in upstream. If your aur helper cannot resolve dependencies or you build manually, you can start with building ruby-css_parser-1.6, ruby-pdf-core-0.7 and ruby-ttfunk-1.5. These are all required versioned packages.

I'm quite new to the arch packaging, but I think proper implemented aur helper must resolve these dependencies. If you have better idea of how it should be done, please share.

EDIT: fix typos

christianlupus commented on 2020-06-04 17:03 (UTC)

At the moment this package requires ruby-ttfunk<1.6. The corresponding AUR package is only available for version 1.6.2.1-1 at the moment of writing. This will cause problems with the dependency checking during building.

tba commented on 2020-06-03 17:37 (UTC)

There should be no problem with dependencies

tba commented on 2020-05-25 23:14 (UTC)

Hey, thanks for packaging!

Are you planning updating the package? If yes, please, add proper dependencies. I've packaged missed ones. I've tested this PKGBUILD which works for me.

TheNiceGuy commented on 2019-12-01 22:20 (UTC)

Running this command gem install --pre asciidoctor-pdf solve the dependencies.

jfernandz commented on 2019-11-29 18:08 (UTC) (edited on 2019-11-29 18:14 (UTC) by jfernandz)

I think the same, about gems dependencies, I not find ideal the manual install for all of them. Moreover ... there is a unresolved dependency that I don't think can be resolved anymore.

$ asciidoctor-pdf Compuestos.adoc
Traceback (most recent call last):
        8: from /usr/bin/asciidoctor-pdf:23:in `<main>'
        7: from /usr/lib/ruby/2.6.0/rubygems.rb:304:in `activate_bin_path'
        6: from /usr/lib/ruby/2.6.0/rubygems.rb:304:in `synchronize'
        5: from /usr/lib/ruby/2.6.0/rubygems.rb:305:in `block in activate_bin_path'
        4: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1417:in `activate'
        3: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1435:in `activate_dependencies'
        2: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1435:in `each'
        1: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1446:in `block in activate_dependencies'
/usr/lib/ruby/2.6.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'treetop' (~> 1.5.0) - did find: [treetop-1.6.10] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/wyre/.gem/ruby/2.6.0:/usr/lib/ruby/gems/2.6.0', execute `gem env` for more information

$ gem install treetop -v 1.5.0   
ERROR:  Could not find a valid gem 'treetop' (= 1.5.0) in any repository
ERROR:  Possible alternatives: treetop

I mean, I cannot install 'treetop=1.5.0' because there is not available in the repos. What do you suggest?

EDIT: Here https://discuss.asciidoctor.org/asciidoctor-pdf-treetop-td7029.html mojavelinux is suggestion that you could use RVM to manage the ruby dependencies. Unfortunately the AUR package https://aur.archlinux.org/packages/rvm/ is orphaned and out of date :(

gaelic commented on 2019-09-06 08:23 (UTC)

Hey, this is intentional because:

  • I cannot automatically include all gems in the package as dependencies via ruby; the gems might already be in the system and hence leading to a file conflict
  • I can include the gems available as a arch package or available in the aur. But not all of them are there

christianlupus commented on 2019-07-10 13:28 (UTC)

I had problems with this package. I had to install some gems manually using gem install, which ist maybe not ideal. Could you veryfy that there are all depencencies resolved? Thanks