Package Details: asciidoctor-pdf 1.5.3-1

Git Clone URL: https://aur.archlinux.org/asciidoctor-pdf.git (read-only, click to copy)
Package Base: asciidoctor-pdf
Description: translate asciidoctor directly to pdf
Upstream URL: https://asciidoctor.org/
Licenses: MIT
Submitter: gaelic
Maintainer: gaelic (tba)
Last Packager: tba
Votes: 5
Popularity: 0.20
First Submitted: 2019-02-19 13:13
Last Updated: 2020-06-03 17:04

Latest Comments

tba commented on 2020-06-04 17:51

ruby-ttfunk<1.6 is provided by ruby-ttfunk-1.5 package. You can see it in the "Dependencies" section above: ruby-ttfunk<1.6 (ruby-ttfunk-1.5) with a link. I use yay as aur helper and it can resolve dependencies fine. Don't know about other aur helpers. FWIW, the same situation is with ruby-prawn (depends on ruby-pdf-core-0.7). Unfortunately, this versions are locked in upstream. If your aur helper cannot resolve dependencies or you build manually, you can start with building ruby-css_parser-1.6, ruby-pdf-core-0.7 and ruby-ttfunk-1.5. These are all required versioned packages.

I'm quite new to the arch packaging, but I think proper implemented aur helper must resolve these dependencies. If you have better idea of how it should be done, please share.

EDIT: fix typos

christianlupus commented on 2020-06-04 17:03

At the moment this package requires ruby-ttfunk<1.6. The corresponding AUR package is only available for version 1.6.2.1-1 at the moment of writing. This will cause problems with the dependency checking during building.

tba commented on 2020-06-03 17:37

There should be no problem with dependencies

tba commented on 2020-05-25 23:14

Hey, thanks for packaging!

Are you planning updating the package? If yes, please, add proper dependencies. I've packaged missed ones. I've tested this PKGBUILD which works for me.

TheNiceGuy commented on 2019-12-01 22:20

Running this command gem install --pre asciidoctor-pdf solve the dependencies.

jfernandz commented on 2019-11-29 18:08

I think the same, about gems dependencies, I not find ideal the manual install for all of them. Moreover ... there is a unresolved dependency that I don't think can be resolved anymore.

$ asciidoctor-pdf Compuestos.adoc
Traceback (most recent call last):
        8: from /usr/bin/asciidoctor-pdf:23:in `<main>'
        7: from /usr/lib/ruby/2.6.0/rubygems.rb:304:in `activate_bin_path'
        6: from /usr/lib/ruby/2.6.0/rubygems.rb:304:in `synchronize'
        5: from /usr/lib/ruby/2.6.0/rubygems.rb:305:in `block in activate_bin_path'
        4: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1417:in `activate'
        3: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1435:in `activate_dependencies'
        2: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1435:in `each'
        1: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1446:in `block in activate_dependencies'
/usr/lib/ruby/2.6.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'treetop' (~> 1.5.0) - did find: [treetop-1.6.10] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/wyre/.gem/ruby/2.6.0:/usr/lib/ruby/gems/2.6.0', execute `gem env` for more information

$ gem install treetop -v 1.5.0   
ERROR:  Could not find a valid gem 'treetop' (= 1.5.0) in any repository
ERROR:  Possible alternatives: treetop

I mean, I cannot install 'treetop=1.5.0' because there is not available in the repos. What do you suggest?

EDIT: Here https://discuss.asciidoctor.org/asciidoctor-pdf-treetop-td7029.html mojavelinux is suggestion that you could use RVM to manage the ruby dependencies. Unfortunately the AUR package https://aur.archlinux.org/packages/rvm/ is orphaned and out of date :(

gaelic commented on 2019-09-06 08:23

Hey, this is intentional because:

  • I cannot automatically include all gems in the package as dependencies via ruby; the gems might already be in the system and hence leading to a file conflict
  • I can include the gems available as a arch package or available in the aur. But not all of them are there

christianlupus commented on 2019-07-10 13:28

I had problems with this package. I had to install some gems manually using gem install, which ist maybe not ideal. Could you veryfy that there are all depencencies resolved? Thanks