Package Details: asio-latest 1.11.0.r161.g14db6371-4

Git Clone URL: https://aur.archlinux.org/asio-latest.git (read-only)
Package Base: asio-latest
Description: Cross-platform C++ library for ASynchronous network I/O (1.11 branch)
Upstream URL: https://think-async.com/Asio
Licenses: custom:boost
Conflicts: asio
Provides: asio
Submitter: zorun
Maintainer: None
Last Packager: zorun
Votes: 14
Popularity: 0.065392
First Submitted: 2016-11-12 22:44
Last Updated: 2017-02-14 23:39

Dependencies (2)

Required by (8)

Sources (1)

Latest Comments

mahalol commented on 2017-03-13 01:56

Hi, I was getting the following error when trying to update with pacaur 4.6.10

==> Making package: asio-latest 1.11.0.r161.g14db6371-4 (Mon Mar 13 14:40:58 NZDT 2017)
==> Retrieving sources...
==> ERROR: /home/myuser/.cache/pacaur/asio-latest/asio is not a clone of https://github.com/chriskohlhoff/asio

I had to remove the current package and delete the pacaur cache, then install again and it compiled successfully.

zorun commented on 2017-02-14 23:40

Ok, this was just $pkgver being slightly inconsistent with the output of pkgver(). Should be fixed.

gdmsl commented on 2017-02-14 22:56

I get the same error using pacaur. Probably it is the same problem that affects the package google-breakpad-git. There is also an open issue on github https://github.com/rmarquis/pacaur/issues/564

zorun commented on 2017-02-12 21:51

Again, can you be more specific about the error?

marmistrz commented on 2017-02-12 21:20

I guess somaulte uses pacaur or some other helper. I get the same error.

zorun commented on 2017-01-02 10:20

I don't understand, what is the program returning this error? The .SRCINFO looks consistent with the PKGBUILD (I build it with a git hook so it shouldn't be able to become inconsistent). But even if it were inconsistent, you should be able to build anyway.

somaulte commented on 2017-01-02 02:41

Failing to install:
asio-latest package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD.