Package Details: asix-module 4.20.0-1

Git Clone URL: https://aur.archlinux.org/asix-module.git (read-only)
Package Base: asix-module
Description: A kernel module for the ASIX USB 2.0 low power AX88772B/AX88772A/AX88760/AX88772/AX88178 ethernet controllers
Upstream URL: http://www.asix.com.tw
Licenses: GPL
Submitter: xyproto
Maintainer: mtorromeo
Last Packager: mtorromeo
Votes: 3
Popularity: 0.000006
First Submitted: 2011-12-14 16:29
Last Updated: 2017-05-02 07:52

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

heppu commented on 2018-02-13 11:07

Installation fails with following error messages:

make -C /usr/lib/modules/4.15.2-2-ARCH/build SUBDIRS=/tmp/trizen-heppu/asix-module/src/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.20.0_Source modules make[1]: Entering directory '/usr/lib/modules/4.15.2-2-ARCH/build' CC [M] /tmp/trizen-heppu/asix-module/src/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.20.0_Source/asix.o In file included from /tmp/trizen-heppu/asix-module/src/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.20.0_Source/asix.c:42:0: /tmp/trizen-heppu/asix-module/src/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.20.0_Source/axusbnet.c: In function ‘axusbnet_probe’: /tmp/trizen-heppu/asix-module/src/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.20.0_Source/axusbnet.c:1327:22: error: assignment from incompatible pointer type [-Werror=incompatible-pointer-types] dev->delay.function = axusbnet_bh; ^ /tmp/trizen-heppu/asix-module/src/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.20.0_Source/axusbnet.c:1328:12: error: ‘struct timer_list’ has no member named ‘data’ dev->delay.data = (unsigned long) dev; ^ /tmp/trizen-heppu/asix-module/src/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.20.0_Source/axusbnet.c:1329:2: error: implicit declaration of function ‘init_timer’; did you mean ‘init_timers’? [-Werror=implicit-function-declaration] init_timer(&dev->delay); ^~~~~~~~~~ init_timers

rashkov commented on 2017-02-02 19:30

getting this on pacman -Syyu

error: failed to prepare transaction (could not satisfy dependencies)
:: asix-module: installing linux (4.9.6-1) breaks dependency 'linux<4.9'

rashkov commented on 2016-12-15 16:15

Thanks for your work mtorromeo. The source changed again. It is now:
AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.19.0_Source.tar.bz2

Note the extension changed from gz to bz2, and the version bump. The patch needs to be re-enabled as well.

rashkov commented on 2016-10-10 17:44

The source has changed to: http://www.asix.com.tw/FrootAttach/driver/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.18.1_Source.tar.gz

Also it needs a patch. This line in axusbnet.c needs to be changed:
net->trans_start = jiffies;

It should be commented out. In its place you should have:
netif_trans_update(net);

Foxboron commented on 2016-08-12 13:56

There seems to be some debug flags left inn the driver. Syslog is being spammed with messages from the driver.

Foxboron commented on 2016-02-06 22:12

The package is still broken. Prevents system upgrades whenever there is a new kernel.

:: Synchronizing package databases...
core 122.8 KiB 2.26M/s 00:00 [######################################] 100%
extra 1769.1 KiB 8.35M/s 00:00 [######################################] 100%
community 3.3 MiB 8.91M/s 00:00 [######################################] 100%
multilib 155.4 KiB 2.66M/s 00:00 [######################################] 100%
archlinuxfr 11.5 KiB 0.00B/s 00:00 [######################################] 100%
infinality-bundle is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: asix-module: requires linux<4.4

Foxboron commented on 2015-09-29 11:03

@mtorremeo Yes, that's great. But the package is preventing me from upgrading to linux 4.2.

mtorromeo commented on 2015-09-29 08:36

@Foxboron: I think you have managed to miss the point. If you build the module against linux 4.1.x the requires of linux>=4.1 linux<4.2 are appropriate and you should rebuild it when upgrading to linux-4.2.x

Foxboron commented on 2015-09-28 23:38

You have managed to mangle the dependencies.
error: failed to prepare transaction (could not satisfy dependencies)
:: asix-module: requires linux<4.2

Working PKGBUILD can be found here:
https://github.com/Foxboron/PKGBUILDS/blob/master/asix-module/PKGBUILD

As i wrote in the mail i sent you, i can take over the ownership of the package.

JKAbrams commented on 2014-09-02 16:14

Here is a patch doing what I described below:
http://bpaste.net/show/bf6f0e13d4c3

And updated PKGBUILD:
http://bpaste.net/show/39155195371c