Package Details: asix-module 4.18.1-1

Git Clone URL: https://aur.archlinux.org/asix-module.git (read-only)
Package Base: asix-module
Description: A kernel module for the ASIX USB 2.0 low power AX88772B/AX88772A/AX88760/AX88772/AX88178 ethernet controllers
Upstream URL: http://www.asix.com.tw
Licenses: GPL
Submitter: xyproto
Maintainer: mtorromeo
Last Packager: mtorromeo
Votes: 2
Popularity: 0.000000
First Submitted: 2011-12-14 16:29
Last Updated: 2016-10-11 07:40

Latest Comments

rashkov commented on 2016-10-10 17:44

The source has changed to: http://www.asix.com.tw/FrootAttach/driver/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.18.1_Source.tar.gz

Also it needs a patch. This line in axusbnet.c needs to be changed:
net->trans_start = jiffies;

It should be commented out. In its place you should have:
netif_trans_update(net);

Foxboron commented on 2016-08-12 13:56

There seems to be some debug flags left inn the driver. Syslog is being spammed with messages from the driver.

Foxboron commented on 2016-02-06 22:12

The package is still broken. Prevents system upgrades whenever there is a new kernel.

:: Synchronizing package databases...
core 122.8 KiB 2.26M/s 00:00 [######################################] 100%
extra 1769.1 KiB 8.35M/s 00:00 [######################################] 100%
community 3.3 MiB 8.91M/s 00:00 [######################################] 100%
multilib 155.4 KiB 2.66M/s 00:00 [######################################] 100%
archlinuxfr 11.5 KiB 0.00B/s 00:00 [######################################] 100%
infinality-bundle is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: asix-module: requires linux<4.4

Foxboron commented on 2015-09-29 11:03

@mtorremeo Yes, that's great. But the package is preventing me from upgrading to linux 4.2.

mtorromeo commented on 2015-09-29 08:36

@Foxboron: I think you have managed to miss the point. If you build the module against linux 4.1.x the requires of linux>=4.1 linux<4.2 are appropriate and you should rebuild it when upgrading to linux-4.2.x

Foxboron commented on 2015-09-28 23:38

You have managed to mangle the dependencies.
error: failed to prepare transaction (could not satisfy dependencies)
:: asix-module: requires linux<4.2

Working PKGBUILD can be found here:
https://github.com/Foxboron/PKGBUILDS/blob/master/asix-module/PKGBUILD

As i wrote in the mail i sent you, i can take over the ownership of the package.

JKAbrams commented on 2014-09-02 16:14

Here is a patch doing what I described below:
http://bpaste.net/show/bf6f0e13d4c3

And updated PKGBUILD:
http://bpaste.net/show/39155195371c

JKAbrams commented on 2014-09-02 15:44

Version 4.13 has been released and they have deleted 4.12.

Here's a PKGBUILD for the new package:
http://bpaste.net/show/d1e745e0a57d

It does however not build:
[...]/asix-module/src/AX88772C_772B_772A_760_772_178_LINUX_DRIVER_v4.13.0_Source/asix.c:49:6: error: macro "__TIME__" might prevent reproducible builds [-Werror=date-time]

When I add the buildflag 'Wno-date-time' to the makefile it builds.
http://bpaste.net/show/0ac9b6812834

ptrxyz commented on 2013-08-08 06:23

Version 4.10 is out.

lineage commented on 2013-04-05 12:03

The 4.6.0 version works for me on kernel 3.7.3. The builtin driver in the kernel seems to receive each packet twice with the second copy having 4 extra bytes stuffed in the front.
The usb module is badged TRUlink and appears as
ID 0b95:1780 ASIX Electronics Corp. AX88178

madmack commented on 2012-09-26 13:22

out of date. needs to be updated and possibly dkms(ed) v4.4.0 : http://www.asix.com.tw/FrootAttach/driver/AX88772B_772A_760_772_178_LINUX_Driver_v4.4.0_Source.zip

xyproto commented on 2011-12-14 16:40

Moved from [community] in connection with the Christmas Cleanup https://wiki.archlinux.org/index.php/Christmas_Cleanup.