Package Details: astap-bin-qt5 2024.03.27-1

Git Clone URL: https://aur.archlinux.org/astap-bin-qt5.git (read-only, click to copy)
Package Base: astap-bin-qt5
Description: Astrometric (plate) solver, stacking of images, photometry and FITS viewer
Upstream URL: https://www.hnsky.org/astap.htm
Keywords: astrometry astronomy astrophotography
Licenses: LGPL3
Conflicts: astap-bin
Provides: astap
Submitter: wrenby
Maintainer: wrenby
Last Packager: wrenby
Votes: 1
Popularity: 0.000280
First Submitted: 2022-04-19 03:08 (UTC)
Last Updated: 2024-03-28 13:12 (UTC)

Dependencies (15)

Required by (16)

Sources (1)

Latest Comments

wrenby commented on 2023-06-14 18:39 (UTC)

@Mr.Smith1974 I don't think I understand what you're asking. This package does provide astap, and it doesn't depend on any other packages of astap, optionally or otherwise -- in fact, it conflicts with them.

Mr.Smith1974 commented on 2023-06-14 11:24 (UTC) (edited on 2023-06-14 11:25 (UTC) by Mr.Smith1974)

Please remove provides=('astap')

Now you can write like this in other builds:


    optdepends=('astap-bin: binary GTk version'
    'astap-bin-qt5: binary Qt version'
    'astap: sourced Qt version'
    'astap-cli: CLI version')

wrenby commented on 2023-06-03 18:19 (UTC) (edited on 2023-06-03 18:28 (UTC) by wrenby)

@Mr.Smith1974 That's the Pascal bindings for Qt5. Forgot to add them as a dependency, but the update should be live now if you update your repositories with yay -Syyu or equivalent.

Mr.Smith1974 commented on 2023-06-03 17:24 (UTC) (edited on 2023-06-03 17:24 (UTC) by Mr.Smith1974)

I installed the program, but it does not start with an error: astap: error while loading shared libraries: libQt5Pas.so.1: cannot open shared object file: No such file or directory

wrenby commented on 2022-07-15 17:11 (UTC) (edited on 2022-07-15 17:18 (UTC) by wrenby)

@italic fixed, thanks for the reminder. really irritating that sourceforge doesn't appear to have a way to install an old version without building from source, so the install script just fails when a new one comes out.

italic commented on 2022-07-15 08:52 (UTC) (edited on 2022-07-15 08:53 (UTC) by italic)

I'm trying to install this today, but run into the following error when installing through pamac:

Building astap-bin-qt5...
==> Making package: astap-bin-qt5 2022.6.14-1 (Fri 15 Jul 2022 01:43:30 AM PDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found astap-2022.6.14.tar.gz
==> Validating source files with sha256sums...
astap-2022.6.14.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
Failed to build astap-bin-qt5

It appears there has been a new version uploaded on 7/13 and this is likely the culprit. I couldn't find any published hash sums to go with the package.