Package Details: asymptote-git 1:2.48.r6498-1

Git Clone URL: https://aur.archlinux.org/asymptote-git.git (read-only)
Package Base: asymptote-git
Description: A vector graphics language (like metapost)
Upstream URL: http://asymptote.sourceforge.net/
Licenses: LGPL3
Conflicts: asymptote
Provides: asymptote
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 7
Popularity: 0.004536
First Submitted: 2015-10-04 20:44
Last Updated: 2018-08-27 17:50

Dependencies (15)

Required by (2)

Sources (1)

Latest Comments

1 2 Next › Last »

supakorn-ras commented on 2018-07-10 23:57

Just to note, but the release of Asymptote 2.45 (which is right now in master) requires a few more dependencies, including python-pyqt5 and librsvg. Also, we switched to Python3.

haawda commented on 2016-12-16 20:15

New git version gives longer version numbers, no need to update.

haawda commented on 2016-03-21 05:19

flex and bison are in base-devel.

incertia commented on 2016-03-20 18:47

as of 656cf97, the makefile requires bison (https://www.archlinux.org/packages/core/x86_64/bison/) to make file 'camp.tab.cc' and flex (https://www.archlinux.org/packages/core/x86_64/flex/) to make file 'lex.yy.cc'

haawda commented on 2014-10-05 08:38

Thanks, applied.

cagprado commented on 2014-10-05 05:20

Since latest release of ghostscript, 3D pictures with text labels can’t be generated anymore. This also breaks compilation while trying to generate documentation examples…

I’ve already filled a bug ticket with a patch to the asymptote team, however, if you think it would be a good idea to add the patch to the PKGBUILD until the upstream has fixed the issue here it is: http://pastebin.com/17vWtgJP

cheers,

haawda commented on 2014-08-22 18:19

adopted again

haawda commented on 2013-12-05 19:58

Orphaning.

haawda commented on 2012-05-06 17:59

I filed a n upstream bug report (https://sourceforge.net/tracker/?func=detail&aid=3524123&group_id=120000&atid=685683). This only appears if you use my imagemagick-svn package. There is a new syntax for the convert command needed, which breaks the creation of latexusage.png.

The patch I attached to the bug report should also work with stable versions of imagemagick (e.g. the one from the repo).

cagprado commented on 2012-02-18 00:32

@kazuo

Thanks!!! Working nicely now ^^