Package Details: ath9k-htc-firmware 1.4.0-3

Git Clone URL: https://aur.archlinux.org/ath9k-htc-firmware.git (read-only)
Package Base: ath9k-htc-firmware
Description: Free firmware files for the Qualcomm Atheros AR7010 and AR9271 USB 802.11n NICs
Upstream URL: http://wireless.kernel.org/en/users/Drivers/ath9k_htc
Licenses: BSD3
Submitter: fauno
Maintainer: Emulatorman
Last Packager: Emulatorman
Votes: 7
Popularity: 1.767329
First Submitted: 2014-06-19 19:47
Last Updated: 2017-01-20 22:09

Latest Comments

Emulatorman commented on 2017-01-29 17:24

@dbedrenko btw, if i add linux-firmware in conflicts, ath9k-htc-firmware will conflict against linux-libre-firmware too.

Emulatorman commented on 2017-01-29 17:20

@dbedrenko I forgot that ath9k-htc-firmware is required by linux-libre-firmware that contains linux-firmware in conflicts and provides arrays. So you should install linux-libre-firmware to solve it.

Emulatorman commented on 2017-01-29 16:18

@dbedrenko yes you're right, i didn't paid attention on that point, thanks for let me know :)

dbedrenko commented on 2017-01-29 08:26

@Emulatorman OK, so shouldn't the PKGBUILD have "linux-firmware" in `conflicts`?

Emulatorman commented on 2017-01-28 22:21

@dbedrenko yes because ath9k-htc-firmware is built from the source instead of linux-firmware which just "copy/paste" them. Otherwise, linux-libre-firmware is a libre replacement of linux-firmware since linux-firmware contains blobs too. I separated "htc_7010.fw" and "htc_9271.fw" from linux-libre-firmware, since it needs a xtensa cross-compiling toolchain to be built.

dbedrenko commented on 2017-01-28 20:24

Hmm it seems this package conflicts with `linux-firmware` in Core. They both provide "htc_7010.fw" and "htc_9271.fw".

Emulatorman commented on 2017-01-25 16:47

@dbedrenko, you're welcome and thanks for let me know that it works well! :)

dbedrenko commented on 2017-01-25 08:09

@Emulatorman I had the same error as onny a few days ago; with the updates it builds and I got my WLAN adapter to work! Thanks for this package!

Emulatorman commented on 2017-01-22 12:52

Hi onny, i disabled build ID generation in xtensa-unknown-elf-gcc [0], check if it solves your problem.

[0]:https://aur.archlinux.org/cgit/aur.git/commit/?h=xtensa-unknown-elf-gcc&id=4d892218a5695fbba90e0bf284a386720f5a5c17

onny commented on 2017-01-22 09:08

Unable to build, even with newest xtensa build toolchain:

[ 91%] Built target firmware
make[2]: Entering directory '/home/onny/.cache/pacaur/ath9k-htc-firmware/src/open-ath9k-htc-firmware-1.4.0/target_firmware/build/k2'
make[2]: Leaving directory '/home/onny/.cache/pacaur/ath9k-htc-firmware/src/open-ath9k-htc-firmware-1.4.0/target_firmware/build/k2'
make[2]: Entering directory '/home/onny/.cache/pacaur/ath9k-htc-firmware/src/open-ath9k-htc-firmware-1.4.0/target_firmware/build/k2'
[ 94%] Generating fw.elf
/usr/lib/gcc/xtensa-unknown-elf/6.3.0/../../../../xtensa-unknown-elf/bin/ld: error: no memory region specified for loadable section `.note.gnu.build-id'
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/gen-firmware.dir/build.make:69: fw.elf] Error 1
make[2]: Leaving directory '/home/onny/.cache/pacaur/ath9k-htc-firmware/src/open-ath9k-htc-firmware-1.4.0/target_firmware/build/k2'
make[1]: *** [CMakeFiles/Makefile2:68: CMakeFiles/gen-firmware.dir/all] Error 2
make[1]: Leaving directory '/home/onny/.cache/pacaur/ath9k-htc-firmware/src/open-ath9k-htc-firmware-1.4.0/target_firmware/build/k2'
make: *** [Makefile:84: all] Error 2
make: Leaving directory '/home/onny/.cache/pacaur/ath9k-htc-firmware/src/open-ath9k-htc-firmware-1.4.0/target_firmware/build/k2'
==> ERROR: A failure occurred in build().

All comments