Package Details: atlantic-dkms 2.5.3-1

Git Clone URL: https://aur.archlinux.org/atlantic-dkms.git (read-only, click to copy)
Package Base: atlantic-dkms
Description: aquantia multigigabit nic driver - "development preview"
Upstream URL: https://github.com/Aquantia/AQtion
Licenses: GPLv2
Conflicts: atlantic
Submitter: icewind
Maintainer: None
Last Packager: icewind
Votes: 5
Popularity: 0.23
First Submitted: 2018-09-27 11:54 (UTC)
Last Updated: 2022-02-16 13:17 (UTC)

Latest Comments

icewind commented on 2022-07-26 20:18 (UTC)

Disowning as I no longer have any arch machines that needs this

ddd commented on 2022-07-26 18:26 (UTC)

There is v2.5.5 (that works without problems with 5.18) on Marvell website

andrej commented on 2022-06-05 14:23 (UTC)

This won’t build with 5.18. I’ve filed a bug upstream.

lunainvictum commented on 2022-02-11 20:16 (UTC)

Package is out of date.

See https://github.com/Aquantia/AQtion/commits/master

Latest commits have a fix for https://github.com/Aquantia/AQtion/issues/33 too

lunainvictum commented on 2021-12-09 03:29 (UTC)

Sadly this didnt build.

Same Errors like here already mentioned.

andrej commented on 2021-11-19 15:03 (UTC)

So, this makes it build. I'm not claiming that it makes it work though.

diff -Nur AQtion-c12137f82bf867240a695872b4b95f23218798f4-original/aq_ethtool.c AQtion-c12137f82bf867240a695872b4b95f23218798f4/aq_ethtool.c
--- ./AQtion-c12137f82bf867240a695872b4b95f23218798f4-original/aq_ethtool.c 2021-06-07 17:15:59.000000000 +0200
+++ ./AQtion-c12137f82bf867240a695872b4b95f23218798f4/aq_ethtool.c  2021-11-19 15:35:08.160266531 +0100
@@ -725,7 +725,9 @@
 #endif

 static int aq_ethtool_get_coalesce(struct net_device *ndev,
-                  struct ethtool_coalesce *coal)
+                  struct ethtool_coalesce *coal,
+                  struct kernel_ethtool_coalesce *,
+                  struct netlink_ext_ack *)
 {
    struct aq_nic_s *aq_nic = netdev_priv(ndev);
    struct aq_nic_cfg_s *cfg;
@@ -749,7 +751,9 @@
 }

 static int aq_ethtool_set_coalesce(struct net_device *ndev,
-                  struct ethtool_coalesce *coal)
+                  struct ethtool_coalesce *coal,
+                  struct kernel_ethtool_coalesce *,
+                  struct netlink_ext_ack *)
 {
    struct aq_nic_s *aq_nic = netdev_priv(ndev);
    struct aq_nic_cfg_s *cfg;

andrej commented on 2021-11-19 14:21 (UTC) (edited on 2021-11-19 14:22 (UTC) by andrej)

Reading the message more carefully, I see that two pointers were added into an API. If they are not used by the module in the actual function that's in the struct, maybe we could just … hack it?

However, if the semantics of that particular API / inversion-of-control have changed somehow (and hence the new pointers were added), that would be a recipe for tears.

andrej commented on 2021-11-19 14:15 (UTC) (edited on 2021-11-19 14:15 (UTC) by andrej)

This won't build with 5.15 kernels.

/var/lib/dkms/atlantic/2.4.14/build/aq_ethtool.c:1473:32: error: initialization of ‘int (*)(struct net_device *, struct ethtool_coalesce *, struct kernel_ethtool_coalesce *, struct netlink_ext_ack *)’ from incompatible pointer type ‘int (*)(struct net_device *, struct ethtool_coalesce *)’ [-Werror=incompatible-pointer-types]
 1473 |         .get_coalesce        = aq_ethtool_get_coalesce,
      |                                ^~~~~~~~~~~~~~~~~~~~~~~
/var/lib/dkms/atlantic/2.4.14/build/aq_ethtool.c:1473:32: note: (near initialization for ‘aq_ethtool_ops.get_coalesce’)
/var/lib/dkms/atlantic/2.4.14/build/aq_ethtool.c:1474:32: error: initialization of ‘int (*)(struct net_device *, struct ethtool_coalesce *, struct kernel_ethtool_coalesce *, struct netlink_ext_ack *)’ from incompatible pointer type ‘int (*)(struct net_device *, struct ethtool_coalesce *)’ [-Werror=incompatible-pointer-types]
 1474 |         .set_coalesce        = aq_ethtool_set_coalesce,
      |                                ^~~~~~~~~~~~~~~~~~~~~~~
/var/lib/dkms/atlantic/2.4.14/build/aq_ethtool.c:1474:32: note: (near initialization for ‘aq_ethtool_ops.set_coalesce’)

I can't see any upstream updates over the last few months. (Was the development moved to another repository, maybe?) In any case I've filed a bug here.

JohnDVD commented on 2021-09-02 12:52 (UTC) (edited on 2021-09-02 12:57 (UTC) by JohnDVD)

I get this message on installing it. I think it's not built. Couldn't find atlantic.ko with today's timestamp.


:: Post-transaction-Hooks werden gestartet …
(1/2) Arming ConditionNeedsUpdate...
(2/2) Install DKMS modules
==> dkms install --no-depmod -m atlantic -v 2.4.10 -k 5.13.8-gnu-1
Error! Bad return status for module build on kernel: 5.13.8-gnu-1 (x86_64)
Consult /var/lib/dkms/atlantic/2.4.10/build/make.log for more information.
==> Warning, `dkms install --no-depmod -m atlantic -v 2.4.10 -k 5.13.8-gnu-1' returned 10
==> depmod 5.13.8-gnu-1

does it conflict with new gcc?


Es werden eingebaute Spezifikationen verwendet.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/lto-wrapper
Ziel: x86_64-pc-linux-gnu
Konfiguriert mit: /build/gcc/src/gcc/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/
info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++,d --with-isl --with-linker-hash-style=gnu 
--with-system-zlib --enable-__cxa_atexit --enable-cet=auto --enable-checking=release --enable-clocale=gnu --enable-default-pie --enable-default-ss
p --enable-gnu-indirect-function --enable-gnu-unique-object --enable-install-libiberty --enable-linker-build-id --enable-lto --enable-multilib --e
nable-plugin --enable-shared --enable-threads=posix --disable-libssp --disable-libstdcxx-pch --disable-libunwind-exceptions --disable-werror gdc_i
nclude_dir=/usr/include/dlang/gdc
Thread-Modell: posix
Unterstützte LTO-Kompressionsalgorithmen: zlib zstd
gcc-Version 11.1.0 (GCC)

tubal-cain commented on 2021-07-13 17:29 (UTC)

has anyone tested this on linux-lqx, it compiles and loads the module but it doesn't create an interface.

feng commented on 2021-05-17 15:48 (UTC)

@andrej Thank you very much for the comment. It really helps a lot. For people who come across this problem, here is my solution: 0. install this package; 1. update aq_nic.h by inserting #include <linux/ethtool.h> at the beginning; 2. reinstall package linux and linux-lts.

andrej commented on 2021-03-07 01:35 (UTC)

This won't build with 5.11 (as reported e.g. here). To fix it, you need to add an include into aq_nic.h:

#include <linux/ethtool.h>

andrej commented on 2020-12-13 23:08 (UTC)

_pkgbase=atlantic
pkgname="${_pkgbase}-dkms"
pkgver=2.4.10
pkgrel=0
pkgdesc="aquantia multigigabit nic driver - \"development preview\""
url="https://github.com/Aquantia/AQtion"
arch=('x86_64')
license=('GPLv2')
depends=('dkms')
makedepends=('linux-headers')
conflicts=("${_pkgbase}")
commit="0168526fadfcf86a1c5cc7f332f4e735e934f53c"
source=("https://github.com/Aquantia/AQtion/archive/$commit.tar.gz"
        'net-v5-aquantia-Remove-the-build_skb-path.diff::http://patchwork.ozlabs.org/project/netdev/patch/MWHPR1001MB23184F3EAFA413E0D1910EC9E8FC0@MWHPR1001MB2318.namprd10.prod.outlook.com/raw/')
sha512sums=('6baf486a134d76b383c1d042a5a7e9d8be78e52971791066b8da2484fff6823d10fd7aaba71aebf41c631816c417dc9b5774e4310726d55ae94dd36dfe2e0178'
            '7141ac7adaf871959b8b78e5a716c4dae46664390850517d4302aa7120734678ecee38bc147e4587f0168dc9e0b65283d79e2bda162000bdf37766a186a54dd7')

build() {
  cd "${srcdir}/AQtion-${commit}"
  patch -p6 < ../net-v5-aquantia-Remove-the-build_skb-path.diff
}

package() {
  cd "${srcdir}/AQtion-${commit}"
  mkdir -p "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
  cp -ar * "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
  cat <<EOF >${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf
        PACKAGE_NAME="${_pkgbase}"
        BUILT_MODULE_NAME[0]="${_pkgbase}"
        PACKAGE_VERSION="${pkgver}"
        DEST_MODULE_LOCATION[0]="/kernel/drivers/net/ethernet/aquantia/atlantic"
        AUTOINSTALL="yes"
EOF
}

This^^^ works for me (with the IPv6 routing hotfix).

andrej commented on 2020-12-09 20:28 (UTC)

IPv6 is broken with this driver; it needs this patch.

icewind commented on 2020-08-31 13:09 (UTC)

thanks again

hisaruki commented on 2020-08-30 03:07 (UTC)

2.4.7 patch here https://gist.github.com/hisaruki/e41dd30cbe5ce455fe84add0d5a24a58

icewind commented on 2019-06-12 16:53 (UTC)

Updated, thanks for the patch

hisaruki commented on 2019-06-12 15:55 (UTC)

2.2.6.0 patch here https://gist.github.com/hisaruki/770959832e80beebaf20ef13fe3ec013