Package Details: audacious-vgmstream r1004-1

Git Clone URL: https://aur.archlinux.org/audacious-vgmstream.git (read-only)
Package Base: audacious-vgmstream
Description: A library for playing streamed audio from video games (for Audacious)
Upstream URL: https://github.com/kode54/vgmstream
Licenses: custom
Submitter: Splith
Maintainer: Splith
Last Packager: Splith
Votes: 0
Popularity: 0.000000
First Submitted: 2016-04-02 20:22
Last Updated: 2016-04-02 20:30

Latest Comments

kode54 commented on 2019-01-02 01:48

This package should be deprecated in favor of vgmstream-kode54-git anyway, as it appears to only be a single purpose package, and having the wrong Makefile name isn't the only thing it's missing relative to that other package.

It doesn't do Git versioning, so its pkgver must be set manually.

It doesn't patch the pkg-config invocation in configure.ac to specify a prefix when querying the plugindir for Audacious.

It doesn't support linking in FFmpeg, mpg123, G.7221, ATRAC9, or the two obsolete libcelt versions used to support various formats.

Maybe just let it die, and people can find the other package instead?

TerusTheBird commented on 2018-11-21 22:16

This doesn't compile even with the required changes to the makefile

Star-X commented on 2018-04-15 03:25

There's an error in the pkgbuild file. It looks for Makefile.unix, but such a file doesn't exist in the repository. The file it actually needs is Makefile.autotools.