Package Details: audible-activator-git 1:0.2+r3.20181128.2e97c84-4

Git Clone URL: https://aur.archlinux.org/audible-activator-git.git (read-only, click to copy)
Package Base: audible-activator-git
Description: A script to retrieve your activation data (activation_bytes) from Audible servers. Use it to play your aax or aax+ files downloaded from amazon audible. Needs chrome or chromium.
Upstream URL: http://github.com/inAudible-NG/audible-activator
Licenses: GPL3
Conflicts: audible-activator
Provides: audible-activator=0.2+r3.20181128.2e97c84
Replaces: audible-activator<=0.2+r3.20181128.2e97c84
Submitter: dreieck
Maintainer: dreieck
Last Packager: dreieck
Votes: 11
Popularity: 0.000011
First Submitted: 2016-08-31 07:58
Last Updated: 2019-08-29 15:29

Latest Comments

1 2 Next › Last »

pokulo commented on 2021-01-28 08:54

Please switch to Python3. This worked for me:

$ diff old/PKGBUILD new/PKGBUILD
6,7c6,7
< pkgver=0.2+r3.20181128.2e97c84
< pkgrel=4
---
> pkgver=0.2+r4.20200714.35cd22e
> pkgrel=1
20,23c20,23
<   "python2"
<   "python2-requests"
<   "python2-selenium"
<   "python2-urllib3"
---
>   "python"
>   "python-requests"
>   "python-selenium"
>   "python-urllib3"

The only new this is seemingly this log entry:

rm: cannot remove '/tmp/tmp.a6pumjLSYS/__pycache__': Is a directory

But I dont see any harm in this.

Svenstaro commented on 2021-01-04 17:33

You can try to switch the package to Python 3. It should work according to upstream.

Blutkoete commented on 2020-10-04 07:49

If you want this PKGBUILD to work, you need to make it use python2 in audible-activator.py. You can replace the prepare() function by the following (only the "sed" command is new):

prepare() {
  cd "${srcdir}/${_pkgname}"
  patch -p1 < "${srcdir}/audible-activator.chromedriverpath.patch"
  sed -i 's/python/python2/' audible-activator.py
}

KaMii commented on 2020-09-06 10:58

Traceback (most recent call last): File "./audible-activator.py", line 10, in <module> import requests ModuleNotFoundError: No module named 'requests' /usr/bin/makepkg: Error: Could not determine version.

dreieck commented on 2019-08-29 15:38

@DrosteEffect: python2-selenium now also is in the AUR (again). Can you check if it works for you?

dreieck commented on 2019-08-29 15:25

@lilmike: Done.

dreieck commented on 2019-08-29 15:24

@DrosteEffect:

python2-selenium is still available from the [archstrike] repo.

lilmike commented on 2019-08-06 07:47

Should makedepend on git, otherwise making in a chroot fails with unable to find the git package to handle git sources.

darthmobius commented on 2019-03-28 16:00

A temporary workaround to satisfy the python2-selenium dependency is to manually install selenium via pip2 (e.g. pip2 install --user selenium).

DrosteEffect commented on 2019-03-24 21:37

The python2-selenium dependency is broken.