Package Details: audio-recorder 1.8.0-1

Git Clone URL: https://aur.archlinux.org/audio-recorder.git (read-only)
Package Base: audio-recorder
Description: Free audio-recorder for Linux
Upstream URL: https://launchpad.net/~audio-recorder
Keywords: multimedia
Licenses: GPL3
Submitter: sistematico
Maintainer: Spike29
Last Packager: Spike29
Votes: 27
Popularity: 0.496906
First Submitted: 2012-08-14 12:55
Last Updated: 2016-08-24 11:40

Latest Comments

Spike29 commented on 2016-08-28 13:57

@ltorvalds024: I think I had some recording issues as well. I fixed it by selecting "Audio output" as the source, instead of "System Default Device".
I just made a test, MP3 recording works with this setup.

ltorvalds024 commented on 2016-08-27 10:29

@Spike29 yes, I have that installed already

Spike29 commented on 2016-08-07 07:57

@ltorvalds024: did you install gst-plugins-ugly? (optional dependency for MP3 recording)

ltorvalds024 commented on 2016-08-07 07:53

the newer version is not recording at all, tried all the options. Getting empty mp3 files. I am running latest arch linux with gnome 3.20

anthillsocial commented on 2016-01-07 11:41

I'm getting this error:

==> Finished making: audio-recorder 1.7.5-1 (Thu 7 Jan 11:37:50 GMT 2016)
loading packages...
error: 'libappindicator-gtk3-*.pkg.tar.xz': could not find or read package
error: 'libappindicator-sharp-*.pkg.tar.xz': could not find or read package

Spike29 commented on 2015-05-11 19:46

Thanks a lot for your patch and your updated PKGBUILD, goetzc !

I also updated to version 1.6.3 - it's the latest version distributed in the Ubuntu PPA repository.

goetzc commented on 2015-05-11 18:47

This fails to build with GTK 3.16.
Please, apply this patch: http://pastebin.com/ec2pV969

updated PKGBUILD: http://pastebin.com/XZ0y21Y4

Spike29 commented on 2015-03-01 21:12

Updated.

Unfortunately, "libappindicator-gtk3" is now required (it's no longer an optional dependency) since classic tray icon support was removed from audio-recorder 1.6.0.
audio-recorder won't build without this dependency.

Spike29 commented on 2015-03-01 18:36

Thanks, I'll update the package later today or tomorrow.

benuski commented on 2015-03-01 17:16

Version 1.6.2 is the current version.

Spike29 commented on 2013-08-16 09:24

I found out that the latest version is 1.2 and is available on audio-recorder's PPA for Ubuntu Saucy : https://launchpad.net/~osmoma/+archive/audio-recorder.

Also, namcap considers pulseaudio, gst-plugins-base and gst-plugins-good as "unneeded" dependencies (libpulse and gstreamer should be enough in theory).
But in practice, audio-recorder won't start if pulseaudio isn't running, and gst-plugins-good provides the "libgstpulse.so" library, which is required for recording ability.
Moreover, gst-plugins-base must be installed alongside gst-plugins-good for true WAV encoding.

Spike29 commented on 2013-08-15 20:50

I found out that the latest version is 1.2 and is available on audio-recorder's PPA for Ubuntu Saucy : https://launchpad.net/~osmoma/+archive/audio-recorder.

Also, namcap considers pulseaudio as an "unneeded" dependency (libpulse should be enough in theory).
However, audio-recorder won't start if pulseaudio isn't running... :-)

Spike29 commented on 2013-08-15 20:49

I found out that the latest version is 1.2 and is available on audio-recorder's PPA for Ubuntu Saucy : https://launchpad.net/~osmoma/+archive/audio-recorder.

Also, namcap considers pulseaudio as an "unneeded" dependency (libpulse should be enough in theory).
However, audio-recorder won't start if pulseaudio isn't running... :)

Spike29 commented on 2013-08-15 20:33

I found out that the latest version is 1.2 and is available on audio-recorder's PPA for Ubuntu Saucy : https://launchpad.net/~osmoma/+archive/audio-recorder.

Spike29 commented on 2013-08-15 16:22

I found out that the latest version is 1.2 and is available on audio-recorder's PPA for Ubuntu Saucy : https://launchpad.net/~osmoma/+archive/audio-recorder.

Spike29 commented on 2013-08-15 10:47

Hi, I just owned this package and updated it to version 1.1.
I also removed unneeded dependencies, added "intltool" as a makedepend, and added "audio-recorder.install" file with glib-compile-schemas and gtk-update-icon-cache commands.

Anonymous comment on 2013-06-24 09:11

Following command does the trick:
$ sudo glib-compile-schemas /usr/share/glib-2.0/schemas
Moreover, I had to install 'intltool' to compile the source.

hobarrera commented on 2012-12-23 06:09

$ audio-recorder
Error: Cannot find settings for /apps/audio-recorder/ in GNOME's registry. Please run "make install" as sudo or root user.
Cannot continue. Terminating this program.

Any hints?

ShyPixie commented on 2012-10-16 16:59

Please, add .install file and call glib-compile-schemas and gtk-update-icon-cache.
It is necessary to commit org.gnome.audio-recorder.gschema.xml and to update the icon cache.

Add dependencies:

hicolor-icon-theme (needed for hicolor theme hierarchy)
dconf (needed for glib schemas)

Remove:

gtk3 (libgnome-media-profiles already depends on the gtk3)
gstreamer0.10-base (gstreamer0.10-*-plugins already depends on the gstreamer0.10-base)
libpulse (gstreamer0.10-plugins already depends on the libpulse)

sistematico commented on 2012-10-03 18:45

Added, thanks!

Spike29 commented on 2012-08-14 14:51

Hi,

gtk3, libgnome-media-profiles and libpulse should be added to dependencies :)