Package Details: aura-bin 1.3.6-1

Git Clone URL: https://aur.archlinux.org/aura-bin.git (read-only)
Package Base: aura-bin
Description: A secure package manager for Arch Linux and the AUR written in Haskell - Prebuilt binary
Upstream URL: https://github.com/fosskers/aura
Licenses: GPL-3
Conflicts: aura, aura-git
Provides: aura
Submitter: fosskers
Maintainer: fosskers
Last Packager: fosskers
Votes: 134
Popularity: 5.379601
First Submitted: 2013-05-12 11:50
Last Updated: 2016-04-20 17:46

Dependencies (7)

Required by (1)

Sources (1)

Latest Comments

despairblue commented on 2016-05-17 07:27

@fosskers sry, the notification for your comment must have slipped through...

I think it was in the PKGBUILD, though it seems to have been fixed by now.

Thx for your awesome work on this!

fosskers commented on 2016-04-22 16:02

@despairblue where did you come about that link?

despairblue commented on 2016-04-22 08:17

@fosskers https://bitbucket.org/fosskers/aura/downloads/aura-1.3.6-x86_6 does not point to any file.

fosskers commented on 2016-03-29 14:32

It was an issue with the `aur` library that aura uses, which has been fixed now with `1.3.5`.

**Details**

Internally, all requests were being sent to aur4.archlinux.org. Recently the arch folks did an SSL certificate renewal, and didn't renew the aur4 subdomain. Thus the `aur` haskell library broke, and so did aura.

altercation commented on 2016-03-26 18:47

aura (via this aura-bin package) was failing for me suddenly. I uninstalled the package and reinstalled (via normal git clone of this package repo and makepkg) and it's working working again. I suspect clearning the aura cache might have had a similar effect. Just noting this here for anyone else seeing the same issue.

epidings commented on 2016-03-25 20:24

The new version 1.3.5 won't update my AUR packages:

> aura -Au
aura >>= Fetching package information...
aura >>= Comparing package versions...
aura >>= No AUR package upgrades necessary.
aura >>= No valid packages specified.

The former version 1.3.4 (with the fix from anks) finds several packages in need of an update:

> aura -Au
aura >>= Fetching package information...
aura >>= Comparing package versions...
aura >>= AUR Packages to upgrade:
atom-editor-bin : 1.5.4-1 => 1.6.0-1
...

fosskers commented on 2016-03-24 20:44

Fixed! Thanks for your patience, everyone.

uiae commented on 2016-03-22 13:50

Thanks anks!

anks commented on 2016-03-21 19:15

In case you were getting the following error:

aura >>= The following are not AUR packages ...

Here's some hackish fix:

sudo sed -i 's/https:\/\/aur4.archlinux.org\//https:\/\/aur.archlinux.org\/\x00/' /usr/bin/aura

The error is caused (probably) by the recent change of certificates, correct me if I am wrong.

fosskers commented on 2015-11-20 22:37

If you take a look at the PKGBUILD, you'll that the $CARCH variable is being used in the source file. The AUR software strips those out when it posts them here, as $CARCH depends on the user's system and the server has no way to know it.

All comments