Package Details: aurman 2.20.1-2

Git Clone URL: (read-only, click to copy)
Package Base: aurman
Description: AUR helper with almost pacman syntax
Upstream URL:
Licenses: MIT
Submitter: polygamma
Maintainer: polygamma
Last Packager: polygamma
Votes: 202
Popularity: 1.45
First Submitted: 2018-03-20 21:31
Last Updated: 2021-06-19 12:54

Pinned Comments

polygamma commented on 2018-08-21 18:02

aurman development for public use has been stopped. i suggest migrating to yay, i am not interested in any kind of feedback, bug reports, feature requests etc. anymore.

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 Next › Last »

polygamma commented on 2018-06-05 21:29

heads up regarding python-requests:

Morganamilo commented on 2018-06-05 19:39

And yes it is too much to go to github to report bugs/behaviour, what exactly do you think the comments here are for?

They are for reporting issues with the PKGBUILD. Not for reporting bugs for upstream.

porcaror commented on 2018-06-05 19:29

Thank you very much. I think that aurman is a great package!

polygamma commented on 2018-06-05 16:25

@porcaror - see

porcaror commented on 2018-06-05 15:43

When I try to use aurman -Syu (your last version) I have the following error:

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 570, in _build_master
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 888, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 779, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (urllib3 1.23 (/usr/lib/python3.6/site-packages), Requirement.parse('urllib3<1.23,>=1.21.1'), {'requests'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/aurman", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 3095, in <module>
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 3079, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 3108, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 572, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 585, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.6/site-packages/pkg_resources/", line 774, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'urllib3<1.23,>=1.21.1' distribution was not found and is required by requests

Can you help me?

fenuks commented on 2018-06-03 13:42

@polygamma Git ensures that repository is valid, but approach with checksum gives quarantee that code hasn't changed since PKGBUILD was published, for example someone hacking your Github account and adding malicious code to repository. And probably should be marginally faster, as already pre-compressed single file is being downloaded. :-))

polygamma commented on 2018-06-03 11:07

@fenuks I do not think this would give any benefits. git ensures in the current case the validity of the files

fenuks commented on 2018-06-03 09:50

Hello, thank you for the work behind aurman. I have suggestion regarding PKGBUILD. Why not use archives with source that are available for every release?It would allow utilizing checksum checking which is nice gain.

Archer1X commented on 2018-05-29 03:38

frealgagu, you have to uninstall/remove the old version of aurman first. Then reinstall it manually. It will install newest pacman as its new dependency.

frealgagu commented on 2018-05-28 23:39

The following is happening to me:

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: aurman: installing pacman (5.1.0-1) breaks dependency 'pacman<5.1'