Package Details: aurvote-git r27.fd413f1-3

Git Clone URL: https://aur.archlinux.org/aurvote-git.git (read-only, click to copy)
Package Base: aurvote-git
Description: Tool to vote for your favorite AUR packages (development version)
Upstream URL: https://github.com/archlinuxfr/aurvote
Licenses: GPL
Conflicts: aurvote
Provides: aurvote
Submitter: neersighted
Maintainer: TheGoliath
Last Packager: TheGoliath
Votes: 1132
Popularity: 2.98
First Submitted: 2013-02-27 22:18
Last Updated: 2020-05-18 15:43

Dependencies (2)

Required by (0)

Sources (1)

Pinned Comments

TheGoliath commented on 2020-05-18 15:44

CO-MAINTENANCE

I don't want this package to get into a situation where it no longer receives updates or patches. Therefore I would like to ask anyone who is willing to take part in the maintenance of the package, to contact me via email!

BINARY PACKAGES ARE PROVIDED IN AN UNOFFICIAL REPOSITORY

The maintainer of this package provides signed binary packages in an unofficially signed repository, which he created and manages himself. These packages are pre-built binary files straight from the PKGBUILD. You can also use them.

Latest Comments

1 2 3 4 5 6 Next › Last »

TheGoliath commented on 2020-05-18 15:44

CO-MAINTENANCE

I don't want this package to get into a situation where it no longer receives updates or patches. Therefore I would like to ask anyone who is willing to take part in the maintenance of the package, to contact me via email!

BINARY PACKAGES ARE PROVIDED IN AN UNOFFICIAL REPOSITORY

The maintainer of this package provides signed binary packages in an unofficially signed repository, which he created and manages himself. These packages are pre-built binary files straight from the PKGBUILD. You can also use them.

hashhar commented on 2017-04-12 19:56

EDIT: Seems you do have a bash-completion script but the PKGBUILD doesn't install it. WHY?

I have written a bash-completion script for this that I find useful for myself.

You can find it here. https://gist.github.com/hashhar/83053afdf4c829e8d41f05d321e87ae7

It completes the flags and optionally completes currently installed package names when completing either the '-v' '--vote' '-u' or '--unvote' options.

QUESTION: Should I complete only locally installed AUR packages or remote AUR packages too?

Currently I complete all locally installed AUR packages.

Det commented on 2015-08-05 00:41

Did you forget about this?

Det commented on 2015-07-23 18:04

You can also add co-maintainers in AUR 4.

neersighted commented on 2015-07-23 16:25

I am currently on vacation until August 2. Thanks for the comments, I'll deal with them when I get home.

Det commented on 2015-07-19 21:17

Also, the pkgver() isn't apparently getting updated even in the PKGBUILD, because there are no tags. You should use the number of commits, followed by the id.

thiagowfx commented on 2015-07-18 20:47

Hi there,

Since this [1] has been merged today, could you please update the PKGBUILD to add zsh-completion to the package?

There is a suggestion of PKGBUILD in the page I linked.


[1]: https://github.com/archlinuxfr/aurvote/pull/5

respiranto commented on 2015-07-12 11:35

Just in case somebody else wants the ability to use the aur4-subdomain:

One has to either modify the script:
AUR_URL="https://aur4.archlinux.org"
AUR_DOMAIN="aur4.archlinux.org"

or the $CONFIGFILE ( ${XDG_CONFIG_HOME:-~/.config}/aurvote ):
AUR_URL="https://aur4.archlinux.org"
AUR_URL_LOGIN="$AUR_URL/login/"
AUR_URL_PKG_INFO="$AUR_URL/rpc.php?type=info&arg="
AUR_URL_PKG_PAGE="$AUR_URL/packages/"
AUR_URL_PKG_ACTION="$AUR_URL/pkgbase/"
AUR_DOMAIN="aur4.archlinux.org"

The other variables are here necessary because they are set in the script before the $COFIGFILE is sourced.

Det commented on 2015-07-09 16:31

Why not a proper version, instead of the "latest"?

Det commented on 2015-07-09 16:30

Maybe this could actually be merged with aurvote-git, since there are no separate releases: https://aur4.archlinux.org/packages/aurvote-git/, https://github.com/archlinuxfr/aurvote/releases

That's probably why archlinuxfr didn't pull this in AUR 4.