Package Details: authelia 4.38.9-1

Git Clone URL: https://aur.archlinux.org/authelia.git (read-only, click to copy)
Package Base: authelia
Description: The Cloud ready multi-factor authentication portal for your Apps.
Upstream URL: https://github.com/authelia/authelia
Licenses: Apache-2.0
Conflicts: authelia-bin, authelia-git
Submitter: nightah
Maintainer: nightah (clems4ever)
Last Packager: nightah
Votes: 2
Popularity: 0.002689
First Submitted: 2020-01-23 09:42 (UTC)
Last Updated: 2024-06-16 09:59 (UTC)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

nightah commented on 2024-04-01 09:01 (UTC)

Thanks @khangp0000 for the notification, I've just resolved the issue.

khangp0000 commented on 2024-03-31 21:01 (UTC) (edited on 2024-03-31 21:05 (UTC) by khangp0000)

go is making ${srcdir}/gopath/* and its subfolder readonly, make it not possible to rm unless you chmod recursively to add write permission or sudo rm, even when you own the file.

Can you add -modcacherw to go build so that the ${srcdir} folder can be easily clean up after build. I use paru and have to manually delete the gopath folder every time after update (or during next update if I was lazy). (You can check the Flags and build options in https://wiki.archlinux.org/title/Go_package_guidelines to see what that flag means)

nightah commented on 2023-10-09 03:26 (UTC)

Apologies for the delay in fixing this, I've just pushed a version that should resolve the frozen lockfile issue with pnpm. If you continue to have issues please let me know.

kuon commented on 2023-10-08 01:01 (UTC)

I also have the ERR_PNPM_FROZEN_LOCKFILE_WITH_OUTDATED_LOCKFILE error, any workaround?

plexman commented on 2023-08-19 23:53 (UTC) (edited on 2023-08-19 23:54 (UTC) by plexman)

Failed to build:

==> Iniciando build()...
ERR_PNPM_FROZEN_LOCKFILE_WITH_OUTDATED_LOCKFILE  Cannot perform a frozen installation because the version of the lockfile is incompatible with this version of pnpm

Try either:
1. Aligning the version of pnpm that generated the lockfile with the version that installs from it, or
2. Migrating the lockfile so that it is compatible with the newer version of pnpm, or
3. Using "pnpm install --no-frozen-lockfile".
Note that in CI environments, this setting is enabled by default.
==> ERROR: Se produjo un fallo en build().
Cancelando...
error: no se pudo construir 'authelia-4.37.5-2':
error: no se pudieron construir los siguientes paquetes: authelia-4.37.5-2

nightah commented on 2023-01-22 08:31 (UTC)

Thanks for the report @feinedsquirrel, this should now be fixed.

feinedsquirrel commented on 2023-01-19 17:58 (UTC) (edited on 2023-01-19 17:59 (UTC) by feinedsquirrel)

Fully updated Arch Linux system. Current pkgver: 4.37.5-1

Fails to build, "eslint" conflict

I looked through the issues on GitHub, but didn't see any that relate to this. Not sure if it is an Arch problem, or an issue in the project.

[vite-plugin-eslint] Plugin "import" was conflicted between ".eslintrc.js » plugin:import/warnings" and ".eslintrc.js » eslint-config-react-app".
file: /home/myuser/authelia/src/authelia-4.37.5/web/src/index.tsx
error during build:
Error: Plugin "import" was conflicted between ".eslintrc.js » plugin:import/warnings" and ".eslintrc.js » eslint-config-react-app".
    at mergePlugins (/home/myuser/authelia/src/authelia-4.37.5/web/node_modules/@eslint/eslintrc/dist/eslintrc.cjs:598:19)
    at createConfig (/home/myuser/authelia/src/authelia-4.37.5/web/node_modules/@eslint/eslintrc/dist/eslintrc.cjs:701:9)
    at ConfigArray.extractConfig (/home/myuser/authelia/src/authelia-4.37.5/web/node_modules/@eslint/eslintrc/dist/eslintrc.cjs:877:33)
    at CLIEngine.isPathIgnored (/home/myuser/authelia/src/authelia-4.37.5/web/node_modules/eslint/lib/cli-engine/cli-engine.js:990:18)
    at ESLint.isPathIgnored (/home/myuser/authelia/src/authelia-4.37.5/web/node_modules/eslint/lib/eslint/eslint.js:681:26)
    at Object.transform (/home/myuser/authelia/src/authelia-4.37.5/web/node_modules/vite-plugin-eslint/dist/index.js:1:2348)
    at file:///home/myuser/authelia/src/authelia-4.37.5/web/node_modules/vite/node_modules/rollup/dist/es/shared/rollup.js:23704:40
    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)

yarn --version
1.22.19

node --version
v19.4.0

nightah commented on 2021-12-21 09:03 (UTC)

I'm unable to reproduce this issue on the current version, can you please provide your version of authelia, yarn and nodejs and explicit reproduction steps please?

ja203 commented on 2021-12-19 21:50 (UTC)

Error when making -

error @typescript-eslint/eslint-plugin@5.5.0: The engine "node" is incompatible with this module. Expected version "^12.22.0 || ^14.17.0 || >=16.0.0". Got "15.6.0"

I've got around by running yarn config set ignore-engines true and rerunning makepkg; seems to fix but don't know if this the right way to fix

nightah commented on 2021-09-16 23:23 (UTC)

Thanks for the report @gdamjan, this has been fixed.