Package Details: autoenv-git 0.2.1.r11.gd6b7db1-1

Git Clone URL: https://aur.archlinux.org/autoenv-git.git (read-only)
Package Base: autoenv-git
Description: Directory based enviroments
Upstream URL: https://github.com/kennethreitz/autoenv
Keywords: autoenv
Licenses: custom
Conflicts: autoenv
Submitter: jyantis
Maintainer: vignkri
Last Packager: vignkri
Votes: 8
Popularity: 0.002176
First Submitted: 2014-09-30 19:09
Last Updated: 2017-10-25 13:31

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

vignkri commented on 2016-11-03 15:48

Fixed the PKGBUILD error in Line 32. Now it will cd to the correct directory.

Dreadman commented on 2016-11-03 15:30

There is a mistake in the PKGBUILD.
Line 32 should be "cd autoenv-git" instead of "cd autoenv". Currently makepkg fails with "PKGBUILD: line 32: cd: autoenv: No such file or directory"

ryukinix commented on 2016-10-22 19:38

Why this package always ask about upgrade? I don't understand. After create the package, the version is the same of the earlier. This never stop! WTF. Check here:

❯ yaourt -Syuu --aur
[sudo] password for lerax:
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
python2-oauth2client1412 : Orphan
rhythmbox-tray-icon : Orphan
Foreign packages: / 45 / 45

==> Software upgrade (new version) :
aur/autoenv-git 0.2.0.r185.92d2f3b-1 -> 1.0.0.r102.c4bc3f5-2
aur/google-chrome 54.0.2840.59-1 -> 54.0.2840.71-1

==> Continue upgrade ? [Y/n]
==> [V]iew package detail [M]anually select packages
==> --------------------------------------------------
==> y

==> Downloading autoenv-git PKGBUILD from AUR...
x .SRCINFO
x PKGBUILD
x autoenv.install
autoenv-git 1.0.0.r102.c4bc3f5-2 (2015-06-11 15:07)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==>

Waiting for Emacs...
==> autoenv-git dependencies:
- bash (already installed)
- git (already installed) [makedepend]


==> Edit autoenv.install ? [Y/n] ("A" to abort)
==> -------------------------------------------
==>

Waiting for Emacs...
==> Continue building autoenv-git ? [Y/n]
==> -------------------------------------
==> y

==> Building and installing package
==> Making package: autoenv-git 1.0.0.r102.c4bc3f5-2 (Sat Oct 22 16:37:28 BRT 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning autoenv git repo...
Cloning into bare repository '/tmp/yaourt-tmp-lerax/aur-autoenv-git/autoenv'...
remote: Counting objects: 683, done.
remote: Compressing objects: 100% (4/4), done.
remote: Total 683 (delta 1), reused 0 (delta 0), pack-reused 679
Receiving objects: 100% (683/683), 98.55 KiB | 0 bytes/s, done.
Resolving deltas: 100% (342/342), done.
==> Validating source files with sha256sums...
autoenv ... Skipped
==> Extracting sources...
-> Creating working copy of autoenv git repo...
Cloning into 'autoenv'...
done.
==> Starting pkgver()...
fatal: No annotated tags can describe '7eb70eca0039f757525a2f88f008e647a492d7f1'.
However, there were unannotated tags: try --tags.
==> Updated version: autoenv-git 0.2.0.r187.7eb70ec-1
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
-> Removing libtool files...
-> Purging unwanted files...
-> Removing static library files...
-> Stripping unneeded symbols from binaries and libraries...
-> Compressing man and info pages...
==> Checking for packaging issue...
==> Creating package "autoenv-git"...
-> Generating .PKGINFO file...
-> Generating .BUILDINFO file...
-> Adding install file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: autoenv-git 0.2.0.r187.7eb70ec-1 (Sat Oct 22 16:37:31 BRT 2016)
==> Cleaning up...
==> Exporting autoenv-git to /var/cache/pacman/pkg/ directory
'/tmp/yaourt-tmp-lerax/PKGDEST.fYe/autoenv-git-0.2.0.r187.7eb70ec-1-any.pkg.tar.xz' -> '/var/cache/pacman/pkg/autoenv-git-0.2.0.r187.7eb70ec-1-any.pkg.tar.xz'

==> Continue installing autoenv-git ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==>

loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) autoenv-git-0.2.0.r187.7eb70ec-1