Package Details: automatic 0.8.3-5

Git Clone URL: https://aur.archlinux.org/automatic.git (read-only, click to copy)
Package Base: automatic
Description: RSS downloader for Linux based systems, capable of adding downloaded torrents directly to Transmission
Upstream URL: http://forum.dsmg600.info/viewtopic.php?id=2291
Licenses: GPLv2
Submitter: mfpuente.ar
Maintainer: xpt
Last Packager: xpt
Votes: 19
Popularity: 0.000000
First Submitted: 2010-01-03 17:35 (UTC)
Last Updated: 2020-04-10 03:12 (UTC)

Latest Comments

mutantmonkey commented on 2015-10-18 23:17 (UTC)

I updated the package to install /etc/automatic.conf, but this might be better fixed upstream. The package itself shouldn't touch things in your $HOME, so this is a bug in automatic itself that should be taken upstream. Try creating .config in your $HOME to see if that makes it happy.

idomeneo1 commented on 2015-10-18 22:55 (UTC)

The config files are not installing properly: 1. The application is not finding the global config file under its current name. There needs to be something like: cp /etc/automatic.conf-sample /etc/automatic.conf 2. No config files are showing up anywhere in my $HOME or $HOME/config folder: ../src/state.c, 115: [load_state] Error: Unable to open statefile '/home/$USER/.config/automatic.state' for reading: No such file or directory

noalwin commented on 2014-12-08 14:56 (UTC)

Shouldn't the service depend on transmission? https://wiki.archlinux.org/index.php/Systemd#Handling_dependencies

prg commented on 2014-01-02 19:07 (UTC)

Not sure if the homepage is temporarily down or permanently down (http://kylek.is-a-geek.org:31337/Automatic/). FWIW here is the github project page: https://github.com/1100101/Automatic

mutantmonkey commented on 2013-06-22 21:28 (UTC)

Thanks, updated.

deimos commented on 2013-06-22 21:25 (UTC)

current version is 0.8.3 sha256sum=1b5c5c65989d12dc7dcdd031dd7d0c1efad80062d615f63836ac86bd010908b8

mutantmonkey commented on 2012-11-27 19:49 (UTC)

Try with this new version, sorry about that.

commented on 2012-11-27 19:40 (UTC)

Hi @mutantmonkey! automatic 0.8.1-1 doesn't build. Here is my log: Targets (1): automatic-0.8.1-1 Proceed with installation? [Y/n] Y :: Retrieving source tarball from AUR... ######################################################################## 100.0% :: Extracting source tarball... :: Building package... ==> Making package: automatic 0.8.1-1 (Tue Nov 27 19:08:42 CET 2012) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving Sources... -> Downloading v0.8.1.tar.gz... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 125 100 125 0 0 186 0 --:--:-- --:--:-- --:--:-- 228 100 99k 100 99k 0 0 46624 0 0:00:02 0:00:02 --:--:-- 113k -> Found automaticd.rc -> Found automaticd.conf -> Found automatic.service ==> Validating source files with sha256sums... v0.8.1.tar.gz ... Passed automaticd.rc ... Passed automaticd.conf ... Passed automatic.service ... Passed ==> Extracting Sources... -> Extracting v0.8.1.tar.gz with bsdtar ==> Starting build()... /root/AUR/automatic/PKGBUILD: line 23: cd: /root/AUR/automatic/src/1100101-Automatic-ae2ed5f: No such file or directory ==> ERROR: A failure occurred in build(). Aborting... notice: automatic failed while building, remove source files (/root/AUR/automatic)? [Y/n] Y warning: package automatic failed to build and won't be installed. I tried to comment out the "cd" lines in PKGBUILD but had no success. I hope you can fix it, @mutantmonkey!

mutantmonkey commented on 2012-11-14 20:10 (UTC)

Fixed and updated

necopinus commented on 2012-11-14 19:48 (UTC)

Anyone else getting 404 errors? NOT WORKING: https://nodeload.github.com/1100101/Automatic/tarball/v0.8.0 WORKING: https://github.com/1100101/Automatic/archive/v0.8.0.zip Also, 0.8. is out.

mutantmonkey commented on 2012-11-14 02:42 (UTC)

Added a systemd unit

brando56894 commented on 2012-07-12 03:12 (UTC)

could you please correct the PKGBUILD so that automatic.conf-sample is in /etc instead of /usr/etc ?

guisacouto commented on 2012-07-01 20:06 (UTC)

v0.8 is out. Can you update the PKGBUILD? tks

mfpuente.ar commented on 2011-06-07 19:47 (UTC)

yes, transmission-cli is optional. Fixed. Thanks

Glaucous commented on 2011-06-07 19:32 (UTC)

Yes it clearly says on the site that the only dependencies are libcurl (http://curl.haxx.se/) libxml2 (http://xmlsoft.org/) libpcre (http://www.pcre.org/)

tomk commented on 2010-10-04 09:19 (UTC)

I'm not getting any headers in /, and you can use --sysconfdir to fix the /usr/etc issue. Also, this app does not depend on transmission-cli, it should be removed from depends=.

mfpuente.ar commented on 2010-04-25 18:17 (UTC)

@kmaglione: yes, I contact to the developer and he knows this issue, he is working to fix this

kmaglione commented on 2010-04-23 22:18 (UTC)

This package is a bit of a mess. It dumps a bunch of headers in / and puts automatic.conf-sample in /usr/etc.