Package Details: avant-window-navigator 0.4.2-4

Git Clone URL: https://aur.archlinux.org/avant-window-navigator.git (read-only)
Package Base: avant-window-navigator
Description: AWN is a customisable dock-like bar at the edge of the screen.
Upstream URL: https://launchpad.net/awn
Keywords: dock launcher panel
Licenses: GPL
Submitter: xyproto
Maintainer: SanskritFritz
Last Packager: SanskritFritz
Votes: 47
Popularity: 0.888271
First Submitted: 2013-10-09 14:28
Last Updated: 2015-06-13 22:42

Latest Comments

SanskritFritz commented on 2016-04-24 18:50

Try libdesktop-agnostic-git.

JuHwon commented on 2016-04-24 11:29

i get an error while installing the libdesktop-agnostic dependency ( with yaourt):

../libdesktop-agnostic/ui-launcher-editor-dialog.vala:99.21-99.53: warning: unhandled error `GLib.Error'
../libdesktop-agnostic/ui-launcher-editor-dialog.vala:49.5-50.15: warning: method `DesktopAgnostic.UI.FixedTable.attach_fill' never used
Waf: Leaving directory `/tmp/yaourt-tmp-hown/aur-libdesktop-agnostic/src/libdesktop-agnostic-0.3.92/build'
Build failed
-> task failed (err #1):
{task: valac_task config.vala,config-bridge.vala,config-client.vala,config-schema.vala,config-schema-option.vala,config-schema-type.vala -> config.c,config.h,desktop-agnostic-cfg.vapi,desktop-agnostic-cfg.deps,config-bridge.c,config.h,desktop-agnostic-cfg.vapi,desktop-agnostic-cfg.deps,config-client.c,config.h,desktop-agnostic-cfg.vapi,desktop-agnostic-cfg.deps,config-schema.c,config.h,desktop-agnostic-cfg.vapi,desktop-agnostic-cfg.deps,config-schema-option.c,config.h,desktop-agnostic-cfg.vapi,desktop-agnostic-cfg.deps,config-schema-type.c,config.h,desktop-agnostic-cfg.vapi,desktop-agnostic-cfg.deps,config.h}
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build libdesktop-agnostic.

SanskritFritz commented on 2015-12-10 05:59

I have libdesktop-agnostic-git installed which provides libdesktop-agnostic, AWN compiles and works here.

cb474 commented on 2015-12-10 00:07

Which libdesktop-agnostic package did you install? I noticed above in the dependencies there's a link to two different versions in AUR. libdesktop-agnostic 0.3.92-8, which is the first link. And libdesktop-agnostic-git 2013.11.01-1, which is the link in parantheses.

I have libdesktop-agnostic 0.3.92-8 installed and AWN is working for me. Although I installed it a long time ago, so I guess I don't know what would happen if I tried using the current PKGBUILD.

dzuykhanh commented on 2015-12-09 04:30

I tried to install AWN but when I run "makepkg -s" it always gives the error missing dependency libdesktop-agnostic, though I have installed libdesktop-agnostic.

So, how can I fix this? Please help me.

Thanks.

SanskritFritz commented on 2015-07-09 20:18

Here it is different:
> namcap avant-window-navigator-0.4.2-4-x86_64.pkg.tar
avant-window-navigator W: Dependency pygtk included but already satisfied
avant-window-navigator W: Dependency hicolor-icon-theme included but already satisfied

bidulock commented on 2015-07-09 03:57

[brian@napoleon avant-window-navigator]$ namcap avant-window-navigator-0.4.2-4-i686.pkg.tar.xz
avant-window-navigator W: Referenced library 'libawn.so.1' is an uninstalled dependency
avant-window-navigator E: Dependency dbus-glib detected and not included (libraries ['usr/lib/libdbus-glib-1.so.2'] needed in files ['usr/bin/avant-window-navigator', 'usr/lib/awn/applets/quick-prefs/quick-prefs.so', 'usr/lib/libawn.so.1.0.1', 'usr/lib/awn/applets/simple-launcher/simple-launcher.so', 'usr/lib/awn/applets/separator/separator.so', 'usr/lib/awn/applets/expander/expander.so', 'usr/bin/awn-applet', 'usr/lib/awn/applets/taskmanager/taskmanager.so', 'usr/lib/python2.7/site-packages/awn/awn.so'])
avant-window-navigator W: Dependency included and not needed ('gconf')
avant-window-navigator W: Dependency included and not needed ('python2-dbus')
avant-window-navigator W: Dependency pygtk included but already satisfied
avant-window-navigator W: Dependency included and not needed ('python2-xdg')
avant-window-navigator W: Dependency hicolor-icon-theme included but already satisfied
avant-window-navigator W: Dependency included and not needed ('xdg-utils')

SanskritFritz commented on 2014-05-29 13:49

No problem, thanks for the heads-up. I bumped the package to make people aware.

hyness commented on 2014-05-29 13:42

Recompiling this package fixed it. I had rebuilt it during that update, but i guess it was before libgtop was updated? Anyway, thanks SanskritFritz for the help and maintaining this package.

SanskritFritz commented on 2014-05-27 21:35

hyness just rebuild the package and awn-extras-applets

All comments