Package Details: avbin 10-2

Git Clone URL: https://aur.archlinux.org/avbin.git (read-only)
Package Base: avbin
Description: Cross-platform media decoding library
Upstream URL: http://avbin.github.com/
Licenses: LGPL
Conflicts: avbin7
Submitter: SpotlightKid
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 3
Popularity: 0.289798
First Submitted: 2015-10-11 20:40
Last Updated: 2016-04-27 18:24

Dependencies (4)

Required by (4)

Sources (1)

Latest Comments

Hell-G commented on 2016-04-28 13:26

No problem, thank you very much!

SpotlightKid commented on 2016-04-28 12:54

Sorry, I have no idea. Seems like pyglet is accessing some internal data which isn't available in this version of avbin. Please report this on the pyglet mailing list or bug tracker.

Hell-G commented on 2016-04-28 11:14

Thank you very much for your fast response! Now the installation works flawlessly.

But I still have an issue with this installation compared to the binary installation from the AVbin website. I am using pyglet. With the binary AVbin version, it worked fine, whereas with the AUR package I get an error using pyglet:
File "/usr/lib/python3.5/site-packages/pyglet/media/__init__.py", line 472, in play
player.queue(self)
File "/usr/lib/python3.5/site-packages/pyglet/media/__init__.py", line 978, in queue
group.queue(source)
File "/usr/lib/python3.5/site-packages/pyglet/media/__init__.py", line 695, in queue
source = source._get_queue_source()
File "/usr/lib/python3.5/site-packages/pyglet/media/__init__.py", line 622, in _get_queue_source
return StaticMemorySource(self._data, self.audio_format)
AttributeError: 'StaticSource' object has no attribute '_data'

Do you have an idea how this could be related to AVbin?

SpotlightKid commented on 2016-04-27 18:25

There was a missing comma in a sed command used in the PKGBUILD.

There were also two other issues with checking out / building the libav submodule.

These are hopefully fixed now. Let me know, if you still have problems.

Hell-G commented on 2016-04-27 12:37

Hi! Anybody else having trouble installing this package?
I get an error about my gcc during the configure phase of the libav build part, although my gcc is working fine.

From github.com:AVbin/libav
* branch a0a5fed908a2f36d64e2b99673475d85b4c49430 -> FETCH_HEAD
Submodule path 'libav': checked out 'a0a5fed908a2f36d64e2b99673475d85b4c49430'
Cleaning up...done
gcc is unable to create an executable file.
If gcc is a cross-compiler, use the --enable-cross-compile option.
Only do this if you know what cross compiling means.
C compiler test failed.

If you think configure made a mistake, make sure you are using the latest
version from Git. If the latest version fails, report the problem to the
libav-user@libav.org mailing list or IRC #libav on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.
AVbin: Fatal error: Failed configuring backend.

Looking at the output in config.log, I think there is a syntax problem in the C compiler test:

check_cc
BEGIN /tmp/ffconf.nFPkhmsy.c
1 int main(void){ return 0; }
END /tmp/ffconf.nFPkhmsy.c
gcc -D_FORTIFY_SOURCE=2 -march=native -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -c -o /tmp/ffconf.u1xLC3ci.o /tmp/ffconf.nFPkhmsy.c
gcc ,-O1,--sort-common,--as-needed,-z,relro -o /tmp/ffconf.GJWSjGak /tmp/ffconf.u1xLC3ci.o
gcc: error: ,-O1,--sort-common,--as-needed,-z,relro: No such file or directory
C compiler test failed.

Any ideas? Thanks!