Package Details: avogadro-git 1425272470-1

Git Clone URL: https://aur.archlinux.org/avogadro-git.git (read-only)
Package Base: avogadro-git
Description: An advanced molecular editor based on Qt
Upstream URL: http://avogadro.cc/wiki/Main_Page
Licenses: GPL2
Conflicts: avogadro
Provides: avogadro
Submitter: Xyne
Maintainer: Xyne
Last Packager: Xyne
Votes: 2
Popularity: 0.000000
First Submitted: 2010-12-19 03:38
Last Updated: 2015-06-21 02:54

Latest Comments

berquist commented on 2016-10-06 17:24

Can you update the PKGBUILD with the latest changes from extra/avogadro? There are two new patches that are applicable here as well.

Xyne commented on 2015-03-06 00:45

From the Avogadro 2 Git page:

Avogadro 2 is being developed as part of the Open Chemistry project at Kitware, along with companion tools and libraries to support the work. The Avogadro 1.x series currently has more features, and can be found here. We will be porting more features to the Avogadro 2 code base, and making regular releases to get feedback from the community.

Until Avogadro 2 becomes the main version this package should pull sources from the 1.x repo.

Feel free to upload avogadro2-git in the meantime. It can replace this package later.

apol commented on 2015-03-05 01:52

Now it's hosted in github and ported to Qt5. Please update!

https://github.com/OpenChemistry/avogadrolibs

Xyne commented on 2014-02-04 23:21

@hseara
I don't remember why I explicitly used mesa-libgl. It was probably specified in the build instructions somewhere and I didn't realize that there were other providers. I have replaced "mesa-libgl" with "libgl".

hseara commented on 2014-02-04 14:43

Is there any reason why you have in the depends array specifically mesa-libgl? I'm using nvidia-libgl instead and works fine. Why you do not substitute mesa-libgl by just libgl. Then the user can choose freely his backend library.

yuyichao commented on 2013-03-03 21:40

QT_QMAKE_EXECUTABLE

Xyne commented on 2012-12-07 22:22

updated, thanks

goetzc commented on 2012-12-07 17:56

The dependencies have to be updated. Take a look at https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/avogadro

depends=('eigen2' 'openbabel' 'python2-pyqt' 'boost-libs' 'glew' 'python2-numpy')
makedepends=('cmake' 'boost' 'doxygen')

Xyne commented on 2011-05-20 23:45

The new version doesn't build. It fails when trying to build the bsdyengine static plugin. Even if I disable the plugin in the options it still fails. I've used pkgfile to search for the missing header but it couldn't it in any repo package.

I've pastebinned an updated PKGBUILD: http://pastebin.com/ZSzHJbC7
If you find a way to get it working, either by locating "ui_bsdysettingswidget.h" or by disabling bsdyengine, let me know how and I will update the package.

This may just be a transient GIT error that will fix itself soon. I'll ask the maintainer of the avogadro package in the repos about this, and then maybe send an email upstream if no solution has been found by then.

vit commented on 2011-05-19 16:34

And remove the patches.

vit commented on 2011-05-19 16:33

Please update the git path to https://github.com/cryos/avogadro.git