Package Details: awesome-revelation-git 2016.05.18.g79525e9-1

Git Clone URL: (read-only)
Package Base: awesome-revelation-git
Description: Show all clients per screen in Awesome window manager. It works for both stable and master version of Awesome.
Upstream URL:
Licenses: GPL3
Conflicts: awesome-revelation
Submitter: seblu
Maintainer: guotsuan
Last Packager: guotsuan
Votes: 12
Popularity: 0.023403
First Submitted: 2012-06-13 23:09
Last Updated: 2016-06-15 18:07

Latest Comments

FMB commented on 2015-10-02 19:48

Thanks guotsuan, I don't get these errors anymore.

guotsuan commented on 2015-09-28 14:26

Or just update to newer version of package. I updated the codes to cope with the problem

guotsuan commented on 2015-09-28 14:10


I think the error caused by the variable, beautiful.fg_normal is not set.

First, could you check if you have awesome lua package 'beautiful' by run command 'locate beautiful/init.lua'. I guess you should have this package.
Also check if you include it in your rc.lua such like

local beautiful = require("beautiful")

Then, you can check if you include a theme in your rc.lua by
Usually you will included one, but it is not necessary.
But after you include a theme for your awesome. beautiful.fg_normal should
be taken care by the theme.

If you do not want to include a theme.
you can also add a line before revelation.init() to specify the color used
by beautiful.fg_normal, for example:

local beautiful = require('beautiful')

beautiful.fg_normal = #DCDCCC


FMB commented on 2015-09-28 13:41

I get these errors at startup (Awesome v3.5.6):

/usr/share/awesome/lib/revelation/init.lua:350: attempt to concatenate a nil value (field 'fg')

error while running the function
stack traceback:
/usr/share/awesome/lib/revelation/init.lua:350: in function 'revelation.init'
/home/XXX/.config/awesome/rc.lua:44: in main chunk
error: /usr/share/awesome/lib/revelation/init.lua:350: attempt to concatenate a nil value (field 'fg')

[line 44 in rc.lua contains "revelation.init()"]

guotsuan commented on 2015-09-27 15:05

Thanks @xduugu for the reminding. The PKGBUILD has been updated.

xduugu commented on 2015-09-27 11:15

Also it says that it was merged with awesome-revelation, it still depends only on awesome-git.

scholi commented on 2014-09-04 08:33

My mistake. I forgot the "revelation.init()"

scholi commented on 2014-09-04 08:30

works only for awesome < 3.5? I got some error for my part with awesome 3.5

W: awesome: luaA_dofunction:77: error while running function
stack traceback:
/usr/share/awesome/lib/revelation/init.lua:166: in function </usr/share/awesome/lib/revelation/init.lua:124>
(...tail calls...)
/usr/share/awesome/lib/awful/key.lua:42: in function </usr/share/awesome/lib/awful/key.lua:42>
error: /usr/share/awesome/lib/revelation/init.lua:166: attempt to index field '?' (a nil value)

scholi commented on 2014-09-04 08:21

works only for awesome < 3.5? I got some error for my part.

scholi commented on 2014-09-04 08:21

works only for awesome > 3.5? I got some error for my part.

All comments