Package Details: awesome-themes-git 20131121-2

Git Clone URL: https://aur.archlinux.org/awesome-themes-git.git (read-only)
Package Base: awesome-themes-git
Description: Theme Collection for AwesomeWM, updated for 3.5.2. This is the successor of awesome34-themes-git
Upstream URL: https://github.com/mikar/awesome-themes
Licenses: GPL
Submitter: serialoverflow
Maintainer: serialoverflow
Last Packager: serialoverflow
Votes: 77
Popularity: 1.590300
First Submitted: 2011-06-17 13:51
Last Updated: 2015-06-11 14:33

Dependencies (2)

Required by (0)

Sources (0)

Latest Comments

serialoverflow commented on 2013-11-22 19:28

i pushed some fixed today, everything should work now

Antunes commented on 2013-11-22 10:08

Hi mikar, thanks for the updating. Works for me except the theme powerarrow-darker. There is a problem in that the file /lib/gears/surface links to wall.png in the home directory instead the file in the /usr/share/awesome directory.

serialoverflow commented on 2013-11-21 17:23

updated for 3.5

serialoverflow commented on 2013-11-11 14:52

had a long linux-break. i'm in the process of making the switch to awesome 3.5 this week and will update all configs and gits, including this one. until then, this still works well with awesome 3.4.

ogasser commented on 2013-08-05 21:10

What about updating this PKGBUILD to point to a repository with themes [1] for the current awesome version in Arch (3.5)?

[1] https://github.com/Morley93/awesome-themes-3.5

tdy commented on 2013-02-27 01:37

gigamo is just empty.. apparently it's supposed to be a submodule, but the submodule mapping is missing or something.

I don't know about those other 2 themes. Keep in mind that these are just a collection of other people's themes that mikar put together. By the looks of it, the person who made the dwm theme used an *extremely* minimal setup because there's almost nothing defined in his/her theme.

The only theme I have any association with is dust, and the one here is already old.

Antunes commented on 2013-02-25 14:14

OK, I changed the gitroot and still have some problems:

1) the theme blue has no menu icon
2) the theme dwm has no layout icons (they simply don't show in the system bar)
3) the theme gigamo still has the old error messages.

tdy commented on 2013-02-24 03:10

Well you can just change the gitroot yourself on line 12:

_gitroot=https://github.com/tdy/awesome-themes

Antunes commented on 2013-02-23 21:14

Thanks for your help. I will try again after this package is updated in AUR. Basically, I wanted to say with my comments that the themes work in my awesome install and should be ready to be ported and replace the old ones (in AUR).

tdy commented on 2013-02-23 19:22

Oh I see the problem. You said you copied the repo to your home folder. That's fine, but that's not how this package was meant to be installed.

If you want to do a local installation, you'll also have to manually copy /usr/share/awesome/themes and /usr/share/awesome/icons to your home folder, but those files can't be added to the repo since that would break the normal way of installation (via makepkg/PKGBUILD).

tdy commented on 2013-02-23 19:13

/usr/share/awesome/themes/default comes with all awesome installations. It's the theme that is used out of the box when you first install awesome. Including it here would only cause file conflicts between awesome and awesome-themes and break the installation.

If your /usr/share/awesome/themes folder doesn't already have the 3 bundled themes (sky, default, zenburn) then something else happened to your base awesome installation. Same with /usr/share/awesome/icons.

Antunes commented on 2013-02-23 12:45

For example, theme blue has the line

wallpaper4 = sharedthemes .. "/default/background.png"

default refers to a "default" directory which should be present in /usr/share/awesome/themes/default but is currently not in your fork.

That is why some icons were missing for me, e.g. the menu icon is often missing but I can fix that by placing the relevant png file in the relevant theme directory.

Antunes commented on 2013-02-23 12:45

For example, theme blue has the line

wallpaper4 = sharedthemes .. "/default/background.png"

default refers to a "default" directory which should be present in /usr/share/awesome/themes/default but is currently not in your fork.

That is why some icons were missing for me, e.g. the menu icon is often missing but I can fix that by playing the relevant png file in the theme directory.

tdy commented on 2013-02-22 23:46

I'm not sure what you mean. Which default folder exactly? There shouldn't be any changes to directories. I just forked the repo (so it should be an exact mirror) and edited some text.

Antunes commented on 2013-02-20 15:59

Thanks for your work tdy. I copied the themes to my home directory and they all work without errors.

But I did have some trouble with some missing icons. One reason seems to be that the old directory structure had a "default" folder containing some important icons.

Antunes commented on 2013-02-20 15:53

Thanks for your work tdy. I copied the themes to my home directory and they all work without errors.

But I did have some trouble with some missing icons. One reason seems to be that the old directory structure had a "default" folder containing some important icons.

tdy commented on 2013-02-17 01:30

I forked the repo and made the aforementioned changes.. not really tested, but everything "should" work:

_gitroot=https://github.com/tdy/awesome-themes

scorpio commented on 2013-01-04 23:50

This quote explains the changes
"In Lua 5.2, the module() function was deprecated. This has an effect on user configs. You now have to explicitely assign modules to variables when you load them:
naughty = require("naughty")" - from "http://awesome.naquadah.org/wiki/Awesome_3.4_to_3.5" section "2. Lua 5.2 Compatibility "

In theme.lua replace this row:
require("awful.util")
with this
local awful = require("awful")
and will not be displayed error

and which meet
theme.wallpaper_cmd = {"awsetbg" .. <your wallpaper paht>}
replace it with
theme.wallpaper = <your wallpaper paht>

Antunes commented on 2013-01-02 16:20

Does anybody know why these themes no longer work with awesome 3.5?

I get an error of the form:

"/usr/share/awesome/lib/awful/util.lua:46: attempt to index local 'color' (a nil value)"

Antunes commented on 2013-01-02 16:19

Does anybody know why these themes no longer work with awesome 3.5?

I get an error of the form:

"/usr/share/awesome/lib/awful/util.lua:46: attempt to index local 'color' (a nil value)

Antunes commented on 2012-10-28 11:42

OK, I realized now that 8 digit color codes include the first two digits for transparency. But I still get occasional "cannot allocate color" errors with the 8 digits. Sorry for the confusion.

Antunes commented on 2012-10-28 11:28

Thanks for the great packages.

There is a small bug in theme "dust". The line

theme.bg_normal = "#22222200"

contains an incorrect color code. (Probly it should be #222200 which fits much nicer than #222222.)

Anonymous comment on 2011-08-10 12:39

W: awesome: image_new_from_file:288: cannot load image /usr/share/awesome/themes/dunz0r/taglist/squareza.png: no such file or directory

The dunz0r theme is looking for the wrong directory. In the repository the directory is called dunzor, but it should be dunz0r. Yeah and thanks for the effort in putting this together.

vkumar commented on 2011-07-21 12:51

This is a fantastic collection. The git repo has valuable screenshots as well. There aren't nearly enough votes for you, sir! Thanks for the package.