Package Details: azure-cli 2.29.0-1

Git Clone URL: https://aur.archlinux.org/azure-cli.git (read-only, click to copy)
Package Base: azure-cli
Description: Command-line tools for Azure.
Upstream URL: https://github.com/Azure/azure-cli
Licenses: MIT
Conflicts: python-azure-cli
Submitter: pallxk
Maintainer: pallxk
Last Packager: pallxk
Votes: 28
Popularity: 1.31
First Submitted: 2019-12-30 09:10
Last Updated: 2021-10-12 08:02

Required by (3)

Sources (3)

Latest Comments

1 2 Next › Last »

cake808 commented on 2021-10-10 07:58

I'm running into version issues :/

==> Starting pkgver()...
==> ERROR: pkgver is not allowed to be empty.
==> ERROR: pkgver() generated an invalid version:
 -> error making: azure-cli

armadillo commented on 2021-04-14 07:27

Thank you @pallxk @djjlewis

pallxk commented on 2021-04-14 00:13

@armadillo, @djjlewis, I've just updated the sha256sum of install-2.22.0.py in PKGBUILD. The file is indeed updated upstream. Check the history of install.py at https://github.com/Azure/azure-cli/commits/dev/scripts/curl_install_pypi/install.py

djjlewis commented on 2021-04-13 14:20

@armadillo looks like the sha for install-2.22.0.py is incorrect in PKGBUILD. If you're feeling brave you can compute the sha yourself on the local file using sha256sum install-2.22.0.py and update the first entry in the sha256sums variable in PKGBUILD (line 16) then run makepkg -si to install manually.

armadillo commented on 2021-04-13 13:28

Currently getting a validation error for 2.22.0-1 as follows: -

==> Making package: azure-cli 2.22.0-1 (Tue 13 Apr 2021 14:26:23 BST)
==> Retrieving sources...
-> Found install-2.22.0.py
-> Found install.response
-> Found az
==> Validating source files with sha256sums...
install-2.22.0.py ... FAILED
install.response ... Passed
az ... Passed
==> ERROR: One or more files did not pass the validity check!
:: Packages failed to build: azure-cli-2.22.0-1

acascais commented on 2021-01-25 09:42

Hello.

edit: restarting the router solved the problem :|

I'm trying to upgrade the azure-cli and I also had the problem with Python. I did what djjlewis recommended (uninstall, remove folders and installed again) but I see the installer stuck:

-- Downloading virtualenv package from https://pypi.python.org/packages/source/v/virtualenv/virtualenv-16.7.7.tar.gz.

I tried to curl this endpoint and I get a "moved permanently":

$ curl https://pypi.python.org/packages/source/v/virtualenv/virtualenv-16.7.7.tar.gz
<html><head><title>301 Moved Permanently</title></head><body><center><h1>301 Moved Permanently</h1></center></body></html>

Is it possible that the installer is not following the redirection correctly?

djjlewis commented on 2020-12-04 15:52

To fix the error while loading shared libraries: libpython3.8.so.1.0: cannot open shared object file: No such file or directory issue below, I removed the package, deleted the cache and re-installed e.g

$ yay -Rns azure-cli
$ rm -rf ~/.cache/yay/azure-cli
$ yay -S azure-cli

felipebalbi commented on 2020-12-04 08:56

After an upgrade today, python switched to 3.9 and azure-cli doesn't work anymore:

$ az help
/opt/azure-cli/bin/python: error while loading shared libraries: libpython3.8.so.1.0: cannot open shared object file: No such file or directory

jlohr commented on 2020-11-30 09:20

I get these warnings when installing. Will the package still work?:

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

pyopenssl 20.0.0 requires cryptography>=3.2, but you'll have cryptography 2.9.2 which is incompatible.
azure-cli-core 2.15.1 requires azure-mgmt-core==1.2.1, but you'll have azure-mgmt-core 1.2.2 which is incompatible.

enihcam commented on 2020-11-16 09:32

/opt/azure-cli/lib/python3.8/site-packages/requests/init.py:89: RequestsDependencyWarning: urllib3 (1.26.0) or chardet (3.0.4) doesn't match a supported version! warnings.warn("urllib3 ({}) or chardet ({}) doesn't match a supported "