Package Details: babashka-bin 0.8.2-1

Git Clone URL: https://aur.archlinux.org/babashka-bin.git (read-only, click to copy)
Package Base: babashka-bin
Description: A Clojure babashka for the grey areas of Bash.
Upstream URL: https://github.com/borkdude/babashka
Licenses: EPL
Conflicts: babashka
Provides: babashka
Submitter: dharrigan
Maintainer: dharrigan
Last Packager: dharrigan
Votes: 6
Popularity: 0.019799
First Submitted: 2019-11-21 09:34 (UTC)
Last Updated: 2022-05-06 13:55 (UTC)

Latest Comments

Kribbstar commented on 2022-04-15 13:59 (UTC)

Hi

I had to change the sha256sum when installing v 0.8.0 on aarch64. From: 0d722412b57b281e905cfca6e4d231585715718a8531f2ca0e51b431803b805a To: 4ed5c9c4ef6a2b93537a42375c8fd36bf94a0680d40db27814ece9c21e5de43b

dharrigan commented on 2021-10-29 19:44 (UTC)

Hey!

No worries! I'm very happy that you managed to figure it out and get it working for you :-) Thank you also for your kind comments about the maintainership. I hope you're finding babashka useful like I am! :-)

-=david=-

j0ni commented on 2021-10-29 15:31 (UTC)

@dharrigan thanks for getting back to me. This was my own oversight - I've been distribution touring for the last month or so (some downtime) and had built my own bb and installed it in ~/.local/bin while I was messing with Silverblue like 3 linuxes ago. I didn't even check the path of the bb, let alone ask the linker, which is also shameful.

All this to say I'm sorry for the noise, and any related cognitive load I may have caused. It's not you, it's me!

Thanks for maintaining this package, and cheers.

dharrigan commented on 2021-10-27 21:06 (UTC)

Hi!

Thank you for your comment. This is most strange, as yes, if it was a serious issue more people would be reporting it. I've installed a fresh version of the current arch distro (amd64) and installed babashka-bin. I was able to run the program without any issues.

[root@arch ~]# bb
Babashka v0.6.2 REPL.
Use :repl/quit or :repl/exit to quit the REPL.
Clojure rocks, Bash reaches.

user=>

Do you have base-devel installed? Also, what is the output of ldd?

[root@arch ~]# ldd /usr/sbin/bb
linux-vdso.so.1 (0x00007fff4d3e6000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fee5b3c8000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007fee5b3ae000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fee5b38d000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fee5b386000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007fee5b1ba000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007fee5b076000)
/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007fee60f00000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fee5b059000)

j0ni commented on 2021-10-27 19:48 (UTC)

On a freshly installed Arch system, updated, I am seeing this:

bb: /usr/lib/libc.so.6: version `GLIBC_2.34' not found (required by bb)

Seems like I shouldn't be the only one here seeing this, it's pretty serious :)

dharrigan commented on 2021-08-26 12:43 (UTC)

Thank you for your contribution :-) Pushed.

crodjer commented on 2021-08-26 12:12 (UTC)

Sent :-)

dharrigan commented on 2021-08-26 09:15 (UTC) (edited on 2021-08-26 09:18 (UTC) by dharrigan)

Sure, send me a patch file directly :-) My email should be deducible from the PKGBUILD :-)

crodjer commented on 2021-08-26 09:09 (UTC)

Could you add support for the aarch64? This will allow me to use it on my RPi Manjaro:

diff --git a/PKGBUILD b/PKGBUILD
index a8a22ab..7bd90ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=babashka-bin
 pkgver=0.5.1
 pkgrel=1
 pkgdesc='A Clojure babashka for the grey areas of Bash.'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
 url='https://github.com/borkdude/babashka'
 license=('EPL')
 depends=('gcc-libs' 'zlib')
@@ -12,8 +12,10 @@ provides=("${pkgname%-bin}")
 conflicts=("${pkgname%-bin}")

 source_x86_64=("${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux-amd64.tar.gz")
+source_aarch64=("${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux-aarch64-static.tar.gz")

 sha256sums_x86_64=('bfd6e39f068fecfc9d0197daf78615b334cc93635056d92d329fd89ce2106b28')
+sha256sums_aarch64=('a7c07f60cd830eba593b7b4801c59976db9596785dbb648e6a297f5a5156e245')

 package() {
   install -Dm755 "${srcdir}/bb" "${pkgdir}/usr/bin/bb"