Package Details: backblaze-b2 3.13.0-1

Git Clone URL: https://aur.archlinux.org/backblaze-b2.git (read-only, click to copy)
Package Base: backblaze-b2
Description: Backblaze B2 Command Line Client
Upstream URL: https://github.com/Backblaze/B2_Command_Line_Tool
Keywords: archive backblaze backup cloud storage
Licenses: MIT
Submitter: 2bluesc
Maintainer: 2bluesc
Last Packager: 2bluesc
Votes: 24
Popularity: 0.011356
First Submitted: 2015-10-29 06:31 (UTC)
Last Updated: 2024-05-28 14:38 (UTC)

Latest Comments

1 2 3 4 5 Next › Last »

larsch commented on 2023-05-18 07:05 (UTC)

Missing dependency on 'python-argcomplete'

2bluesc commented on 2023-02-22 17:17 (UTC)

@intelfx updates applied. Btw, your patch was missing the referenced patch file.

Thanks for sharing!

intelfx commented on 2023-02-22 14:43 (UTC)

Similar to python-b2sdk, this does not build due to requiring an old setuptools_scm and PKGBUILD not adhering to PEP 517.

Please apply: http://ix.io/4oTS

Archist commented on 2022-10-09 22:42 (UTC) (edited on 2022-10-09 22:53 (UTC) by Archist)

The python-tabulate package in arch was updated to version 0.9.0 on October 6th, but the upstream backblaze repo is still pointing to version 0.8.10, causing this program to fail on import.

Traceback (most recent call last):)
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 581, in _build_master)
    ws.require(__requires__))
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 909, in require)
    needed = self.resolve(parse_requirements(requirements)))
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 800, in resolve)
    raise VersionConflict(dist, req).with_context(dependent_req))
pkg_resources.ContextualVersionConflict: (tabulate 0.9.0 (/usr/lib/python3.10/site-packages), Requirement.parse('tabulate==0.8.10'), {'b2'}))

There is an open PR on the upstream to bump the version.

Artemis commented on 2022-03-17 10:31 (UTC) (edited on 2022-03-17 10:32 (UTC) by Artemis)

The following patch updates the version to 3.2.1 and also points the download to github:

diff --git a/PKGBUILD b/PKGBUILD
index c27d11c..cf3b7d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@

 pkgname=backblaze-b2
 _pkgname=b2
-pkgver=3.1.0
+pkgver=3.2.1
 pkgrel=1
 pkgdesc='Backblaze B2 Command Line Client'
 url='https://github.com/Backblaze/B2_Command_Line_Tool'
@@ -23,8 +23,8 @@ makedepends=('python-pip'
 license=('MIT')
 arch=('any')

-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('411232733599a7553bd146e842e84b15530712aead26d71ff68b81fec754d62b')
+source=("https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('351bf1c26b6147edce4245d09fc0b608b10d3665cf4358bd3ebdb40318b6e562')

 build() {
     cd ${srcdir}/${_pkgname}-${pkgver}

Hoek commented on 2022-01-15 23:20 (UTC)

@2bluesc thank you, that helped!

2bluesc commented on 2022-01-15 16:44 (UTC)

@Hoek you probably need to rebuild your AUR packages built against Python 3.9 after installing 3.10:

pacman -Qoq /usr/lib/python3.9
yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

Or something similar.

Hoek commented on 2021-12-31 14:30 (UTC)

Current version fails to run:

Traceback (most recent call last):
  File "/bin/backblaze-b2", line 33, in <module>
    sys.exit(load_entry_point('b2==3.1.0', 'console_scripts', 'b2')())
  File "/bin/backblaze-b2", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 919, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 518, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for b2

Kage-Yami commented on 2021-07-08 10:29 (UTC) (edited on 2021-07-08 10:33 (UTC) by Kage-Yami)

Looks like while the last issue I reported has been resolved, we've had a regression with the setuptools_scm dependency - this is back to failing to build in environments without pip, similar to what was happening back in April, as it looks like the requirement of <6.0 was removed in the last AUR update, without also patching out the requirement from the source code.

samhh commented on 2021-07-03 11:19 (UTC)

Is anyone else finding that as of 2.5.0 of this package Duplicity isn't working with Backblaze?

BackendException: Could not initialise backend: No module named 'b2sdk.download_dest'