Package Details: backblaze-b2 4.0.3-2

Git Clone URL: (read-only, click to copy)
Package Base: backblaze-b2
Description: Backblaze B2 Command Line Client
Upstream URL:
Keywords: archive backblaze backup cloud storage
Licenses: MIT
Submitter: 2bluesc
Maintainer: 2bluesc
Last Packager: 2bluesc
Votes: 24
Popularity: 0.006295
First Submitted: 2015-10-29 06:31 (UTC)
Last Updated: 2024-06-26 16:17 (UTC)

Latest Comments

1 2 3 4 5 6 Next › Last »

qlyoung commented on 2024-06-25 20:08 (UTC)

This is missing a build dependency on python-pdm-backend.

TankieTanuki commented on 2024-06-17 02:39 (UTC)

What happened here?

WARNING setuptools_scm.pyproject_reading toml section missing 'pyproject.toml does not contain a tool.setuptools_scm section'
Traceback (most recent call last):
  File "/usr/lib/python3.12/site-packages/setuptools_scm/_integration/", line 36, in read_pyproject
    section = defn.get("tool", {})[tool_name]

larsch commented on 2023-05-18 07:05 (UTC)

Missing dependency on 'python-argcomplete'

2bluesc commented on 2023-02-22 17:17 (UTC)

@intelfx updates applied. Btw, your patch was missing the referenced patch file.

Thanks for sharing!

intelfx commented on 2023-02-22 14:43 (UTC)

Similar to python-b2sdk, this does not build due to requiring an old setuptools_scm and PKGBUILD not adhering to PEP 517.

Please apply:

Archist commented on 2022-10-09 22:42 (UTC) (edited on 2022-10-09 22:53 (UTC) by Archist)

The python-tabulate package in arch was updated to version 0.9.0 on October 6th, but the upstream backblaze repo is still pointing to version 0.8.10, causing this program to fail on import.

Traceback (most recent call last):)
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 581, in _build_master)
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 909, in require)
    needed = self.resolve(parse_requirements(requirements)))
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 800, in resolve)
    raise VersionConflict(dist, req).with_context(dependent_req))
pkg_resources.ContextualVersionConflict: (tabulate 0.9.0 (/usr/lib/python3.10/site-packages), Requirement.parse('tabulate==0.8.10'), {'b2'}))

There is an open PR on the upstream to bump the version.

Artemis commented on 2022-03-17 10:31 (UTC) (edited on 2022-03-17 10:32 (UTC) by Artemis)

The following patch updates the version to 3.2.1 and also points the download to github:

diff --git a/PKGBUILD b/PKGBUILD
index c27d11c..cf3b7d1 100644
@@ -2,7 +2,7 @@

 pkgdesc='Backblaze B2 Command Line Client'
@@ -23,8 +23,8 @@ makedepends=('python-pip'


 build() {
     cd ${srcdir}/${_pkgname}-${pkgver}

Hoek commented on 2022-01-15 23:20 (UTC)

@2bluesc thank you, that helped!

2bluesc commented on 2022-01-15 16:44 (UTC)

@Hoek you probably need to rebuild your AUR packages built against Python 3.9 after installing 3.10:

pacman -Qoq /usr/lib/python3.9
yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

Or something similar.

Hoek commented on 2021-12-31 14:30 (UTC)

Current version fails to run:

Traceback (most recent call last):
  File "/bin/backblaze-b2", line 33, in <module>
    sys.exit(load_entry_point('b2==3.1.0', 'console_scripts', 'b2')())
  File "/bin/backblaze-b2", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.10/importlib/metadata/", line 919, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.10/importlib/metadata/", line 518, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for b2