Package Details: balena-etcher 1:1.5.61-1

Git Clone URL: https://aur.archlinux.org/balena-etcher.git (read-only)
Package Base: balena-etcher
Description: Flash OS images to SD cards & USB drives, safely and easily
Upstream URL: https://etcher.io
Licenses: Apache
Conflicts: etcher, etcher-bin, etcher-git
Submitter: gin078
Maintainer: gin078 (imrehg)
Last Packager: gin078
Votes: 173
Popularity: 2.53
First Submitted: 2019-05-13 11:35
Last Updated: 2019-11-06 13:14

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

Krychek commented on 2019-02-18 15:00

Replying to myself... I'm using antergos and they have their own version that shadows this one. Running yaourt etcher let me choose this package instead of the default one.

Krychek commented on 2019-02-18 14:58

I have just installed this package, but the version I got is 1.4.4 instead of 1.4.9. Could you someone else verify this?

haavard commented on 2019-01-27 16:38

medicineman25: this doesn't seem like a packaging issue, and I can't reproduce it. Seems likely something about your network setup is off.

medicineman25 commented on 2019-01-27 08:21

Getting this error:

npm WARN tarball tarball data for simple-progress-webpack-plugin@https://registry.npmjs.org/simple-progress-webpack-plugin/-/simple-progress-webpack-plugin-1.1.2.tgz (sha512-bNQfb3qSqbtsfxg6d0dGechUUJH2lZqKG5+bj2aoJmEA0rSzcm+2JVfC2YgkDABfuGItZ/O5ttt6BssWZW4SNg==) seems to be corrupted. Trying one more time. npm WARN tarball tarball data for angular@https://registry.npmjs.org/angular/-/angular-1.6.3.tgz (sha512-GEr8LYsE0pXmryfZj7wlmV3+yAqoPt6slcuklJG7vLqNBBAH6A/N2Kc1O5SR2dnaUwIWOJHRlh2Ajlnimlf//A==) seems to be corrupted. Trying one more time. npm WARN tarball tarball data for @fortawesome/fontawesome-free-webfonts@https://registry.npmjs.org/@fortawesome/fontawesome-free-webfonts/-/fontawesome-free-webfonts-1.0.9.tgz (sha512-nLgl6b6a+tXaoJJnSRw0hjN8cWM/Q5DhxKAwI9Xr0AiC43lQ2F98vQ1KLA6kw5OoYeAyisGGqmlwtBj0WqOI5Q==) seems to be corrupted. Trying one more time. npm WARN tarball tarball data for ajv@https://registry.npmjs.org/ajv/-/ajv-5.5.2.tgz (sha512-Ajr4IcMXq/2QmMkEmSvxqfLN5zGmJ92gHXAeOXq1OekoH2rfDNsgdDoL2f7QaRCy7G/E6TpxBVdRuNraMztGHw==) seems to be corrupted. Trying one more time. npm WARN tarball tarball data for rabin-bindings@https://registry.npmjs.org/rabin-bindings/-/rabin-bindings-1.7.4.tgz (sha512-4Ml+Hsw1asNttafMFF+GWgGOcZs9nJk7qb3GE9eyihMUOrxFVcKeKcfeCncTSIPYsfWNvdf4yc0GGbHPUiQYjg==) seems to be corrupted. Trying one more time. npm WARN tarball tarball data for showdown@https://registry.npmjs.org/showdown/-/showdown-1.9.0.tgz (sha512-x7xDCRIaOlicbC57nMhGfKamu+ghwsdVkHMttyn+DelwzuHOx4OHCVL/UW/2QOLH7BxfCcCCVVUix3boKXJKXQ==) seems to be corrupted. Trying one more time. npm WARN tarball tarball data for eslint@https://registry.npmjs.org/eslint/-/eslint-2.13.1.tgz (sha512-29PFGeV6lLQrPaPHeCkjfgLRQPFflDiicoNZOw+c/JkaQ0Am55yUICdYZbmCiM+DSef+q7oCercimHvjNI0GAw==) seems to be corrupted. Trying one more time. npm WARN tarball tarball data for 7zip-bin-linux@~1.3.1 (sha512-Wv1uEEeHbTiS1+ycpwUxYNuIcyohU6Y6vEqY3NquBkeqy0YhVdsNUGsj0XKSRciHR6LoJSEUuqYUexmws3zH7Q==) seems to be corrupted. Trying one more time.

haavard commented on 2019-01-23 19:17

Yes, it requires electron2. This is in the official repos, so that should not be a problem.

For the app menu, this package installs virtually the same .desktop file as the upstream package. Can you verify that /usr/share/applications/etcher-electron.desktop exists and is owned by this package?

abdulhakeem commented on 2019-01-23 03:47

This doesn't seem to work... it requires electron2, so I have both electron2 and electron3 installed on my system, and then once you install etcher, it doesn't actually appear anywhere. In GNOME, it's completely absent from the app menu, so there's no way to actually launch and use it. Uninstalling, seeing if maybe the etcher-bin package is any different. This worked fine for years up until like 2-3 months ago, idk what happened.

astro commented on 2018-12-05 07:59

Hi, I have a npm error with the last update : Trying to find linux-electron-2.0.12-x64-3b7f564fa3af27bd500b351171c102d3b5117f3858c530d30196b9959c2dac0a.tar.gz... Rebuilding native modules Installing dependencies npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but npm-shrinkwrap.json was generated for lockfileVersion@0. I'll try to do my best with it! npm ERR! code E418 npm ERR! 418 I'm a teapot: @fortawesome/fontawesome-free-webfonts@https://registry.npmjs.org/@fortawesome/fontawesome-free-webfonts/-/fontawesome-free-webfonts-1.0.9.tgz

I'm a Teapot !?? 418 ?? The URL "https://registry.npmjs.org/@fortawesome/fontawesome-free-webfonts/-/fontawesome-free-webfonts-1.0.9.tgz" is correct.

imrehg commented on 2018-11-19 09:56

@haavard see my comment below, for the AWS_ACCESS_KEY needs make electron-develop -i, and that is not make -i, but the flag to "do not upload cache" https://github.com/balena-io/scripts/blob/8baa9e9a4063edc0b597baf16e266e28ed460b94/shared/npm-install.sh#L44

haavard commented on 2018-11-18 17:37

For the error AWS_ACCESS_KEY_ID, this is due to a bug in the Etcher build system (issue submitted here). Temporary workarounds are to make the aws command unavailable (e.g. uninstall aws-cli or build in a chroot).

Additionally, npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but npm-shrinkwrap.json was generated for lockfileVersion@0. I'll try to do my best with it! is not an error, just a warning, and can be ignored.

haavard commented on 2018-11-18 17:36

imrehg: make -i simply tells make to ignore errors, which may coincidentally make Etcher build in this case, but can't be enabled in general at a package level.