Package Details: banshee 2.6.2-14

Git Clone URL: https://aur.archlinux.org/banshee.git (read-only)
Package Base: banshee
Description: Music management and playback for GNOME
Upstream URL: http://banshee.fm/
Licenses: MIT
Submitter: nicman23
Maintainer: nicman23
Last Packager: nicman23
Votes: 36
Popularity: 0.316015
First Submitted: 2016-11-21 08:19
Last Updated: 2017-12-10 11:06

Pinned Comments

nicman23 commented on 2019-03-21 15:38

to prevent future out of date flags: if you want 2.9.x go to banshee-git.

2.9.x tags from gnome are non usable.

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

zekt commented on 2017-06-14 20:59

Crash on startup. Downgrade mono to 4.6.1 fix the issue, hope someone could look into it.

nicman23 commented on 2017-05-04 05:46

@JohnRobson taglib-sharp-git is needed to get the id tags (or whatever they are called) from flac and opus files.

I only use flac and opus.. (and speex if i have to)

JohnRobson commented on 2017-05-03 22:15

taglib-sharp-git and taglib-sharp are in conflict. Please use taglib-sharp.

ente commented on 2017-04-30 07:41

build fails on youtube:
Making all in Banshee.YouTube
MCS ../../../bin/Banshee.YouTube.dll
error CS0009: Metadata file `/usr/lib/mono/GData-Sharp/Google.GData.Client.dll' does not contain valid metadata
error CS0009: Metadata file `/usr/lib/mono/GData-Sharp/Google.GData.Extensions.dll' does not contain valid metadata
error CS0009: Metadata file `/usr/lib/mono/GData-Sharp/Google.GData.YouTube.dll' does not contain valid metadata
Compilation failed: 3 error(s), 0 warnings


removing Youtube from the makefile fixes the error (run makepkg with -e so ur changes dont get overwritten)

JohnRobson commented on 2017-04-28 01:43

FIXME: banshee: installing libsoup (2.58.0-1) breaks dependency 'libsoup-gnome'

Just-Punk commented on 2017-04-25 06:09

I have the same (rusinsr commented on 2017-04-24 20:37) dependency problem.
I deleted aur/banshee via pacman in usual way.
And after in beginning of banshee creating' package I have changed its deps in PKGBUILD:
libsoup-gnome -----> libsoup
taglib-sharp-git -----> taglib-sharp
----
Thanx to rusinsr.

rusinsr commented on 2017-04-24 20:37

After some recent gnome updates I managed to install banshee by replacing the libsoup-gnome dependency with simply libsoup, and changed taglib-sharp-git dependency to taglib-sharp. (I still have that one mono package set to never update in my Pacman config, so that is also still a problem)

nicman23 commented on 2017-04-09 11:08

one possible solution is to have mono 4.6 in /opt and run banshee from that.

nicman23 commented on 2017-04-09 09:35

yeah me too, i am going to periodically look at ubuntu's / debian's patches for banashee. if you find anything useful, please mail me

fromthevoid commented on 2017-04-08 00:05

So bummed that nobody maintains my favorite audio player.